Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » WindowBuilder » WindowBuilder Issue
icon4.gif  WindowBuilder Issue [message #861607] Sat, 28 April 2012 16:48 Go to next message
Hans Mueller is currently offline Hans MuellerFriend
Messages: 28
Registered: April 2012
Junior Member
Hey Guys,
i have a little problem with my windowbuilder, im using eclipse 3.7

when im using the design mode windowbuilder shows this preview:
http://desmond.imageshack.us/Himg213/scaled.php?server=213&filename=bsp2om.png&res=landing

but when i run the program it looks like this:
http://desmond.imageshack.us/Himg233/scaled.php?server=233&filename=bsp1.png&res=landing


can anybody help me?
Re: WindowBuilder Issue [message #863412 is a reply to message #861607] Sun, 29 April 2012 12:47 Go to previous messageGo to next message
Eric Clayberg is currently offline Eric ClaybergFriend
Messages: 884
Registered: July 2009
Location: Boston, MA
Senior Member
In the first picture, it looks like you are using Swing and viewing it with the WIndows look and feel. In the second picture, it looks like you are running it using the default look and feel. This is entirely expected behavior depending on the settings you have in place and the LAF you have set up (or not) for your program.
Re: WindowBuilder Issue [message #865658 is a reply to message #863412] Mon, 30 April 2012 14:05 Go to previous messageGo to next message
Hans Mueller is currently offline Hans MuellerFriend
Messages: 28
Registered: April 2012
Junior Member
and how can i change the LAF ???
Re: WindowBuilder Issue [message #867228 is a reply to message #865658] Tue, 01 May 2012 07:27 Go to previous messageGo to next message
Eric Clayberg is currently offline Eric ClaybergFriend
Messages: 884
Registered: July 2009
Location: Boston, MA
Senior Member
I highly recommend starting with the docs.
Re: WindowBuilder Issue [message #867934 is a reply to message #867228] Tue, 01 May 2012 15:04 Go to previous messageGo to next message
Hans Mueller is currently offline Hans MuellerFriend
Messages: 28
Registered: April 2012
Junior Member
thx, but i already started with the docs.

but no matter which setting i chose it always shows the same shit:
http://desmond.imageshack.us/Himg233/scaled.php?server=233&filename=bsp1.png&res=landing
Re: WindowBuilder Issue [message #868563 is a reply to message #867934] Wed, 02 May 2012 08:23 Go to previous message
Eric Clayberg is currently offline Eric ClaybergFriend
Messages: 884
Registered: July 2009
Location: Boston, MA
Senior Member
Hans Mueller wrote on Tue, 01 May 2012 11:04
it always shows the same shit

Should I translate the above as "Java always shows the same LAF for my app"?

If you have read the doc page I linked to, does that mean that you now know how to set the LAF of your app? What setting(s) are you using?

I would suggest providing a test case and describing what you have done to set the LAF. Specifically, what code are you using to set the LAF?
Previous Topic:ExpressionConverter null - assertionException
Next Topic:Need help with an internal error issue
Goto Forum:
  


Current Time: Sun Nov 23 10:07:46 GMT 2014

Powered by FUDForum. Page generated in 0.11014 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software