Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » line breaks in pdf ?
line breaks in pdf ? [message #111534] Thu, 19 January 2006 07:34 Go to next message
Thomas A. X-Berger is currently offline Thomas A. X-Berger
Messages: 15
Registered: July 2009
Junior Member
Hi @ all,

I have a really odd problem.
I'm working with BIRT since M1 and most of my reports are from that era.
I have a scripted datasource and using Pojos.
On the startpage of my report i have a data-field where I show a short
summary of the datas.
The code is:
=========================== C O D E ===========================
text="";
it = ht.keySet().iterator();
while(it.hasNext()){
key = it.next();
text1=key.toString()+": ";
text2=ht.get(key)+"\n";
text=text+text1+text2
}
test+"";
=========================== / C O D E ===========================
the problem is the line-break inside.
In HTML it looks fine, but when I generate a PDF there are no line-breaks
any more.
I have this issue since BIRT 2.0 RC1.
Has it anything to do with the i-Text?
Does anybody know what character-sequence I have to enter for a line-break?

MfU & best regards,
Thomas.
Re: line breaks in pdf ? [message #658970 is a reply to message #111534] Thu, 10 March 2011 10:22 Go to previous messageGo to next message
RWIL Mising name is currently offline RWIL Mising name
Messages: 28
Registered: February 2011
Junior Member
Hi,

I'm using BIRT 2.6.2 and i'm facing the exact same problem. Carriage return+line feed in a data field are displayed correctly in the HTML version, but in the PDF version I've only got the first line of the text, the rest is skipped.

Any idea ?

Regards
Re: line breaks in pdf ? [message #658973 is a reply to message #658970] Thu, 10 March 2011 10:27 Go to previous message
RWIL Mising name is currently offline RWIL Mising name
Messages: 28
Registered: February 2011
Junior Member
Ok, I've found a workaround. I have to change the "whitespace" property of my data field from "auto" to "preformatted" and now it also works in the PDF format.

The difference of behavior between the HTML and the PDF version with "whitespace=auto" is not a good idea, for my point of view, because it looks fine in HTML.
Previous Topic:Can't get year from date using getYear or getFullYear
Next Topic:PDF and image
Goto Forum:
  


Current Time: Tue Jul 22 09:31:47 EDT 2014

Powered by FUDForum. Page generated in 0.03958 seconds