Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » acagent dcom errors (on winxp)
acagent dcom errors (on winxp) [message #111385] Wed, 05 September 2007 08:58 Go to next message
Eclipse User
Originally posted by: bmf1972.fastmail.fm

Hi all,

I am trying to run AGR tests in standard mode.
For the testing purpose I have just recorded a New Java Project macro.
I have configured the agent to run as a Windows service under my user
account. The following DCOM Errors (EventId 10016) occur:

<SNIP>
The application-specific permission settings do not grant Local
Activation permission for the COM Server application with CLSID
{0C0A3666-30C9-11D0-8F20-00805F2CD064}
to the user MANAGER\pm SID
(S-1-5-21-1351778941-242146922-296224648-1005). This security
permission can be modified using the Component Services administrative tool.
</SNIP>

<SNIP>
The machine-default permission settings do not grant Local Activation
permission for the COM Server application with CLSID
{9BA05972-F6A8-11CF-A442-00A0C90A8F39}
to the user MANAGER\pm SID
(S-1-5-21-1351778941-242146922-296224648-1005). This security
permission can be modified using the Component Services administrative tool.
</SNIP>

And the test result is:

<SNIP>
There was an error while running the macro associated with the test
case: New Java Project. org.eclipse.core.runtime.CoreException: A
time-out occurred while waiting for the nested shell
org.eclipse.jface.wizard.WizardDialog to complete. It is likely caused
by the absence of the shell.
at
org.eclipse.tptp.test.auto.gui.internal.commands.MacroComman dShell.playback(MacroCommandShell.java:896)
at
org.eclipse.tptp.test.auto.gui.internal.macro.Macro.playback (Macro.java:346)
at
org.eclipse.tptp.test.auto.gui.internal.macro.MacroManager.r unMacro(MacroManager.java:574)
at
org.eclipse.tptp.test.auto.gui.internal.macro.MacroManager.a ccess$4(MacroManager.java:568)
at
org.eclipse.tptp.test.auto.gui.internal.macro.MacroManager$1 $MacroOperationWrapper.run(MacroManager.java:501)
at java.lang.Thread.run(Thread.java:619)
</SNIP>

One more interesting thing... I have built a "Hello World" Eclipse
plugin and recorded a test for its "Hello World" button. When running
the test, the same DCOM errors occur but the test succeeds.

Adrian.
Re: acagent dcom errors (on winxp) [message #112697 is a reply to message #111385] Wed, 19 September 2007 12:29 Go to previous messageGo to next message
Paul Slauenwhite is currently offline Paul Slauenwhite
Messages: 970
Registered: July 2009
Senior Member
Hi Adrian,
What version of Windows are you running? Can you try running the Agent
Controller as an application?

Paul
"Adrian Herscu" <bmf1972@fastmail.fm> wrote in message
news:fblr3a$326$1@build.eclipse.org...
> Hi all,
>
> I am trying to run AGR tests in standard mode.
> For the testing purpose I have just recorded a New Java Project macro.
> I have configured the agent to run as a Windows service under my user
> account. The following DCOM Errors (EventId 10016) occur:
>
> <SNIP>
> The application-specific permission settings do not grant Local Activation
> permission for the COM Server application with CLSID
> {0C0A3666-30C9-11D0-8F20-00805F2CD064}
> to the user MANAGER\pm SID
> (S-1-5-21-1351778941-242146922-296224648-1005). This security permission
> can be modified using the Component Services administrative tool.
> </SNIP>
>
> <SNIP>
> The machine-default permission settings do not grant Local Activation
> permission for the COM Server application with CLSID
> {9BA05972-F6A8-11CF-A442-00A0C90A8F39}
> to the user MANAGER\pm SID
> (S-1-5-21-1351778941-242146922-296224648-1005). This security permission
> can be modified using the Component Services administrative tool.
> </SNIP>
>
> And the test result is:
>
> <SNIP>
> There was an error while running the macro associated with the test case:
> New Java Project. org.eclipse.core.runtime.CoreException: A time-out
> occurred while waiting for the nested shell
> org.eclipse.jface.wizard.WizardDialog to complete. It is likely caused by
> the absence of the shell.
> at
> org.eclipse.tptp.test.auto.gui.internal.commands.MacroComman dShell.playback(MacroCommandShell.java:896)
> at
> org.eclipse.tptp.test.auto.gui.internal.macro.Macro.playback (Macro.java:346)
> at
> org.eclipse.tptp.test.auto.gui.internal.macro.MacroManager.r unMacro(MacroManager.java:574)
> at
> org.eclipse.tptp.test.auto.gui.internal.macro.MacroManager.a ccess$4(MacroManager.java:568)
> at
> org.eclipse.tptp.test.auto.gui.internal.macro.MacroManager$1 $MacroOperationWrapper.run(MacroManager.java:501)
> at java.lang.Thread.run(Thread.java:619)
> </SNIP>
>
> One more interesting thing... I have built a "Hello World" Eclipse plugin
> and recorded a test for its "Hello World" button. When running the test,
> the same DCOM errors occur but the test succeeds.
>
> Adrian.
Re: acagent dcom errors (on winxp) [message #113074 is a reply to message #112697] Sun, 23 September 2007 14:42 Go to previous messageGo to next message
Eclipse User
Originally posted by: bmf1972.fastmail.fm

Hi Paul,

I am using WinXP SP2.
I have configured the Agent Controller to run as a Windows service and
it works OK on configured to run with administrative privileges.
Trying to make it run with user privileges requires enabling the user to
launch and access those two COM+ components.

Adrian.

Paul Slauenwhite wrote:
> Hi Adrian,
> What version of Windows are you running? Can you try running the Agent
> Controller as an application?
>
> Paul
> "Adrian Herscu" <bmf1972@fastmail.fm> wrote in message
> news:fblr3a$326$1@build.eclipse.org...
>> Hi all,
>>
>> I am trying to run AGR tests in standard mode.
>> For the testing purpose I have just recorded a New Java Project macro.
>> I have configured the agent to run as a Windows service under my user
>> account. The following DCOM Errors (EventId 10016) occur:
>>
>> <SNIP>
>> The application-specific permission settings do not grant Local Activation
>> permission for the COM Server application with CLSID
>> {0C0A3666-30C9-11D0-8F20-00805F2CD064}
>> to the user MANAGER\pm SID
>> (S-1-5-21-1351778941-242146922-296224648-1005). This security permission
>> can be modified using the Component Services administrative tool.
>> </SNIP>
>>
>> <SNIP>
>> The machine-default permission settings do not grant Local Activation
>> permission for the COM Server application with CLSID
>> {9BA05972-F6A8-11CF-A442-00A0C90A8F39}
>> to the user MANAGER\pm SID
>> (S-1-5-21-1351778941-242146922-296224648-1005). This security permission
>> can be modified using the Component Services administrative tool.
>> </SNIP>
>>
>> And the test result is:
>>
>> <SNIP>
>> There was an error while running the macro associated with the test case:
>> New Java Project. org.eclipse.core.runtime.CoreException: A time-out
>> occurred while waiting for the nested shell
>> org.eclipse.jface.wizard.WizardDialog to complete. It is likely caused by
>> the absence of the shell.
>> at
>> org.eclipse.tptp.test.auto.gui.internal.commands.MacroComman dShell.playback(MacroCommandShell.java:896)
>> at
>> org.eclipse.tptp.test.auto.gui.internal.macro.Macro.playback (Macro.java:346)
>> at
>> org.eclipse.tptp.test.auto.gui.internal.macro.MacroManager.r unMacro(MacroManager.java:574)
>> at
>> org.eclipse.tptp.test.auto.gui.internal.macro.MacroManager.a ccess$4(MacroManager.java:568)
>> at
>> org.eclipse.tptp.test.auto.gui.internal.macro.MacroManager$1 $MacroOperationWrapper.run(MacroManager.java:501)
>> at java.lang.Thread.run(Thread.java:619)
>> </SNIP>
>>
>> One more interesting thing... I have built a "Hello World" Eclipse plugin
>> and recorded a test for its "Hello World" button. When running the test,
>> the same DCOM errors occur but the test succeeds.
>>
>> Adrian.
>
>
Re: acagent dcom errors (on winxp) [message #113171 is a reply to message #113074] Mon, 24 September 2007 12:06 Go to previous messageGo to next message
Paul Slauenwhite is currently offline Paul Slauenwhite
Messages: 970
Registered: July 2009
Senior Member
Hi Adrian,
We have not seen this issue before in our testing, I guess since our
testers are user accounts with admin privileges. Can you please open a
defect
( https://bugs.eclipse.org/bugs/enter_bug.cgi?product=TPTP%20A gent%20Controller
and the Documentation component) with the details we can provide a readme
entry for the limitation and its work-around?

Thanks,
Paul
"Adrian Herscu" <bmf1972@fastmail.fm> wrote in message
news:fd5u0q$7t1$1@build.eclipse.org...
> Hi Paul,
>
> I am using WinXP SP2.
> I have configured the Agent Controller to run as a Windows service and it
> works OK on configured to run with administrative privileges.
> Trying to make it run with user privileges requires enabling the user to
> launch and access those two COM+ components.
>
> Adrian.
>
> Paul Slauenwhite wrote:
>> Hi Adrian,
>> What version of Windows are you running? Can you try running the
>> Agent Controller as an application?
>>
>> Paul
>> "Adrian Herscu" <bmf1972@fastmail.fm> wrote in message
>> news:fblr3a$326$1@build.eclipse.org...
>>> Hi all,
>>>
>>> I am trying to run AGR tests in standard mode.
>>> For the testing purpose I have just recorded a New Java Project macro.
>>> I have configured the agent to run as a Windows service under my user
>>> account. The following DCOM Errors (EventId 10016) occur:
>>>
>>> <SNIP>
>>> The application-specific permission settings do not grant Local
>>> Activation permission for the COM Server application with CLSID
>>> {0C0A3666-30C9-11D0-8F20-00805F2CD064}
>>> to the user MANAGER\pm SID
>>> (S-1-5-21-1351778941-242146922-296224648-1005). This security
>>> permission can be modified using the Component Services administrative
>>> tool.
>>> </SNIP>
>>>
>>> <SNIP>
>>> The machine-default permission settings do not grant Local Activation
>>> permission for the COM Server application with CLSID
>>> {9BA05972-F6A8-11CF-A442-00A0C90A8F39}
>>> to the user MANAGER\pm SID
>>> (S-1-5-21-1351778941-242146922-296224648-1005). This security
>>> permission can be modified using the Component Services administrative
>>> tool.
>>> </SNIP>
>>>
>>> And the test result is:
>>>
>>> <SNIP>
>>> There was an error while running the macro associated with the test
>>> case: New Java Project. org.eclipse.core.runtime.CoreException: A
>>> time-out occurred while waiting for the nested shell
>>> org.eclipse.jface.wizard.WizardDialog to complete. It is likely caused
>>> by the absence of the shell.
>>> at
>>> org.eclipse.tptp.test.auto.gui.internal.commands.MacroComman dShell.playback(MacroCommandShell.java:896)
>>> at
>>> org.eclipse.tptp.test.auto.gui.internal.macro.Macro.playback (Macro.java:346)
>>> at
>>> org.eclipse.tptp.test.auto.gui.internal.macro.MacroManager.r unMacro(MacroManager.java:574)
>>> at
>>> org.eclipse.tptp.test.auto.gui.internal.macro.MacroManager.a ccess$4(MacroManager.java:568)
>>> at
>>> org.eclipse.tptp.test.auto.gui.internal.macro.MacroManager$1 $MacroOperationWrapper.run(MacroManager.java:501)
>>> at java.lang.Thread.run(Thread.java:619)
>>> </SNIP>
>>>
>>> One more interesting thing... I have built a "Hello World" Eclipse
>>> plugin and recorded a test for its "Hello World" button. When running
>>> the test, the same DCOM errors occur but the test succeeds.
>>>
>>> Adrian.
>>
Re: acagent dcom errors (on winxp) [message #113201 is a reply to message #113171] Mon, 24 September 2007 21:08 Go to previous message
Eclipse User
Originally posted by: bmf1972.fastmail.fm

Done.
https://bugs.eclipse.org/bugs/show_bug.cgi?id=204491
Adrian.

Paul Slauenwhite wrote:
> Hi Adrian,
> We have not seen this issue before in our testing, I guess since our
> testers are user accounts with admin privileges. Can you please open a
> defect
> ( https://bugs.eclipse.org/bugs/enter_bug.cgi?product=TPTP%20A gent%20Controller
> and the Documentation component) with the details we can provide a readme
> entry for the limitation and its work-around?
>
> Thanks,
> Paul
> "Adrian Herscu" <bmf1972@fastmail.fm> wrote in message
> news:fd5u0q$7t1$1@build.eclipse.org...
>> Hi Paul,
>>
>> I am using WinXP SP2.
>> I have configured the Agent Controller to run as a Windows service and it
>> works OK on configured to run with administrative privileges.
>> Trying to make it run with user privileges requires enabling the user to
>> launch and access those two COM+ components.
>>
>> Adrian.
>>
>> Paul Slauenwhite wrote:
>>> Hi Adrian,
>>> What version of Windows are you running? Can you try running the
>>> Agent Controller as an application?
>>>
>>> Paul
>>> "Adrian Herscu" <bmf1972@fastmail.fm> wrote in message
>>> news:fblr3a$326$1@build.eclipse.org...
>>>> Hi all,
>>>>
>>>> I am trying to run AGR tests in standard mode.
>>>> For the testing purpose I have just recorded a New Java Project macro.
>>>> I have configured the agent to run as a Windows service under my user
>>>> account. The following DCOM Errors (EventId 10016) occur:
>>>>
>>>> <SNIP>
>>>> The application-specific permission settings do not grant Local
>>>> Activation permission for the COM Server application with CLSID
>>>> {0C0A3666-30C9-11D0-8F20-00805F2CD064}
>>>> to the user MANAGER\pm SID
>>>> (S-1-5-21-1351778941-242146922-296224648-1005). This security
>>>> permission can be modified using the Component Services administrative
>>>> tool.
>>>> </SNIP>
>>>>
>>>> <SNIP>
>>>> The machine-default permission settings do not grant Local Activation
>>>> permission for the COM Server application with CLSID
>>>> {9BA05972-F6A8-11CF-A442-00A0C90A8F39}
>>>> to the user MANAGER\pm SID
>>>> (S-1-5-21-1351778941-242146922-296224648-1005). This security
>>>> permission can be modified using the Component Services administrative
>>>> tool.
>>>> </SNIP>
>>>>
>>>> And the test result is:
>>>>
>>>> <SNIP>
>>>> There was an error while running the macro associated with the test
>>>> case: New Java Project. org.eclipse.core.runtime.CoreException: A
>>>> time-out occurred while waiting for the nested shell
>>>> org.eclipse.jface.wizard.WizardDialog to complete. It is likely caused
>>>> by the absence of the shell.
>>>> at
>>>> org.eclipse.tptp.test.auto.gui.internal.commands.MacroComman dShell.playback(MacroCommandShell.java:896)
>>>> at
>>>> org.eclipse.tptp.test.auto.gui.internal.macro.Macro.playback (Macro.java:346)
>>>> at
>>>> org.eclipse.tptp.test.auto.gui.internal.macro.MacroManager.r unMacro(MacroManager.java:574)
>>>> at
>>>> org.eclipse.tptp.test.auto.gui.internal.macro.MacroManager.a ccess$4(MacroManager.java:568)
>>>> at
>>>> org.eclipse.tptp.test.auto.gui.internal.macro.MacroManager$1 $MacroOperationWrapper.run(MacroManager.java:501)
>>>> at java.lang.Thread.run(Thread.java:619)
>>>> </SNIP>
>>>>
>>>> One more interesting thing... I have built a "Hello World" Eclipse
>>>> plugin and recorded a test for its "Hello World" button. When running
>>>> the test, the same DCOM errors occur but the test succeeds.
>>>>
>>>> Adrian.
>
Previous Topic:C/C++ code review
Next Topic:TPTP 4.4.0 On-line Help.
Goto Forum:
  


Current Time: Tue Sep 23 04:45:01 GMT 2014

Powered by FUDForum. Page generated in 0.03816 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software