Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » Time-out when launching the process
Time-out when launching the process [message #110309] Mon, 27 August 2007 12:51 Go to next message
Eclipse UserFriend
Originally posted by: mauro.molinari.cardinis.com

Hello,
I still have problems to use TPTP on my machine.

I made an HelloWorld application. When I try to profile it, I get a
"warning" dialog with the text:

One of the selected launch delegates has failed.
Reson:
< nothing written here!! >

If I click on details, I find the following exception:

org.eclipse.core.runtime.CoreException
A time-out occurred while attempting to launch the process

org.eclipse.core.runtime.CoreException: A time-out occurred while
attempting to launch the process
at
org.eclipse.tptp.trace.ui.internal.launcher.core.LauncherUti lity.createCoreException(LauncherUtility.java:123)
at
org.eclipse.tptp.trace.ui.internal.launcher.core.LauncherUti lity.createCoreException(LauncherUtility.java:131)
at
org.eclipse.tptp.platform.jvmti.client.internal.launcher.TID elegateHelper.handleError(TIDelegateHelper.java:596)
at
org.eclipse.tptp.platform.jvmti.client.internal.launcher.TID elegateHelper.launchProcess(TIDelegateHelper.java:512)
at
org.eclipse.tptp.platform.jvmti.client.internal.launcher.TID elegateHelper.launch(TIDelegateHelper.java:312)
at
org.eclipse.tptp.platform.jvmti.client.internal.launcher.TIJ avaLauncherDelegate.launch(TIJavaLauncherDelegate.java:37)
at
org.eclipse.tptp.trace.ui.internal.launcher.core.LauncherUti lity.delegateInit(LauncherUtility.java:1153)
at
org.eclipse.tptp.trace.ui.provisional.launcher.PrimaryLaunch Delegate.run(PrimaryLaunchDelegate.java:196)
at java.lang.Thread.run(Unknown Source)

On the log I find:

!ENTRY org.eclipse.hyades.trace.ui 4 4 2007-08-27 14:47:16.890
!MESSAGE A time-out occurred while attempting to launch the process
!STACK 1
org.eclipse.core.runtime.CoreException: A time-out occurred while
attempting to launch the process
at
org.eclipse.tptp.trace.ui.internal.launcher.core.LauncherUti lity.createCoreException(LauncherUtility.java:123)
at
org.eclipse.tptp.trace.ui.internal.launcher.core.LauncherUti lity.createCoreException(LauncherUtility.java:131)
at
org.eclipse.tptp.platform.jvmti.client.internal.launcher.TID elegateHelper.handleError(TIDelegateHelper.java:596)
at
org.eclipse.tptp.platform.jvmti.client.internal.launcher.TID elegateHelper.launchProcess(TIDelegateHelper.java:512)
at
org.eclipse.tptp.platform.jvmti.client.internal.launcher.TID elegateHelper.launch(TIDelegateHelper.java:312)
at
org.eclipse.tptp.platform.jvmti.client.internal.launcher.TIJ avaLauncherDelegate.launch(TIJavaLauncherDelegate.java:37)
at
org.eclipse.tptp.trace.ui.internal.launcher.core.LauncherUti lity.delegateInit(LauncherUtility.java:1153)
at
org.eclipse.tptp.trace.ui.provisional.launcher.PrimaryLaunch Delegate.run(PrimaryLaunchDelegate.java:196)
at java.lang.Thread.run(Unknown Source)
!SUBENTRY 1 org.eclipse.hyades.trace.ui 4 0 2007-08-27 14:47:16.890
!MESSAGE A time-out occurred while attempting to launch the process

Anybody can help to solve this problem? :-(

My OS is Windows 2000.
I'm using the IAC.
TPTP version is 4.4.0.2.

Thanks in advance.

Mauro.
Re: Time-out when launching the process [message #110507 is a reply to message #110309] Tue, 28 August 2007 10:19 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: alexander.n.alexeev.intel.com

Mauro, could you describe you case more precisely

- What JRE do you use for profiled executions
- What type of profiling do you use ("Java application", "External Java
application")
- Can you find ACServer.exe in Task Manger after fault?
- Please, provide full consecution of you actions.

Alex.
Re: Time-out when launching the process [message #110544 is a reply to message #110507] Tue, 28 August 2007 13:50 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: mauro.molinari.cardinis.com

Alexander N, Alexeev ha scritto:
> Mauro, could you describe you case more precisely
>
> - What JRE do you use for profiled executions
> - What type of profiling do you use ("Java application", "External Java
> application")
> - Can you find ACServer.exe in Task Manger after fault?
> - Please, provide full consecution of you actions.
> Alex.

Hi Alexander,
thank you for your help.

- well, I just noticed that there is no JRE tab in Profile Dialog.
Anyway, in Run Dialog I set up the corresponding run configuration to
use JRE 1.5.0_12; moreover, in Profile Dialog, for this configuration,
under Monitor tab I checked just "Execution Time Analysis" under "Java
Profiling - JRE 1.5 or newer"

- I use "Java application"

- yes, ACServer.exe is there after fault

- I wrote the following class:

package com.cardinis.test;

public class HelloWorld
{
public static void main(String[] args)
{
System.out.println("Ciao");
}
}

Then I ran it, creating a new Run configuration for it, named
"HelloWorld" and with no particular option (the mentioned JRE is the
default for my workspace).
The program runs fine and outputs "Ciao".

Then, I opened the Profile dialog and, for HelloWorld configuration
under "Monitor" tab I checked "Execution Time Analysis" under "Java
Profiling - JRE 1.5 or newer". Finally I clicked on Profile. From that
moment on, I just click on the "HelloWorld" option under the Profile
button drop-down menu. But the result is always the one I described in
my previous message.

I successfully profiled other applications on another PC with TPTP
4.4.0, running Linux. But I can't profile on mine! :-(

Mauro.
Re: Time-out when launching the process [message #110580 is a reply to message #110544] Wed, 29 August 2007 05:53 Go to previous messageGo to next message
Igor Alelekov is currently offline Igor AlelekovFriend
Messages: 139
Registered: July 2009
Senior Member
Hi Mauro,
what TPTP build are you using?
Regards,
Igor
Re: Time-out when launching the process [message #110629 is a reply to message #110580] Wed, 29 August 2007 07:04 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: mauro.molinari.cardinis.com

Igor Alelekov ha scritto:
> Hi Mauro,
> what TPTP build are you using?
> Regards,
> Igor
>

Hi Igor,
I installed TPTP from Europa Update Site, then I updated it to 4.4.0.2
still using update manager.
Anyway, I hope that the following information answers better your
question: otherwise, please tell me exactly where do I have to look at
to get it.

org.eclipse.tptp.monitoring (4.1.200.v200707080100) "TPTP Monitoring"
[Starting]
org.eclipse.tptp.monitoring.doc.user (4.2.200.v200707080100) "TPTP
Monitoring Project Documentation" [Starting]
org.eclipse.tptp.monitoring.examples (4.3.100.v200707080100) "User
examples for the TPTP Monitoring Tools Plugins" [Starting]
org.eclipse.tptp.monitoring.instrumentation (4.3.0.v200707080100) "TPTP
Instrumentation Monitoring" [Resolved]
org.eclipse.tptp.monitoring.instrumentation.doc.user
(4.3.0.v200705310943) "TPTP Monitoring Instrumentation Doc User" [Resolved]
org.eclipse.tptp.monitoring.instrumentation.ui (4.4.0.v200707070100)
"Monitoring Instrumentation UI" [Starting]
org.eclipse.tptp.monitoring.la.core (4.3.100.v200707080100) "Monitoring
Log Analyzer Core" [Resolved]
org.eclipse.tptp.monitoring.logui (4.4.0.v200706130100) "TPTP Import Log
Plugin" [Starting]
org.eclipse.tptp.monitoring.managedagent (4.4.0.v200707080100) "Managed
Agent Plugin" [Starting]
org.eclipse.tptp.monitoring.managedagent.doc.user
(4.3.100.v200706120100) "Managed Agent Documentation Plugin" [Resolved]
org.eclipse.tptp.monitoring.managedagent.jmx (4.4.0.v200706130100) "JMX
Managed Agent" [Starting]
org.eclipse.tptp.monitoring.managedagent.ui (4.4.0.v200707070100)
"Managed Agent UI Plugin" [Starting]
org.eclipse.tptp.monitoring.notifications (4.4.0.v200706090100)
"WS-Notifications Provider Plug-in" [Starting]
org.eclipse.tptp.monitoring.profile.server (4.2.100.v200707080100) "TPTP
Profile On Server Logging Utility" [Starting]
org.eclipse.tptp.monitoring.report.birt (4.2.100.v200707080100) "BIRT
Monitor Reports for TPTP Branding Plugin" [Resolved]
org.eclipse.tptp.monitoring.report.birt.doc.user (4.4.0.v200705070853)
"Monitoring Tools Business Intelligence Reporting Tools Doc User
Plug-in" [Resolved]
org.eclipse.tptp.monitoring.report.birt.ui (4.4.0.v200705300100) "BIRT
Monitor Reports for TPTP" [Starting]
org.eclipse.tptp.monitoring.symptom.doc.user (4.3.100.v200705070853)
"TPTP Monitoring Symptom Catalog Documentation" [Resolved]
org.eclipse.tptp.monitoring.symptom.editor (4.3.100.v200705040100)
"Symptom editor plug-in" [Starting]
org.eclipse.tptp.platform.ac.linux_em64t (4.4.0.v200706020100) "TPTP
Linux_em64t IAC Plug-in" [Resolved]
org.eclipse.tptp.platform.ac.linux_ia32 (4.4.0.v200706020100) "TPTP
Linux_ia32 IAC Plug-in" [Resolved]
org.eclipse.tptp.platform.ac.linux_ipf (4.4.0.v200706020100) "TPTP
Linux_ipf IAC Plug-in" [Resolved]
org.eclipse.tptp.platform.ac.win_em64t (4.4.0.v200706020100) "TPTP
Win_em64t IAC Plug-in" [Resolved]
org.eclipse.tptp.platform.ac.win_ia32 (4.4.0.v200706020100) "TPTP
Win_ia32 IAC Plug-in" [Resolved]
org.eclipse.tptp.platform.ac.win_ipf (4.4.0.v200706020100) "TPTP Win_ipf
IAC Plug-in" [Resolved]
org.eclipse.tptp.platform.agentcontroller (4.2.0.v200706270100) "TPTP
Agent Controller" [Resolved]
org.eclipse.tptp.platform.agentcontroller.doc.user
(4.2.200.v200705260100) "Agent Controller documentation" [Starting]
org.eclipse.tptp.platform.analysis (4.1.200.v200707090100) "TPTP
Analysis" [Starting]
org.eclipse.tptp.platform.analysis.codereview.java (4.4.0.v200704210100)
"Java Code Review Plug-in" [Starting]
org.eclipse.tptp.platform.analysis.codereview.java.rules
(4.4.0.v200705300100) "Java Code Review Rules Plug-in" [Starting]
org.eclipse.tptp.platform.analysis.core (4.4.0.v200706060100) "TPTP
Analysis Framework Core Plug-in" [Starting]
org.eclipse.tptp.platform.analysis.core.ui (4.4.0.v200706060100) "Static
Analysis User Interface Plug-in" [Starting]
org.eclipse.tptp.platform.analysis.core.ui.doc (4.2.200.v200704271041)
"Analysis run cofiguration online help" [Resolved]
org.eclipse.tptp.platform.analysis.engine (4.1.200.v200707090100) "TPTP
Analysis Engine" [Starting]
org.eclipse.tptp.platform.collection.framework (4.2.100.v200704140100)
"TPTP Collection Framework" [Resolved]
org.eclipse.tptp.platform.common (4.3.100.v200704240100) "TPTP Common
Plug-in" [Active]
org.eclipse.tptp.platform.common.ui (4.4.0.v200705310100) "TPTP Common
UI Plug-in" [Active]
org.eclipse.tptp.platform.common.ui.trace (4.3.100.v200707060100) "TPTP
Common UI Trace Plug-in" [Starting]
org.eclipse.tptp.platform.core (4.1.200.v200707090100) "TPTP Platform"
[Starting]
org.eclipse.tptp.platform.doc.user (4.2.100.v200707090100) "TPTP
Platform Project Documentation" [Starting]
org.eclipse.tptp.platform.examples (4.3.100.v200707090100) "TPTP
Platform Examples" [Resolved]
org.eclipse.tptp.platform.execution (4.4.0.v200708071640) "TPTP Core
Platform Execution Framework" [Resolved]
org.eclipse.tptp.platform.iac.administrator (4.4.0.v200705230100)
"Integrated Agent Controller Administrator" [Active]
org.eclipse.tptp.platform.instrumentation.ui (4.3.0.v200707090100)
"Instrument Core UI" [Starting]
org.eclipse.tptp.platform.integration.pde (4.4.0.v200706132116) "TPTP
Platform Integration PDE" [Starting]
org.eclipse.tptp.platform.jvmti.client (4.4.0.v200708071640) "TPTP JVMTI
Profiler Client" [Starting]
org.eclipse.tptp.platform.jvmti.runtime (4.4.0.v200708010927) "JVMTI
Runtime" [Starting]
org.eclipse.tptp.platform.la.core (4.3.100.v200707090100) "Log Analysis
Core" [Starting]
org.eclipse.tptp.platform.log.doc.user (4.3.100.v200705290100) "TPTP
Platform Log Documentation" [Resolved]
org.eclipse.tptp.platform.log.views (4.3.100.v200706060100) "Hyades Log
UI" [Starting]
org.eclipse.tptp.platform.logging.events (4.3.100.v200704140100) "Common
Base Events" [Starting]
org.eclipse.tptp.platform.lta (4.1.200.v200707090100) "TPTP Log and
Trace Analyzer" [Starting]
org.eclipse.tptp.platform.models (4.3.0.v200708071640) "Hyades Models"
[Active]
org.eclipse.tptp.platform.probekit (4.1.200.v200707090100) "TPTP
ProbeKit" [Starting]
org.eclipse.tptp.platform.probekit.launch (4.4.0.v200706300100)
"Probekit Launch Configuration" [Starting]
org.eclipse.tptp.platform.profile.server (4.2.0.v200707090100) "TPTP
Profile on Server" [Starting]
org.eclipse.tptp.platform.profile.server.core (4.2.0.v200706170100)
"TPTP Profile On Server Core" [Starting]
org.eclipse.tptp.platform.profile.server.doc.user
(4.3.100.v200704250100) "TPTP Profile On Server Doc User Plug-in" [Resolved]
org.eclipse.tptp.platform.profile.server.wst (4.3.0.v200707060100) "TPTP
Profile On Server WTP Utility" [Active]
org.eclipse.tptp.platform.report (4.1.200.v200707090100) "TPTP Charting
Service" [Starting]
org.eclipse.tptp.platform.report.birt (4.4.0.v200707090100) "BIRT
Reporting for TPTP Branding plugin" [Starting]
org.eclipse.tptp.platform.report.birt.ui (4.4.0.v200705300100) "BIRT
Reporting for TPTP" [Starting]
org.eclipse.tptp.platform.report.core (4.4.0.v200703262200) "TPTP Report
Framework" [Starting]
org.eclipse.tptp.platform.report.ui (4.1.200.v200704140100) "TPTP Report
UI" [Starting]
org.eclipse.tptp.platform.samples (4.1.200.v200707090100) "TPTP Platform
Samples" [Starting]
org.eclipse.tptp.platform.statistical.report.birt (4.4.0.v200707090100)
"BIRT Statistical Reports for TPTP Branding Plugin" [Starting]
org.eclipse.tptp.platform.statistical.report.birt.ui
(4.4.0.v200705250100) "BIRT Statistical Reports UI for TPTP" [Starting]
org.eclipse.tptp.platform.statistical.ui (4.1.200.v200707090100) "TPTP
Statistical UI" [Starting]
org.eclipse.tptp.platform.trace (4.1.200.v200707090100) "TPTP Platform
Trace" [Starting]
org.eclipse.tptp.test (4.2.0.v200707090100) "TPTP Test" [Starting]
org.eclipse.tptp.test.report.birt (4.4.0.v200707090100) "BIRT Test
Reports for TPTP Branding Plugin" [Starting]
org.eclipse.tptp.test.report.birt.doc.user (4.4.0.v200705300100)
"Testing Tools Business Intelligence Reporting Tools Doc User Plug-in"
[Resolved]
org.eclipse.tptp.test.report.birt.ui (4.4.0.v200705300100) "BIRT Test
Reports for TPTP" [Starting]
org.eclipse.tptp.test.samples (4.2.0.v200707090100) "TPTP Test Samples"
[Starting]
org.eclipse.tptp.test.tools (4.2.0.v200707090100) "TPTP Test Tools"
[Starting]
org.eclipse.tptp.test.tools.junit.plugin (4.4.0.v200705290100) "TPTP
JUnit Plugin Test Tools" [Starting]
org.eclipse.tptp.trace (4.1.300.v200707090100) "TPTP Trace" [Starting]
org.eclipse.tptp.trace.arm (4.3.0.v200707090100) "TPTP ARM Monitoring"
[Resolved]
org.eclipse.tptp.trace.arm.doc.user (4.3.0.v200705310100) "TPTP Trace
ARM Doc User" [Resolved]
org.eclipse.tptp.trace.arm.ui (4.3.0.v200707090100) "Instrument ARM UI"
[Starting]
org.eclipse.tptp.trace.jvmti.client (4.4.0.v200707090100) "TPTP Trace
JVMTI Client" [Starting]
org.eclipse.tptp.trace.report.birt (4.4.0.v200707090100) "BIRT Trace
Reports for TPTP Branding Plugin" [Resolved]
org.eclipse.tptp.trace.report.birt.doc.user (4.4.0.v200705301304)
"Tracing and Profiling Tools Business Intelligence Reporting Tools Doc
User Plug-in" [Resolved]
org.eclipse.tptp.trace.report.birt.ui (4.4.0.v200705300100) "BIRT Trace
Reports for TPTP" [Starting]

Thanks for you help!

Mauro.
Re: Time-out when launching the process [message #110873 is a reply to message #110629] Fri, 31 August 2007 07:31 Go to previous messageGo to next message
Igor Alelekov is currently offline Igor AlelekovFriend
Messages: 139
Registered: July 2009
Senior Member
Hi Mauro,
This intermittent issue should be resolved with fix of
https://bugs.eclipse.org/bugs/show_bug.cgi?id=201443.
Regards,
Igor
Re: Time-out when launching the process [message #110884 is a reply to message #110873] Fri, 31 August 2007 07:52 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: mauro.molinari.cardinis.com

Igor Alelekov ha scritto:
> Hi Mauro,
> This intermittent issue should be resolved with fix of
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=201443.
> Regards,
> Igor
>

Hi Igor,
I hope this is true. I can test it when your fix is available in a build
and let you know.
Is 4.4.1 for Eclipse 3.3 or 3.4? I hope 3.3, otherwise I think a
backport for 4.4.0.x should be necessary, as this problem is really
blocking, at least for me... :-(

Thanks again!
Mauro.
Re: Time-out when launching the process [message #110920 is a reply to message #110884] Fri, 31 August 2007 11:23 Go to previous messageGo to next message
Igor Alelekov is currently offline Igor AlelekovFriend
Messages: 139
Registered: July 2009
Senior Member
Mauro,
TPTP 4.1 requires Eclipse 3.3.
Build with this fix will be available soon.
Regards,
Igor
Re: Time-out when launching the process [message #111307 is a reply to message #110920] Tue, 04 September 2007 14:16 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: mauro.molinari.cardinis.com

Igor Alelekov ha scritto:
> Mauro,
> TPTP 4.1 requires Eclipse 3.3.
> Build with this fix will be available soon.
> Regards,
> Igor

Hi Igor,
today I downloaded tptp.runtime-TPTP-4.4.1-200709030100.zip and
installed it on my Eclipse 3.3 installation.
I started Eclipse with -clean option.
But I still have the time-out problem :-(

Do you have any suggestion?

Mauro.
Re: Time-out when launching the process [message #111333 is a reply to message #111307] Wed, 05 September 2007 00:55 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: delfina.observant.com.au

Hi Igor and Mauro

I'm experiencing the exact same issue trying to profile a simple application
using the TPTP-4.4.0.2 all-in-one package running against Eclipse 3.3.

This issue doesn't appear to be the same as bug 201443. The symptoms and stack
traces differ (I see the exact stack trace as in Mauro's original post).

An earlier post titled "Time out problem" that describes the same problem went
unanswered, so any feedback at all on how to get the most basic of profiling
functionality working would be greatly appreciated.

Delfina

Mauro Molinari wrote:
> Igor Alelekov ha scritto:
>> Mauro,
>> TPTP 4.1 requires Eclipse 3.3.
>> Build with this fix will be available soon.
>> Regards,
>> Igor
>
> Hi Igor,
> today I downloaded tptp.runtime-TPTP-4.4.1-200709030100.zip and
> installed it on my Eclipse 3.3 installation.
> I started Eclipse with -clean option.
> But I still have the time-out problem :-(
>
> Do you have any suggestion?
>
> Mauro.
Re: Time-out when launching the process [message #111346 is a reply to message #111307] Wed, 05 September 2007 05:40 Go to previous messageGo to next message
Igor Alelekov is currently offline Igor AlelekovFriend
Messages: 139
Registered: July 2009
Senior Member
Hi Mauro,
What Agent Controller are you using?
If stand-alone, please try agntctrl.win_ia32-TPTP-4.4.1-200709030100 or
newer.
Regards,
Igor
Re: Time-out when launching the process [message #111355 is a reply to message #111346] Wed, 05 September 2007 07:07 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: mauro.molinari.cardinis.com

Igor Alelekov ha scritto:
> Hi Mauro,
> What Agent Controller are you using?
> If stand-alone, please try agntctrl.win_ia32-TPTP-4.4.1-200709030100 or
> newer.
> Regards,
> Igor

Hi Igor,
it was the IAC.
Now I just tried the stand-alone version you're suggesting, but the
result is the same... :-(

Do you have any idea on what is going wrong?

Thanks again for your support.
Mauro.
Re: Time-out when launching the process [message #111363 is a reply to message #111333] Wed, 05 September 2007 07:09 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: mauro.molinari.cardinis.com

Delfina Gonzalez ha scritto:
> Hi Igor and Mauro
>
> I'm experiencing the exact same issue trying to profile a simple
> application using the TPTP-4.4.0.2 all-in-one package running against
> Eclipse 3.3.
>
> This issue doesn't appear to be the same as bug 201443. The symptoms and
> stack traces differ (I see the exact stack trace as in Mauro's original
> post).
>
> An earlier post titled "Time out problem" that describes the same
> problem went unanswered, so any feedback at all on how to get the most
> basic of profiling functionality working would be greatly appreciated.
>
> Delfina

Hi Delfina,
I'm glad to see that I'm not the only one to suffer from this problem...

I hope this can be solved, otherwise we can't use TPTP profiling
features completely...

Thank you for your post.
Mauro.
Re: Time-out when launching the process [message #112091 is a reply to message #111346] Mon, 10 September 2007 07:11 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: mauro.molinari.cardinis.com

Igor Alelekov ha scritto:
> Hi Mauro,
> What Agent Controller are you using?
> If stand-alone, please try agntctrl.win_ia32-TPTP-4.4.1-200709030100 or
> newer.
> Regards,
> Igor

Hi Igor,
any suggestion for this? Should I open a new bug?

Mauro.
Re: Time-out when launching the process [message #112125 is a reply to message #111307] Mon, 10 September 2007 10:05 Go to previous messageGo to next message
Igor Alelekov is currently offline Igor AlelekovFriend
Messages: 139
Registered: July 2009
Senior Member
Hi Mauro,
I'll look at this right now.
Regards,
Igor
Re: Time-out when launching the process [message #112159 is a reply to message #112091] Mon, 10 September 2007 13:29 Go to previous messageGo to next message
Igor Alelekov is currently offline Igor AlelekovFriend
Messages: 139
Registered: July 2009
Senior Member
Hi Mauro,
Unforunately I can't reproduce this issue using TPTP build 200709090100
and both Agent Controllers - Integrated and stand-alone.
Does path to your Eclipse home directory has spaces (this could affect the
integrated one)?
Regards,
Igor
Re: Time-out when launching the process [message #112172 is a reply to message #112159] Mon, 10 September 2007 14:35 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: mauro.molinari.cardinis.com

Igor Alelekov ha scritto:
> Hi Mauro,
> Unforunately I can't reproduce this issue using TPTP build 200709090100
> and both Agent Controllers - Integrated and stand-alone.
> Does path to your Eclipse home directory has spaces (this could affect
> the integrated one)?
> Regards,
> Igor
>
>

No, it doesn't.
I just successfully profiled on another Sempron 2600+, running on
Windows XP.

May it be Windows 2000 the source of the problem?

Mauro.
Re: Time-out when launching the process [message #112279 is a reply to message #112125] Wed, 12 September 2007 18:09 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: jeremiah.jahn.gmail.com

In case your curious, I'm also having this problem. What's strang about
it, is that it depends on which unit test I'm trying to run.

It'll work for one test and not another. This seems to be a classpath
related issue. When I limit the number of class path entries to only those
that are exported, then the error seems to go away. I have multiple
prjoject dependencies for the project I'm trying to profile. If I switch
to a simple classpath project, ie just rt.jar or something it works fine.
It's quite often that i'll have a jar in one project that is just there
for compilation but I'll also include it in an additional project that
uses my lib. So there are certian jar that show up in profile dialog's
classpath 4 and 5 times. jdom.jar and junit being good examples. When i
click that button things seem to work okay. except for:

java.lang.ClassNotFoundException:
at java.net.URLClassLoader$1.run(URLClassLoader.java:200)

which shows up everywhere but doesn't seem to have an effect.
Re: Time-out when launching the process [message #112292 is a reply to message #112279] Thu, 13 September 2007 07:12 Go to previous messageGo to next message
Igor Alelekov is currently offline Igor AlelekovFriend
Messages: 139
Registered: July 2009
Senior Member
Hi,
The Mauro's problem is resolved by the
https://bugs.eclipse.org/bugs/show_bug.cgi?id=201474.
Hope this fix (will be available soon) resolves your problem as well.
Regards,
Igor
Re: Time-out when launching the process [message #114793 is a reply to message #112292] Wed, 10 October 2007 02:18 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: _NO_SPAM_PLZ_achan.progress.com

Hi,

What version contains this bug fix? I'm getting a similar stack trace but
now exactly the same:

org.eclipse.core.runtime.CoreException
A time-out occurred while attempting to launch the process

org.eclipse.core.runtime.CoreException: A time-out occurred while attempting
to launch the process
at
org.eclipse.tptp.trace.ui.internal.launcher.core.LauncherUti lity.createCoreException(LauncherUtility.java:123)
at
org.eclipse.tptp.trace.ui.internal.launcher.core.LauncherUti lity.createCoreException(LauncherUtility.java:131)
at
org.eclipse.tptp.platform.jvmti.client.internal.launcher.TID elegateHelper.handleError(TIDelegateHelper.java:597)
at
org.eclipse.tptp.platform.jvmti.client.internal.launcher.TID elegateHelper.launchProcess(TIDelegateHelper.java:513)
at
org.eclipse.tptp.platform.jvmti.client.internal.launcher.TID elegateHelper.launch(TIDelegateHelper.java:313)
at
org.eclipse.tptp.platform.jvmti.client.internal.launcher.TIJ avaLauncherDelegate.launch(TIJavaLauncherDelegate.java:37)
at
org.eclipse.tptp.trace.ui.internal.launcher.core.LauncherUti lity.delegateInit(LauncherUtility.java:1153)
at
org.eclipse.tptp.trace.ui.provisional.launcher.PrimaryLaunch Delegate.run(PrimaryLaunchDelegate.java:196)
at java.lang.Thread.run(Unknown Source)

I'm using the

tptp.runtime.allInOne.win32.win32.x86-TPTP-4.4.1-20071003010 0.zip

I was able to profile a simple HelloWorld app but not my large project.

Thanks.

-Aston


"Igor Alelekov" <igor.alelekov@intel.com> wrote in message
news:f5fa2af89964e9a0aabf8758fac897f6$1@www.eclipse.org...
> Hi,
> The Mauro's problem is resolved by the
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=201474.
> Hope this fix (will be available soon) resolves your problem as well.
> Regards,
> Igor
>
Re: Time-out when launching the process [message #114830 is a reply to message #114793] Wed, 10 October 2007 07:11 Go to previous messageGo to next message
Igor Alelekov is currently offline Igor AlelekovFriend
Messages: 139
Registered: July 2009
Senior Member
Hi Aston,
Build 200710030100 should contain the above mentioned fix.
Are you using Integrated Agent Controller?
Regards,
Igor
Re: Time-out when launching the process [message #114864 is a reply to message #114830] Wed, 10 October 2007 08:49 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: mauro.molinari.cardinis.com

Igor Alelekov ha scritto:
> Hi Aston,
> Build 200710030100 should contain the above mentioned fix.
> Are you using Integrated Agent Controller?
> Regards,
> Igor

Hi Igor, I just tried build 200709101254, the latest candidate, which
should contain the patch, but actually it does not work yet...

That's my fault: when you closed the bug, I didn't verified the fix with
the new release, I trusted your patched DLL that you attached to the bug
report.
I'm adding some new comments to the original bug report to help you
track down the problem again...

Mauro.
Re: Time-out when launching the process [message #114906 is a reply to message #114793] Wed, 10 October 2007 09:22 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: mauro.molinari.cardinis.com

A Chan ha scritto:
> I'm using the
>
> tptp.runtime.allInOne.win32.win32.x86-TPTP-4.4.1-20071003010 0.zip
>
> I was able to profile a simple HelloWorld app but not my large project.
>
> Thanks.
>
> -Aston

Hi Aston,
please monitor this bug report:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=201474
and add your feedback.
You'll also find an attachment with a modified SocketTL.dll that you can
use with the stand-alone 4.4.1 agent controller to enable you to profile
your application, if you need to do it right now.

Mauro.
Re: Time-out when launching the process [message #114994 is a reply to message #114864] Wed, 10 October 2007 11:22 Go to previous messageGo to next message
Igor Alelekov is currently offline Igor AlelekovFriend
Messages: 139
Registered: July 2009
Senior Member
Hi Mauro,
The build 200709101254 doesn't contain the fix.
Please try a last build.
Regards,
Igor
Re: Time-out when launching the process [message #115072 is a reply to message #114906] Wed, 10 October 2007 14:55 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: _NO_SPAM_PLZ_achan.progress.com

Where can I download SocketTL.dll ?

Do I need to upgrade to AgentController 4.4.1?

Thanks.

-aston


"Mauro Molinari" <mauro.molinari@cardinis.com> wrote in message
news:fei5jk$rdd$1@build.eclipse.org...
>A Chan ha scritto:
>> I'm using the
>>
>> tptp.runtime.allInOne.win32.win32.x86-TPTP-4.4.1-20071003010 0.zip
>>
>> I was able to profile a simple HelloWorld app but not my large project.
>>
>> Thanks.
>>
>> -Aston
>
> Hi Aston,
> please monitor this bug report:
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=201474
> and add your feedback.
> You'll also find an attachment with a modified SocketTL.dll that you can
> use with the stand-alone 4.4.1 agent controller to enable you to profile
> your application, if you need to do it right now.
>
> Mauro.
Re: Time-out when launching the process [message #115097 is a reply to message #114906] Wed, 10 October 2007 15:11 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: _NO_SPAM_PLZ_achan.progress.com

Mauro,

Yes, the SocketTL.dll works!

Thanks a million!

-Aston

"Mauro Molinari" <mauro.molinari@cardinis.com> wrote in message
news:fei5jk$rdd$1@build.eclipse.org...
>A Chan ha scritto:
>> I'm using the
>>
>> tptp.runtime.allInOne.win32.win32.x86-TPTP-4.4.1-20071003010 0.zip
>>
>> I was able to profile a simple HelloWorld app but not my large project.
>>
>> Thanks.
>>
>> -Aston
>
> Hi Aston,
> please monitor this bug report:
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=201474
> and add your feedback.
> You'll also find an attachment with a modified SocketTL.dll that you can
> use with the stand-alone 4.4.1 agent controller to enable you to profile
> your application, if you need to do it right now.
>
> Mauro.
Re: Time-out when launching the process [message #115149 is a reply to message #115072] Wed, 10 October 2007 16:22 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: mauro.molinari.cardinis.com

A Chan ha scritto:
> Where can I download SocketTL.dll ?
>
> Do I need to upgrade to AgentController 4.4.1?
>
> Thanks.
>
> -aston

Yes, of course, you must upgrade to stand-alone AgentController 4.4.1
(build 200710030100 or later) in order to get the patched one.

Mauro.
Re: Time-out when launching the process [message #115161 is a reply to message #114994] Wed, 10 October 2007 16:23 Go to previous message
Eclipse UserFriend
Originally posted by: mauro.molinari.cardinis.com

Igor Alelekov ha scritto:
> Hi Mauro,
> The build 200709101254 doesn't contain the fix.
> Please try a last build.
> Regards,
> Igor
>

You're right, sorry!
Actually, with the latest development build it works, using the
stand-alone agent controller.
It doesn't work yet with the IAC.
I'm writing in the bug report.

Thanks again!

Mauro.
Previous Topic:Monitor stop collecting data after a few seconds
Next Topic:help! CoreException
Goto Forum:
  


Current Time: Sun Dec 21 15:11:06 GMT 2014

Powered by FUDForum. Page generated in 0.02658 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software