Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » WindowBuilder » Custom composite problem - replicate/double copy of component
Custom composite problem - replicate/double copy of component [message #855211] Tue, 24 April 2012 16:03 Go to next message
Charles anon is currently offline Charles anon
Messages: 13
Registered: December 2011
Junior Member
I have created a simple custom composite component (a label and progress bar) and after adding it to the palette, I then introduce it to the UI viewer. However, the component is displayed twice. See the attached screenshot.

...Help?
Re: Custom composite problem - replicate/double copy of component [message #855217 is a reply to message #855211] Tue, 24 April 2012 16:08 Go to previous messageGo to next message
Konstantin Scheglov is currently offline Konstantin Scheglov
Messages: 554
Registered: July 2009
Senior Member
I don't remember already exactly why, but this seems to be related to XWT rendering process.
First it creates Composite class (during this it renders XWT template on it), and then it renders XWT template on the form where your place this component. So, you have XWT template rendered twice. I don't have plans to fix this. Please contact XWT authors, not XWT Designer.


Konstantin Scheglov,
Google, Inc.
Re: Custom composite problem - replicate/double copy of component [message #855915 is a reply to message #855217] Wed, 25 April 2012 07:45 Go to previous messageGo to next message
Charles anon is currently offline Charles anon
Messages: 13
Registered: December 2011
Junior Member
Ok, I'm waiting confirmation for joining the wb-xwt-dev mailing list (I hope this is what you meant, I could not figure out where the registration was for those listed at wwwDOTxwtDOTorg/supportDOThtml).
Re: Custom composite problem - replicate/double copy of component [message #856193 is a reply to message #855915] Wed, 25 April 2012 13:02 Go to previous message
Konstantin Scheglov is currently offline Konstantin Scheglov
Messages: 554
Registered: July 2009
Senior Member
Actually WB-xwt is still WindowBuilder mailing list, so still wrong direction Smile
You should contact authors of http://wiki.eclipse.org/E4/XWT


Konstantin Scheglov,
Google, Inc.
Previous Topic:menuitem not working
Next Topic:Error parsing refactored code
Goto Forum:
  


Current Time: Sat Sep 20 14:06:11 GMT 2014

Powered by FUDForum. Page generated in 0.04627 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software