Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » [AGR] delete project with contents does not work correctly
[AGR] delete project with contents does not work correctly [message #109895] Thu, 23 August 2007 14:11 Go to next message
Matthias Wiskow is currently offline Matthias WiskowFriend
Messages: 25
Registered: July 2009
Junior Member
Hi,

as part of my AGR test suite I create some kind of project, act on it,
and finally delete it. The project deletion is done with the option
"delete also contents in <filesystem location>".

During test execution, the project disappears from the Project Explorer
tree as expected. However, in the workspace's filesystem location the
correspondent project folder remains.

This is true for different types of projects (Java, C, C++) and working
in different perspectives.

Has anyone else experienced this?

Thanks,
Matthias

Environment:
- Windows XP SP2
- TPTP 4.4.0.2 AllinOne + AGR
Re: [AGR] delete project with contents does not work correctly [message #110274 is a reply to message #109895] Mon, 27 August 2007 12:03 Go to previous messageGo to next message
Paul Slauenwhite is currently offline Paul SlauenwhiteFriend
Messages: 970
Registered: July 2009
Senior Member
Hi Matthias,
Using the TPTP 4.4.0.2 driver, I can reproduce this symptom. It is
caused by a change in the path for the deleted resource. The radio buttons
in the confirmation dialog contain the path, which changed, so the correct
radio button cannot be resolved:

<shell descriptive="Confirm Project Delete" referenced="12" return-code="0">

<command descriptive="Also delete contents under
&amp;apos;D:\AC_Hyades_WSAD_Dri..." type="focus" referenceId="13"/>

<command descriptive="Do not delete contents" type="select" referenceId="14"
selection="false"/>

<command descriptive="Also delete contents under
&amp;apos;D:\AC_Hyades_WSAD_Dri..." type="select" referenceId="13"
selection="true"/>

<command descriptive="Yes" type="select" referenceId="15"/>

</shell>

<object descriptive="Shell: Confirm Project Delete" referenceId="12"
id=" org.eclipse.ui.actions.DeleteResourceAction$DeleteProjectDia log ">

<object descriptive="Button: Also delete contents under
&amp;apos;D:\AC_Hyades_WSAD_Dri..." referenceId="13" contextId="shell"
resolverId="org.eclipse.tptp.test.auto.gui.nontrivial" id="{{Also delete
contents under
&amp;apos;D:/AC_Hyades_WSAD_Drivers/TPTP-4.4.0.2/eclipse /workspace/myproj&amp;apos;}}-{{0.3}}{{null}}-{{0.3}}{{4 }}-{{0.3}}{{(500,16)}}-{{0.2}}{{(5,5)}}-{{0.1}}{{0}}-{{0.2}} "/>

<object descriptive="Button: Do not delete contents" referenceId="14"
contextId="shell" resolverId="org.eclipse.tptp.test.auto.gui.nontrivial"
id="{{Do not delete
contents}}-{{0.3}}{{null}}-{{0.3}}{{4}}-{{0.3}}{{(131,16)}}- {{0.2}}{{(5,62)}}-{{0.1}}{{3}}-{{0.2}} "/>

<object descriptive="Button: Yes" referenceId="15" contextId="shell"
resolverId="org.eclipse.tptp.test.auto.gui.adaptive" id="{{0}}-{{1.0}}"/>

</object>

Please open a defect (TPTP Testing product and
Test.Execution.AutoGUIRunner component).

In the meantime, you may want to write a custom widget resolver (see
http://www.eclipse.org/tptp/test/documents/userguides/Intro- Auto-GUI-4-4-0.html#2.4.1).

Paul
"Matthias Wiskow" <matthias.wiskow@windriver.com> wrote in message
news:fak4ia$mk$1@build.eclipse.org...
> Hi,
>
> as part of my AGR test suite I create some kind of project, act on it, and
> finally delete it. The project deletion is done with the option "delete
> also contents in <filesystem location>".
>
> During test execution, the project disappears from the Project Explorer
> tree as expected. However, in the workspace's filesystem location the
> correspondent project folder remains.
>
> This is true for different types of projects (Java, C, C++) and working in
> different perspectives.
>
> Has anyone else experienced this?
>
> Thanks,
> Matthias
>
> Environment:
> - Windows XP SP2
> - TPTP 4.4.0.2 AllinOne + AGR
Re: [AGR] delete project with contents does not work correctly [message #110459 is a reply to message #110274] Tue, 28 August 2007 07:14 Go to previous message
Matthias Wiskow is currently offline Matthias WiskowFriend
Messages: 25
Registered: July 2009
Junior Member
Hi Paul,

I filed Bug #201377 against it.

And I will try the Adaptive Widget Recorder.

Thanks,
Matthias

Paul Slauenwhite wrote:
> Hi Matthias,
> Using the TPTP 4.4.0.2 driver, I can reproduce this symptom. It is
> caused by a change in the path for the deleted resource. The radio buttons
> in the confirmation dialog contain the path, which changed, so the correct
> radio button cannot be resolved:
>
> <shell descriptive="Confirm Project Delete" referenced="12" return-code="0">
>
> <command descriptive="Also delete contents under
> &amp;apos;D:\AC_Hyades_WSAD_Dri..." type="focus" referenceId="13"/>
>
> <command descriptive="Do not delete contents" type="select" referenceId="14"
> selection="false"/>
>
> <command descriptive="Also delete contents under
> &amp;apos;D:\AC_Hyades_WSAD_Dri..." type="select" referenceId="13"
> selection="true"/>
>
> <command descriptive="Yes" type="select" referenceId="15"/>
>
> </shell>
>
> <object descriptive="Shell: Confirm Project Delete" referenceId="12"
> id=" org.eclipse.ui.actions.DeleteResourceAction$DeleteProjectDia log ">
>
> <object descriptive="Button: Also delete contents under
> &amp;apos;D:\AC_Hyades_WSAD_Dri..." referenceId="13" contextId="shell"
> resolverId="org.eclipse.tptp.test.auto.gui.nontrivial" id="{{Also delete
> contents under
> &amp;apos;D:/AC_Hyades_WSAD_Drivers/TPTP-4.4.0.2/eclipse /workspace/myproj&amp;apos;}}-{{0.3}}{{null}}-{{0.3}}{{4 }}-{{0.3}}{{(500,16)}}-{{0.2}}{{(5,5)}}-{{0..1}}{{0}}-{{0.2} } "/>
>
> <object descriptive="Button: Do not delete contents" referenceId="14"
> contextId="shell" resolverId="org.eclipse.tptp.test.auto.gui.nontrivial"
> id="{{Do not delete
> contents}}-{{0.3}}{{null}}-{{0.3}}{{4}}-{{0.3}}{{(131,16)}}- {{0.2}}{{(5,62)}}-{{0.1}}{{3}}-{{0.2}} "/>
>
> <object descriptive="Button: Yes" referenceId="15" contextId="shell"
> resolverId="org.eclipse.tptp.test.auto.gui.adaptive" id="{{0}}-{{1.0}}"/>
>
> </object>
>
> Please open a defect (TPTP Testing product and
> Test.Execution.AutoGUIRunner component).
>
> In the meantime, you may want to write a custom widget resolver (see
> http://www.eclipse.org/tptp/test/documents/userguides/Intro- Auto-GUI-4-4-0.html#2.4.1).
>
> Paul
> "Matthias Wiskow" <matthias.wiskow@windriver.com> wrote in message
> news:fak4ia$mk$1@build.eclipse.org...
>> Hi,
>>
>> as part of my AGR test suite I create some kind of project, act on it, and
>> finally delete it. The project deletion is done with the option "delete
>> also contents in <filesystem location>".
>>
>> During test execution, the project disappears from the Project Explorer
>> tree as expected. However, in the workspace's filesystem location the
>> correspondent project folder remains.
>>
>> This is true for different types of projects (Java, C, C++) and working in
>> different perspectives.
>>
>> Has anyone else experienced this?
>>
>> Thanks,
>> Matthias
>>
>> Environment:
>> - Windows XP SP2
>> - TPTP 4.4.0.2 AllinOne + AGR
>
>
Previous Topic:TPTP for C/C++
Next Topic:Time out problem
Goto Forum:
  


Current Time: Sun Nov 23 03:34:34 GMT 2014

Powered by FUDForum. Page generated in 0.02237 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software