Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » Problem with standard mode execution in different contexts
Problem with standard mode execution in different contexts [message #109573] Mon, 20 August 2007 09:37 Go to next message
Matthias Wiskow is currently offline Matthias Wiskow
Messages: 25
Registered: July 2009
Junior Member
This is a multi-part message in MIME format.
--------------020202030006000108020901
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
</head>
<body bgcolor="#ffffff" text="#000000">
Hi,<br>
I have problems in executing a simple AGR test suite.<br>
<br>
Environment:<br>
- Eclipse 3.3<br>
- TPTP 4.4.0.2 AllinOne + correspondent AGR and Agent Controller<br>
- JRE 1.5 Update 11<br>
- Windows XP SP2<br>
<br>
I folllowed the <a
href=" http://www.eclipse.org/tptp/test/documents/userguides/Intro- Auto-GUI-4-4-0.html">AGR
tutorial</a> and created a small test suite with 4 test cases (create
Java project, add a class, edit the class, delete the project).<br>
Running the test suite in standard mode with "Use current workbench as
context" works fine, both with IAC and external AC.<br>
But I don't manage to run the test when specifying a different Eclipse
3.3 installation (by equinox launcher plug-in) or using the deployment
method described in chapter 2.2.1.<br>
<br>
Symptom: SUT is started, but nothing else happens.<br>
<br>
I also tried it with the SUT having AGR and TPTP platform integrated as
well as with different target platform settings in the plug-in
development preferences.<br>
<br>
Did I miss or misunderstand something?<br>
<br>
I attached a zip with two Agent Controller logs: one of a successful
session and one of a failed session.<br>
<br>
Any help is highly appreciated.<br>
<br>
Thanks,<br>
Matthias<br>
</body>
</html>

--------------020202030006000108020901
Content-Type: application/x-zip-compressed;
name="servicelog.zip"
Content-Transfer-Encoding: base64
Content-Disposition: inline;
filename="servicelog.zip"

UEsDBBQAAAAIAMh4FDe8tLSSVwYAAIMxAAATAAAAc2VydmljZWxvZy5sb2cu ZmFpbO2a/Wvj
OBrHf76D+x+ED4472Lh6l5ybHFiyvVvIdHptdlmWwJA6mtSQ2DnbaWb2r9/H dl467WRuu7OB
0oYW4hfJevRIH38fPfIbWywWRW4mlYvvXF6jtHSTOivyUbZwA49irHpY9yge EdbHrM+YrwOG
Mf7FQ7N5cTOZn+dVPclTdz4deKEKhbFKG2Ipp3FgJOc2jmIuVMAZUR5aVLOB d+VSl925KUqh
8Uk+RR+KEq3y0qXFLM9+hRtZXrvywyR1fZRl00FRznyXzrNl5fx6WS9919h6 WRZ32dSV36F0
MR3Ms6p2uSvDNHXL2k09VEGpMqs/DTyBPQTHFfRr4BEf+8T7z9/++pc3VbEq UwcuWBY5PPC8
tag7hs7M4McWeV0W87krvf298+no0xK8M7ocXe4qe8h9dOmq8V2c32VlkS/a x0T9cfppts7y
8W2xcOObVTafjpuaY+5zMIW2J73NSa/xONYEY/gfT2Z5ndblfFyV6bguJ3m1 LMq6rWDnWWve
YjkajsHK3KU1Da2ffofmWe4QpUx74Mf94MADuYfmRdqO78C7/uX73n9DjCn1 06Jc+pOpvy4r
OF7sS3X9PL/8CWouyyJ1VdU8StBAgn9XN3bvrs4g1FyBqjfZHDyPRkMP1bcw paZNNR5ofM+N
3cPjblzfN53yzrphyepV2zwCK9ysKD9dTJrZeOWa7l9v77ZjeK908zz0cTHP q/7HKht4t3W9
7J+drddrf818mENn4Fxy9vPb4XV66xaT3tY7HoLy/bo152EbCIyvijzLZ9dp 0TrjYhRfXYTD
5k5T1G5MHHjDd99vOnC2swlO35w9YKy59lTsYHpwfBC7CFvOeCBYFHJrjAml 1oziREeBliTe
YJdkcwdQlEACgsolQII6aqB3CLzddAfBNMHiPjzkhcPzAdxy3XplBw9R6rmx I7jUJ3aezg7v
M+njgB9kh4c84ipMKLE8tCwUCSGCi4hpS7igDyXr8sfR++R8GO+1qywWKG0H 8DVRcxXaxfQH
cADYWe3A0c8QHBbQEzh/EBwi1EFwZEKpTULMYwL8BCYQcWQVliRsIkR2AucE zusFBwKwg+A0
GmMiFhmI2Sg1mkUQvQUyTDCPSKw34Nh3F9fvAJdh+OOF/SGOkH339m14EbWL pbQL+MGEfwrw
0r989IKXOzlMp+lltnRAz+54uFnu7QgSkj8iiB6RoGaSw1sNTHnADWP8FKn9 MW6Uz8XhSC3B
obWSRhYrrnCsg0gnNtJBIlgo7VZwznNwfbOg2TMCffjfylV1JzmTZqKjK7co aoj7q4YSmDfb
4UZcE4nWWX2LVqtsipTSWmA16REppz3uiO4FNwT3KGeOfUjFlCj2wuVrY91X 1IvTR+iJI6LX
GvR17SKUnxg8AoNUhhEODWHwum0SfZglWMYmSIwJTIR3Qd+seT2X8ILsxur3 UOS/eoyC4ITR
C8JIBgcxIolVIVWxZAkPQMlCEhjLlRYgbMqQDUbdAOUFCFexghXT55r1j79/ DP/9ipjpjr+A
DVPyxM2L4Eb0BfUDeTjnEEdSEhNZEwqeJJFWUvLIskQaI2JtNtxEoDydADVx 4OSkQL9bgYg4
SdArQSkIBRWwVrXCcKlZQBXHobCBMlqF8RYla0dDtMvhfbZHm3Z5vAM7tC11 byc5/G42aNsr
ezRf/Q4tkYI9u5zfibbj0IZpiJlWWrGYa0JDlbAkMYmiRAllybcKF3rhyvV/ WWLi2X3tcGLp
SCyFxlgMf9pyLmmspdUx5ZxZEcSM7DeeFsXdUzF6pXtSXyKK48f59BNRL5Mo KWWkiEmwNDzG
MjBacBZSbrCKabJVp0uLbtsFw2U3km3LVR9tTuFmBXM4az4ravPn0EC9qhD2 vznQ27TwFJi+
NkuOTVr7xqnGTRz8yPLxoyvvF1M/XS633+3pR9iRP4s6IR5R9wXP3tvJ0kD8 tyP1NAL+dAKP
iFRweJOXShJFTHJYTXEeE8OxVoFgONIyZqG6v7y6TsvVzU0jVff3oF7ZNxHd +fVq2ZTYbyzp
ZxfWnbZ3j0RMFGsTxViLIOISJwYnllutYsYMUXr7IV64HcK4VZqu4TUoT7lN UjTfR6xvs/QW
rR1o0p1DeQHjVZYOZl8+3YWEn8kSewmETT63p8uYb3Iw+2w5xg/T5UdP8G1s OGH0JYx+A1BL
AwQUAAAACABseBQ3+1vXi98IAACkYAAAFgAAAHNlcnZpY2Vsb2cubG9nLnN1 Y2Nlc3PtnHtP
3NgVwP9upX4Ha1pVrbRj7vtBQ6X78i4SITSwVbVCimZsByzN2FPbA6Gfvsfz ggQmGzZQUcZK
JGyPH8fn3p/P037jqum0Ku2oycNVXrZRWuejtqjKs2KaHwwIQnKI1JCgM0z2 ud4nLCaCIoR+
GUQXk2o8mhyWTTsq0/wwOxgYwpJEBRc41owgar02jKGgMUOSSjaIps3FweB9 nubFVZ5FKVx8
VGbRx6qO5mWdp9VFWfwHfijKNq8/jtJ8PyqK7KCqL+I8nRSzJo/bWTuL807W k7q6KrK8/iFK
p9nBpGjavMxrk6b5rM2zQdTAXnXR3hwMOBpEsNzAfR0McIxiPPj7H37/uzdN Na/THFQwq0o4
4eFCouUy3MwF/HFV2dbVZJLXg9vfDrOzmxlo5+zk7GRz8CDKP+XpvNNdKK+K uiqni9P4/fP0
5uK6KM8vq2l+Pp4Xk+y8O/KcxQxEIYuV4Wpl2GkcKYwQ/D8fXZRt2taT86ZO z9t6VDazqm4X
B7hJsRBvOjs7OgcpyzxtiXFx+kM0Kco8IoSqAejxdnDghDAAkypdjO/B4PSX H4f/MAgREqdV
PYtHWXxdN7A8vd1reZ+HJ/+EI2d1leZN052Kc0pAv/Oxu1XXUqCo2wKHjosJ aD46OxpE7SVM
qWxxGKLijhqXJw/Lcf3Q3dRgbzksRTtfXD4CKfKLqr45HnWz8X3e3f7p+tfF GN7Zuztf9Gk6
KZv9T01xMLhs29n+3t719XV8TWOYQ3ugXLz3r7dHp+llPh0N19oZRLD/frsQ 58trRCB8U5VF
eXGaVgtlHJ+F98fmqPul29WtRDwYHL37cXUDexuZYPXN3heMddseix2PMcyL bdhJQxk3OFiq
GHfaauYI8YnB2hsi0Qq7pJjkAEUNJERwcA2QREtq4O4i0HZ3OxFME8TvwoNf OTwfQS2nC61s
4MFSvjR2mOI9O49lh+4jvE9JTBXZyk5ivKJYYmQNMwoZhzUxQWClgkyQ/NJk nfx89iE5PAq3
tquuplG6GMBdoua9cdPsJ1AAyNlswFEvEBzSSdCD85vAYURvNzqOcC5xQrxl hnObUALkJAxb
R7ChPTg9OLsLjtbbLY6wMG2sdAx5ZonRLKHeIwEGngoh1hbHvTs+fQe4HJmf j91PwUfu3du3
5tgvgqV06fCDCH/hoKW/xtErDndKmE7ZSTHLgZ7N8tEq3NsQxAW7RxB5RoK6 SQ5PNRDlHjei
5+a3ccNiTrcbHIu98EZjOI4BJ5pa57XAliGXeO5W3ByWoPouoLllBO7h3/O8 aZcmZ9RN9Oh9
Pq1a8PubjhKYN+vhjihWLLou2stoPi+ySIixygRTQ5xpPGSYfxyORxiWeEpS ggVOef7KzddK
uq9YL0buocefEb2FQL8SLaEewWdA0CDjPeMuBMlcgrUFDhPquCUuISRsfL6L 7ulcw/NxOVTf
AlG88xRp3VP0eijibCtFKnChA/LgATIlghUBJ9aBTUOBc7E2ZMvxKSswW9Uc 4qXPLdaf//jJ
/G2HkFkuP0ANlaLH5nVgw3EMEdBWbIJlglEbKPPwj2hnnaIUnEFJVUDmcf5f WEzkqv7T3drS
5c0oy5t4M8njy1FdwlyIQZthvdGP2tHJco5AJHbHcyRU3PUcFcuylI/ZMB2P syGjWT4cp4QP
Jf+YpmMiMsJU7zn2nuNuwOsohGuUOEkcU8Zp7hKRYOoxpiKRdJvn+C0Q9Z5j 7znuCEVIUCkR
FipoBjpWhkgsrEdEc6xF2OI5PpWt633O3ufcMeCU8Ahb6qXGLNFGK8kN0sjJ IJGx8guz1bmd
n3mD9xqXJvnFKL2Jn4jIXaqbPdDjhAl+gX0aPYi/DUQSI769s5BijwUnQhHP qKBGWeyZAttH
ArWEr0A8AYFHCwyXj8wRxH9Xrz0//w3lZcFpX15+NaSwmPDtJgvmjKGCGO09 kzyoRGqBsVXe
AjwmWZHiIci6NVqjPk3/zcEW5n20tRskMYw1VQqhhDLskBZeMmsRR0x7bddt tc6dHUWbNqfP
2tjTZavTlib2BXRvRyX8XfWwL7bckrnzTez4JdqtHrZngQ0RSaShJmDOuMcm SAExl0LU2ERo
+r1mK9r1WInyF/c+SI/SM9mthHobEmEZYi4hypDAuQpOa22VIpukxbS6eixF O9q0+xBQDN1v
OOyB+v8FSpLtnYeI2CQxhoHrh5C1RGsugS/nlScIr5MPLrpcBAur/Nziys1+ tFqFHxuYwkX3
2tWiSgwXaOdNhOLv9vJWV3gMS1+bJc8N2uKB05x3TvA9yc/vbfkwzeJ0Nlu/ 16juUYefCjrM
70H3gGZvcYOwmjwBUo8j4MkJfD6kKNqez/OCsMQGLLxmjmEFzl6w4PLZRDNK yN3Y6jSt5+Px
3dx616O7Y0m95frpfNbtcds+oV6eU9e3vz8PMeDQUSoShbEHr85qiiQYI+yl E1hsOijMegjD
wtIsL3wNlqdeZyi690euL4v0MrrOwSZd5VFZwXjVdQ6zr8w2HuFnZom+BsJG n8uzrO+uEjC3
tV2EvizuPntybyVDj9H/ACNOpEWecuMYE5iZoJD22FppDVgh/n2+HOG69+Z6 b+61eXNkH/MY
0e0foAiOAkEJ10ExHqiW2HiKVNAEIicpv5K86xv8+prTDpmnXyXJQiBEZcK8 0gwFbKXjGEvG
ZaISQ3xfc+prTj1sTwWbUqBZwmlQnBmndGCeBBw8Rppjxr7XbPU1p77mtCso 4YQKnZhABWWE
Scsd2CymNLLe+O7TVQ/VnL6Nor7m1NecXiNQMqboKzUnGYzyDBNtmGDOWsYZ 594gywnFoq85
9VmKPkvxOKS0ClrYkGihASUL7p4zFnCyimtrcZ9B7zPovWXqMNIx7hLo2xrM OXYGS+aEY4qC
YSLCOyG5wRaFhN5NUdwv3XavRfWl2xdauqWS9MQ8CzEocIypFwnrOso9xSFB 3lLqJE7WeQbT
EdO01ax7xy+ZzJvLJ/9WxdVoUmRRBlvd7dcxOEL0NX8/sDvgbor9ocAKafTS Euw9jCsY/wtQ
SwECFAAUAAAACADIeBQ3vLS0klcGAACDMQAAEwAAAAAAAAABACAAAAAAAAAA c2VydmljZWxv
Zy5sb2cuZmFpbFBLAQIUABQAAAAIAGx4FDf7W9eL3wgAAKRgAAAWAAAAAAAA AAEAIAAAAIgG
AABzZXJ2aWNlbG9nLmxvZy5zdWNjZXNzUEsFBgAAAAACAAIAhQAAAJsPAAAA AA==
--------------020202030006000108020901--
Re: Problem with standard mode execution in different contexts [message #109725 is a reply to message #109573] Tue, 21 August 2007 06:56 Go to previous messageGo to next message
Paul Slauenwhite is currently offline Paul Slauenwhite
Messages: 970
Registered: July 2009
Senior Member
This is a multi-part message in MIME format.

------=_NextPart_000_0083_01C7E3C8.D36A6C80
Content-Type: text/plain;
charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

Hi Matthias,
Are you clearing the existing workspace or using a new workspace =
when running in a new context? Also, what string are you specifying in =
the Eclipse Location text field:

http://www.eclipse.org/tptp/test/documents/userguides/auto-g ui-images-4-4=
-0/overview-page-4-4-0.png

Paul
"Matthias Wiskow" <matthias.wiskow@windriver.com> wrote in message =
news:fac5eo$7ct$1@build.eclipse.org...
Hi,
I have problems in executing a simple AGR test suite.

Environment:
- Eclipse 3.3
- TPTP 4.4.0.2 AllinOne + correspondent AGR and Agent Controller
- JRE 1.5 Update 11
- Windows XP SP2

I folllowed the AGR tutorial and created a small test suite with 4 =
test cases (create Java project, add a class, edit the class, delete the =
project).
Running the test suite in standard mode with "Use current workbench as =
context" works fine, both with IAC and external AC.
But I don't manage to run the test when specifying a different Eclipse =
3.3 installation (by equinox launcher plug-in) or using the deployment =
method described in chapter 2.2.1.

Symptom: SUT is started, but nothing else happens.

I also tried it with the SUT having AGR and TPTP platform integrated =
as well as with different target platform settings in the plug-in =
development preferences.

Did I miss or misunderstand something?

I attached a zip with two Agent Controller logs: one of a successful =
session and one of a failed session.

Any help is highly appreciated.

Thanks,
Matthias

------=_NextPart_000_0083_01C7E3C8.D36A6C80
Content-Type: text/html;
charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=3DContent-Type content=3D"text/html; =
charset=3Diso-8859-1">
<META content=3D"MSHTML 6.00.6000.16481" name=3DGENERATOR>
<STYLE></STYLE>
</HEAD>
<BODY text=3D#000000 bgColor=3D#ffffff>
<DIV><FONT face=3DArial size=3D2>Hi Matthias,</FONT></DIV>
<DIV><FONT face=3DArial size=3D2>&nbsp;&nbsp;&nbsp; Are you clearing the =
existing=20
workspace or using a new workspace when running in a new context?&nbsp; =
Also,=20
what string are you specifying in the Eclipse Location text =
field:</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2><A=20
href=3D" http://www.eclipse.org/tptp/test/documents/userguides/auto-g ui-im=
ages-4-4-0/overview-page-4-4-0.png">http://www.eclipse.org/tptp/test/docu=
ments/userguides/auto-gui-images-4-4-0/overview-page-4-4-0.p ng </A></FONT>=
</DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>Paul</FONT></DIV>
<BLOCKQUOTE=20
style=3D"PADDING-RIGHT: 0px; PADDING-LEFT: 5px; MARGIN-LEFT: 5px; =
BORDER-LEFT: #000000 2px solid; MARGIN-RIGHT: 0px">
<DIV>"Matthias Wiskow" &lt;<A=20
=
href=3D"mailto:matthias.wiskow@windriver.com">matthias.wiskow@windriver.c=
om</A>&gt;=20
wrote in message <A=20
=
href=3D"news:fac5eo$7ct$1@build.eclipse.org">news:fac5eo$7ct$1@build.ecli=
pse.org</A>...</DIV>Hi,<BR>I=20
have problems in executing a simple AGR test =
suite.<BR><BR>Environment:<BR>-=20
Eclipse 3.3<BR>- TPTP 4.4.0.2 AllinOne + correspondent AGR and Agent=20
Controller<BR>- JRE 1.5 Update 11<BR>- Windows XP SP2<BR><BR>I =
folllowed the=20
<A=20
=
href=3D" http://www.eclipse.org/tptp/test/documents/userguides/Intro- Auto-=
GUI-4-4-0.html">AGR=20
tutorial</A> and created a small test suite with 4 test cases (create =
Java=20
project, add a class, edit the class, delete the project).<BR>Running =
the test=20
suite in standard mode with "Use current workbench as context" works =
fine,=20
both with IAC and external AC.<BR>But I don't manage to run the test =
when=20
specifying a different Eclipse 3.3 installation (by equinox launcher =
plug-in)=20
or using the deployment method described in chapter =
2.2.1.<BR><BR>Symptom: SUT=20
is started, but nothing else happens.<BR><BR>I also tried it with the =
SUT=20
having AGR and TPTP platform integrated as well as with different =
target=20
platform settings in the plug-in development preferences.<BR><BR>Did I =
miss or=20
misunderstand something?<BR><BR>I attached a zip with two Agent =
Controller=20
logs: one of a successful session and one of a failed =
session.<BR><BR>Any help=20
is highly =
appreciated.<BR><BR>Thanks,<BR>Matthias<BR></BLOCKQUOTE ></BODY></HTML>

------=_NextPart_000_0083_01C7E3C8.D36A6C80--
Re: Problem with standard mode execution in different contexts [message #109732 is a reply to message #109725] Tue, 21 August 2007 09:08 Go to previous messageGo to next message
Matthias Wiskow is currently offline Matthias Wiskow
Messages: 25
Registered: July 2009
Junior Member
Hi Paul,
thanks for your reply.
Please see inserted answers below.

Does the target platform in the plug-in development preference settings
play a role?

Matthias

Paul Slauenwhite wrote:
> Hi Matthias,
> Are you clearing the existing workspace or using a new workspace
> when running in a new context?
I tried both, but it made no difference.

Also, what string are you specifying in
> the Eclipse Location text field:
I inserted the absolute path to the equinox launcher plug-in. Since I'm
working on Windows it looks like
D:\eclipse\plugins\org.eclipse.equinox.launcher_1.0.0.v20070 606.jar

>
> http://www.eclipse.org/tptp/test/documents/userguides/auto-g ui-images-4-4-0/overview-page-4-4-0.png
>
> Paul
>
> "Matthias Wiskow" <matthias.wiskow@windriver.com
> <mailto:matthias.wiskow@windriver.com>> wrote in message
> news:fac5eo$7ct$1@build.eclipse.org...
> Hi,
> I have problems in executing a simple AGR test suite.
>
> Environment:
> - Eclipse 3.3
> - TPTP 4.4.0.2 AllinOne + correspondent AGR and Agent Controller
> - JRE 1.5 Update 11
> - Windows XP SP2
>
> I folllowed the AGR tutorial
> < http://www.eclipse.org/tptp/test/documents/userguides/Intro- Auto-GUI-4-4-0.html>
> and created a small test suite with 4 test cases (create Java
> project, add a class, edit the class, delete the project).
> Running the test suite in standard mode with "Use current workbench
> as context" works fine, both with IAC and external AC.
> But I don't manage to run the test when specifying a different
> Eclipse 3.3 installation (by equinox launcher plug-in) or using the
> deployment method described in chapter 2.2.1.
>
> Symptom: SUT is started, but nothing else happens.
>
> I also tried it with the SUT having AGR and TPTP platform integrated
> as well as with different target platform settings in the plug-in
> development preferences.
>
> Did I miss or misunderstand something?
>
> I attached a zip with two Agent Controller logs: one of a successful
> session and one of a failed session.
>
> Any help is highly appreciated.
>
> Thanks,
> Matthias
Re: Problem with standard mode execution in different contexts [message #109881 is a reply to message #109732] Thu, 23 August 2007 09:56 Go to previous messageGo to next message
Matthias Wiskow is currently offline Matthias Wiskow
Messages: 25
Registered: July 2009
Junior Member
Hi,
problem solved :-)
It was most probably all my bad :-(
After adding TPTP AllinOne + AGR via extension location to my SUT
everything works fine now.

I have been looking around for information of how to set up the SUT for
AGR test execution, but didn't find any documentation.
Did I miss some doc out there?

Perhaps it would be great to add correspondent remarks to the AGR
tutorial. It describes the deployment setup in detail, but leaves the
beginner alone in finding out how to setup the test candidate.

Anyway, thanks for your help!

Matthias

Matthias Wiskow wrote:
> Hi Paul,
> thanks for your reply.
> Please see inserted answers below.
>
> Does the target platform in the plug-in development preference settings
> play a role?
>
> Matthias
>
> Paul Slauenwhite wrote:
>> Hi Matthias,
>> Are you clearing the existing workspace or using a new workspace
>> when running in a new context?
> I tried both, but it made no difference.
>
> Also, what string are you specifying in
>> the Eclipse Location text field:
> I inserted the absolute path to the equinox launcher plug-in. Since I'm
> working on Windows it looks like
> D:\eclipse\plugins\org.eclipse.equinox.launcher_1.0.0.v20070 606.jar
>
>>
>> http://www.eclipse.org/tptp/test/documents/userguides/auto-g ui-images-4-4-0/overview-page-4-4-0.png
>>
>>
>> Paul
>>
>> "Matthias Wiskow" <matthias.wiskow@windriver.com
>> <mailto:matthias.wiskow@windriver.com>> wrote in message
>> news:fac5eo$7ct$1@build.eclipse.org...
>> Hi,
>> I have problems in executing a simple AGR test suite.
>>
>> Environment:
>> - Eclipse 3.3
>> - TPTP 4.4.0.2 AllinOne + correspondent AGR and Agent Controller
>> - JRE 1.5 Update 11
>> - Windows XP SP2
>>
>> I folllowed the AGR tutorial
>>
>> < http://www.eclipse.org/tptp/test/documents/userguides/Intro- Auto-GUI-4-4-0.html>
>>
>> and created a small test suite with 4 test cases (create Java
>> project, add a class, edit the class, delete the project).
>> Running the test suite in standard mode with "Use current workbench
>> as context" works fine, both with IAC and external AC.
>> But I don't manage to run the test when specifying a different
>> Eclipse 3.3 installation (by equinox launcher plug-in) or using the
>> deployment method described in chapter 2.2.1.
>>
>> Symptom: SUT is started, but nothing else happens.
>>
>> I also tried it with the SUT having AGR and TPTP platform integrated
>> as well as with different target platform settings in the plug-in
>> development preferences.
>>
>> Did I miss or misunderstand something?
>>
>> I attached a zip with two Agent Controller logs: one of a successful
>> session and one of a failed session.
>>
>> Any help is highly appreciated.
>>
>> Thanks,
>> Matthias
Re: Problem with standard mode execution in different contexts [message #110202 is a reply to message #109732] Mon, 27 August 2007 07:17 Go to previous messageGo to next message
Paul Slauenwhite is currently offline Paul Slauenwhite
Messages: 970
Registered: July 2009
Senior Member
Hi Matthias,
The classpath variable ECLIPSE_HOME is used to by default for this AGR
property. The ECLIPSE_HOME variable is populated by the target platform.

Paul
"Matthias Wiskow" <matthias.wiskow@windriver.com> wrote in message
news:faeo5v$o0n$1@build.eclipse.org...
> Hi Paul,
> thanks for your reply.
> Please see inserted answers below.
>
> Does the target platform in the plug-in development preference settings
> play a role?
>
> Matthias
>
> Paul Slauenwhite wrote:
>> Hi Matthias,
>> Are you clearing the existing workspace or using a new workspace when
>> running in a new context?
> I tried both, but it made no difference.
>
> Also, what string are you specifying in
>> the Eclipse Location text field:
> I inserted the absolute path to the equinox launcher plug-in. Since I'm
> working on Windows it looks like
> D:\eclipse\plugins\org.eclipse.equinox.launcher_1.0.0.v20070 606.jar
>
>>
>> http://www.eclipse.org/tptp/test/documents/userguides/auto-g ui-images-4-4-0/overview-page-4-4-0.png
>> Paul
>>
>> "Matthias Wiskow" <matthias.wiskow@windriver.com
>> <mailto:matthias.wiskow@windriver.com>> wrote in message
>> news:fac5eo$7ct$1@build.eclipse.org...
>> Hi,
>> I have problems in executing a simple AGR test suite.
>>
>> Environment:
>> - Eclipse 3.3
>> - TPTP 4.4.0.2 AllinOne + correspondent AGR and Agent Controller
>> - JRE 1.5 Update 11
>> - Windows XP SP2
>>
>> I folllowed the AGR tutorial
>>
>> < http://www.eclipse.org/tptp/test/documents/userguides/Intro- Auto-GUI-4-4-0.html>
>> and created a small test suite with 4 test cases (create Java
>> project, add a class, edit the class, delete the project).
>> Running the test suite in standard mode with "Use current workbench
>> as context" works fine, both with IAC and external AC.
>> But I don't manage to run the test when specifying a different
>> Eclipse 3.3 installation (by equinox launcher plug-in) or using the
>> deployment method described in chapter 2.2.1.
>>
>> Symptom: SUT is started, but nothing else happens.
>>
>> I also tried it with the SUT having AGR and TPTP platform integrated
>> as well as with different target platform settings in the plug-in
>> development preferences.
>>
>> Did I miss or misunderstand something?
>>
>> I attached a zip with two Agent Controller logs: one of a successful
>> session and one of a failed session.
>>
>> Any help is highly appreciated.
>>
>> Thanks,
>> Matthias
Re: Problem with standard mode execution in different contexts [message #110215 is a reply to message #109881] Mon, 27 August 2007 07:20 Go to previous message
Paul Slauenwhite is currently offline Paul Slauenwhite
Messages: 970
Registered: July 2009
Senior Member
Hi Matthias,
Correct, you will need the same dependencies and levels in the target
context.

There is no documentation on configuration the SUT. I have a comment to
https://bugs.eclipse.org/bugs/show_bug.cgi?id=196239 regarding your request
to update the AGR documentation. You can add yourself to the CC list.

Paul
"Matthias Wiskow" <matthias.wiskow@windriver.com> wrote in message
news:fak3nj$u6t$1@build.eclipse.org...
> Hi,
> problem solved :-)
> It was most probably all my bad :-(
> After adding TPTP AllinOne + AGR via extension location to my SUT
> everything works fine now.
>
> I have been looking around for information of how to set up the SUT for
> AGR test execution, but didn't find any documentation.
> Did I miss some doc out there?
>
> Perhaps it would be great to add correspondent remarks to the AGR
> tutorial. It describes the deployment setup in detail, but leaves the
> beginner alone in finding out how to setup the test candidate.
>
> Anyway, thanks for your help!
>
> Matthias
>
> Matthias Wiskow wrote:
>> Hi Paul,
>> thanks for your reply.
>> Please see inserted answers below.
>>
>> Does the target platform in the plug-in development preference settings
>> play a role?
>>
>> Matthias
>>
>> Paul Slauenwhite wrote:
>>> Hi Matthias,
>>> Are you clearing the existing workspace or using a new workspace
>>> when running in a new context?
>> I tried both, but it made no difference.
>>
>> Also, what string are you specifying in
>>> the Eclipse Location text field:
>> I inserted the absolute path to the equinox launcher plug-in. Since I'm
>> working on Windows it looks like
>> D:\eclipse\plugins\org.eclipse.equinox.launcher_1.0.0.v20070 606.jar
>>
>>>
>>> http://www.eclipse.org/tptp/test/documents/userguides/auto-g ui-images-4-4-0/overview-page-4-4-0.png
>>> Paul
>>>
>>> "Matthias Wiskow" <matthias.wiskow@windriver.com
>>> <mailto:matthias.wiskow@windriver.com>> wrote in message
>>> news:fac5eo$7ct$1@build.eclipse.org...
>>> Hi,
>>> I have problems in executing a simple AGR test suite.
>>>
>>> Environment:
>>> - Eclipse 3.3
>>> - TPTP 4.4.0.2 AllinOne + correspondent AGR and Agent Controller
>>> - JRE 1.5 Update 11
>>> - Windows XP SP2
>>>
>>> I folllowed the AGR tutorial
>>>
>>> < http://www.eclipse.org/tptp/test/documents/userguides/Intro- Auto-GUI-4-4-0.html>
>>> and created a small test suite with 4 test cases (create Java
>>> project, add a class, edit the class, delete the project).
>>> Running the test suite in standard mode with "Use current workbench
>>> as context" works fine, both with IAC and external AC.
>>> But I don't manage to run the test when specifying a different
>>> Eclipse 3.3 installation (by equinox launcher plug-in) or using the
>>> deployment method described in chapter 2.2.1.
>>>
>>> Symptom: SUT is started, but nothing else happens.
>>>
>>> I also tried it with the SUT having AGR and TPTP platform integrated
>>> as well as with different target platform settings in the plug-in
>>> development preferences.
>>>
>>> Did I miss or misunderstand something?
>>>
>>> I attached a zip with two Agent Controller logs: one of a successful
>>> session and one of a failed session.
>>>
>>> Any help is highly appreciated.
>>>
>>> Thanks,
>>> Matthias
Previous Topic:CoreException time-out running tptp on java
Next Topic:AGR- Cannot Identify Widget in IViewPart
Goto Forum:
  


Current Time: Mon Jul 28 20:37:57 EDT 2014

Powered by FUDForum. Page generated in 0.02221 seconds