Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » Error configuring application listener(java.lang.ClassNotFoundException)
Error configuring application listener [message #854010] Mon, 23 April 2012 15:05 Go to next message
tim zchina is currently offline tim zchinaFriend
Messages: 3
Registered: April 2012
Junior Member
I downloaded Virgo Tomcat Server: virgo-tomcat-server-3.5.0.M03 and it runs ok.

Then I download the source code of Virgo-supplied applications from git://git.eclipse.org/gitroot/virgo/org.eclipse.virgo.apps.git. And I build the source code with ant 1.8.2 using "ant clean clean-integration test", then I replaced D:\virgo-tomcat-server-3.5.0.M03\repository\ext\org.eclipse.virgo.apps.admin.web_3.5.0.M03.jar with just now locally build org.eclipse.virgo.apps.admin.web_3.5.0.M03.jar,and keep anything else unchanged.

Now when I startup virgo, I got the following error:

[2012-04-23 22:34:17.032] ERROR Thread-27 o.a.catalina.core.ContainerBase.[Catalina].[localhost].[/admin] Error configuring application listener of class org.springframework.web.context.ContextLoaderListener java.lang.ClassNotFoundException: org.springframework.web.context.ContextLoaderListener
at org.eclipse.gemini.web.tomcat.internal.loading.BundleWebappClassLoader.loadClass(BundleWebappClassLoader.java:307)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
at org.apache.catalina.core.DefaultInstanceManager.loadClass(DefaultInstanceManager.java:415)
at org.apache.catalina.core.DefaultInstanceManager.loadClassMaybePrivileged(DefaultInstanceManager.java:397)
at org.apache.catalina.core.DefaultInstanceManager.newInstance(DefaultInstanceManager.java:118)
at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4660)
at org.apache.catalina.core.StandardContext$1.call(StandardContext.java:5226)
at org.apache.catalina.core.StandardContext$1.call(StandardContext.java:5221)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
at java.util.concurrent.FutureTask.run(FutureTask.java:138)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
at java.lang.Thread.run(Thread.java:662)


Did I miss something or what's wrong?

Thanks in advance.
Tim
Re: Error configuring application listener [message #854640 is a reply to message #854010] Tue, 24 April 2012 05:47 Go to previous messageGo to next message
tim zchina is currently offline tim zchinaFriend
Messages: 3
Registered: April 2012
Junior Member
To get version 3.5.0.M03, I changed the release.type=integration to release.type=milestone in built.property,and added build.stamp=M3.

Maybe my build settings are wrong?
Re: Error configuring application listener [message #867334 is a reply to message #854640] Tue, 01 May 2012 08:38 Go to previous messageGo to next message
Glyn Normington is currently offline Glyn NormingtonFriend
Messages: 1222
Registered: July 2009
Senior Member
To reproduce the 3.5.0.M03 build perfectly, I would recommend you do a git checkout of the tag 3.5.0.M03, then issue "git clean -dfx" to remove any extraneous files, before building with Ant 1.8.x under Java 6.

If the problem reproduces, then compare the manifest in the bundle you built to the official version and see if there's a difference. If there is a difference, then come back here.

Hope that helps!
Re: Error configuring application listener [message #868499 is a reply to message #867334] Wed, 02 May 2012 05:14 Go to previous message
tim zchina is currently offline tim zchinaFriend
Messages: 3
Registered: April 2012
Junior Member
That's OK. thx!
Previous Topic:Weird in war file deployment exception
Next Topic:Virgo 3.5.0.M04 released
Goto Forum:
  


Current Time: Thu Dec 18 16:26:28 GMT 2014

Powered by FUDForum. Page generated in 0.03433 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software