Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Linux Tools Project » Can't install Linux Tools
Can't install Linux Tools [message #9971] Tue, 09 June 2009 16:06 Go to next message
Ermin HasiÃ?eviÃ?â?¡ is currently offline Ermin HasiÃ?eviÃ?â?¡
Messages: 2
Registered: July 2009
Junior Member
Hi, guys!

I try to install Linux tools from archive I downloaded from the internet.
I instruct Eclipse update manager with the location of the archive and
then start the installation process but I get error. I decided to install
autotools for starters but for some reason update manager thinks that some
other plugin that autotools relies on is missing. Error message is this:

Cannot complete the install because one or more required items could not
be found.
Software being installed: Autotools Feature (Incubation)
1.0.3.200905251648
(org.eclipse.linuxtools.cdt.autotools.feature.feature.group
1.0.3.200905251648)
Missing requirement: Autotools Feature (Incubation) 1.0.3.200905251648
(org.eclipse.linuxtools.cdt.autotools.feature.feature.group
1.0.3.200905251648) requires 'org.eclipse.cdt.make.core [5.0.0,6.0.0)' but
it could not be found

I looked at the list of installed plugins and it says that it has:

org.eclipse.cdt.make.core (6.0.0.200905061052) "C/C++ Standard make Build
Core" [Active]

Is there any way to manually override this?

I have Eclipse 3.5RC3 and CDT 6.0 (installed from latest CDT 6.0 master
archive!) on my computer.
Re: Can't install Linux Tools [message #9994 is a reply to message #9971] Tue, 09 June 2009 21:18 Go to previous messageGo to next message
Andrew Overholt is currently offline Andrew Overholt
Messages: 55
Registered: July 2009
Member
On Tue, 2009-06-09 at 16:06 +0000, Ermin Hasičević wrote:
> I have Eclipse 3.5RC3 and CDT 6.0 (installed from latest CDT 6.0
> master archive!) on my computer.

Our update site is for Ganymede (CDT 5) dependencies. You can install
from a zip of our Galileo builds instead. Grab the latest one here:

https://build.eclipse.org/hudson/job/cbi-linuxtools-Galileo/

After adding the zip as an archive in the update dialog, if you see
nothing listed in main pane it's because we have no categories.
Un-check the "group by categories" option at the bottom.

Our forth-coming (July) 0.3 release will target Galileo.

HTH,

Andrew
Re: Can't install Linux Tools [message #478841 is a reply to message #9994] Fri, 07 August 2009 08:28 Go to previous messageGo to next message
Mikael Springer is currently offline Mikael Springer
Messages: 20
Registered: July 2009
Junior Member
Hi.

I download the latest Galileo build as archive.zip. In Eclipse 3.5 I go
to Preferences/"Install/Update"/Available Software Sites and click Add.
I then click "Archive..." and selects the archive.zip file I downloaded.
The site is added with the following URL:

jar:file:/home/micke/dev/galileo/update-sites/linux-tools/ar chive.zip!/

The URL looks exactly like this. It looks a bit strange to me. Is this
correct?

When I try to install anything from this site in the install dialog I
get an error saying "No repository found at
jar:file:/home/micke/dev/galileo/update-sites/linux-tools/ar chive.zip!/. "

What am I doing wrong?

Regards, Micke.

Andrew Overholt wrote:
> On Tue, 2009-06-09 at 16:06 +0000, Ermin Hasičević wrote:
>> I have Eclipse 3.5RC3 and CDT 6.0 (installed from latest CDT 6.0
>> master archive!) on my computer.
>
> Our update site is for Ganymede (CDT 5) dependencies. You can install
> from a zip of our Galileo builds instead. Grab the latest one here:
>
> https://build.eclipse.org/hudson/job/cbi-linuxtools-Galileo/
>
> After adding the zip as an archive in the update dialog, if you see
> nothing listed in main pane it's because we have no categories.
> Un-check the "group by categories" option at the bottom.
>
> Our forth-coming (July) 0.3 release will target Galileo.
>
> HTH,
>
> Andrew
>
Re: Can't install Linux Tools [message #479038 is a reply to message #9994] Sat, 08 August 2009 13:55 Go to previous messageGo to next message
Lorenzo Bettini is currently offline Lorenzo Bettini
Messages: 1362
Registered: July 2009
Senior Member
Andrew Overholt wrote:
> On Tue, 2009-06-09 at 16:06 +0000, Ermin Hasičević wrote:
>> I have Eclipse 3.5RC3 and CDT 6.0 (installed from latest CDT 6.0
>> master archive!) on my computer.
>
> Our update site is for Ganymede (CDT 5) dependencies. You can install
> from a zip of our Galileo builds instead. Grab the latest one here:
>
> https://build.eclipse.org/hudson/job/cbi-linuxtools-Galileo/
>
> After adding the zip as an archive in the update dialog, if you see
> nothing listed in main pane it's because we have no categories.
> Un-check the "group by categories" option at the bottom.
>
> Our forth-coming (July) 0.3 release will target Galileo.
>

Hi

this version does not seem to be available yet (see also my thread
"autotools in Galileo")

--
Lorenzo Bettini, PhD in Computer Science, DI, Univ. Torino
ICQ# lbetto, 16080134 (GNU/Linux User # 158233)
HOME: http://www.lorenzobettini.it MUSIC: http://www.purplesucker.com
http://www.myspace.com/supertrouperabba
BLOGS: http://tronprog.blogspot.com http://longlivemusic.blogspot.com
http://www.gnu.org/software/src-highlite
http://www.gnu.org/software/gengetopt
http://www.gnu.org/software/gengen http://doublecpp.sourceforge.net
Re: Can't install Linux Tools [message #479867 is a reply to message #478841] Wed, 12 August 2009 19:41 Go to previous messageGo to next message
Andrew Overholt is currently offline Andrew Overholt
Messages: 55
Registered: July 2009
Member
We're readying our 0.3 release with a plan of releasing it one week from day (the 19th of August). If you want to try it now, with an Eclipse SDK 3.5, use this update site:

http://download.eclipse.org/technology/linuxtools/updates-ni ghtly

If you can't use the update site, you can grab a zip of the latest build from here:

https://build.eclipse.org/hudson/job/cbi-linuxtools-Galileo/ lastSuccessfulBuild/artifact/

Click on build/<the directory with the big name including 200908something>
Download linuxtools-Update-incubation-<same big date-string as above>.zip
Use it as an archive as you've tried with the update manager
The URI will indeed look funny with the jar and the ! but it is correct

Please let us know if it doesn't work.

Thanks and sorry for the delay,

Andrew
Re: Can't install Linux Tools [message #481527 is a reply to message #479867] Fri, 21 August 2009 12:07 Go to previous messageGo to next message
Lorenzo Bettini is currently offline Lorenzo Bettini
Messages: 1362
Registered: July 2009
Senior Member
Andrew Overholt wrote:
> We're readying our 0.3 release with a plan of releasing it one week from
> day (the 19th of August). If you want to try it now, with an Eclipse
> SDK 3.5, use this update site:
>
> http://download.eclipse.org/technology/linuxtools/updates-ni ghtly
>
> If you can't use the update site, you can grab a zip of the latest build
> from here:
>
> https://build.eclipse.org/hudson/job/cbi-linuxtools-Galileo/ lastSuccessfulBuild/artifact/
>
>
> Click on build/<the directory with the big name including 200908something>
> Download linuxtools-Update-incubation-<same big date-string as above>.zip
> Use it as an archive as you've tried with the update manager
> The URI will indeed look funny with the jar and the ! but it is correct
>
> Please let us know if it doesn't work.
>
> Thanks and sorry for the delay,
>
> Andrew

Hi

I downloaded the zip, and extracted it in the dropins folder, but
eclipse does not seem to detect it...

dropins/
linuxtools/
eclipse/
<plugins> contents
<features> contents

where am I going wrong?

thanks in advance
Lorenzo
--
Lorenzo Bettini, PhD in Computer Science, DI, Univ. Torino
ICQ# lbetto, 16080134 (GNU/Linux User # 158233)
HOME: http://www.lorenzobettini.it MUSIC: http://www.purplesucker.com
http://www.myspace.com/supertrouperabba
BLOGS: http://tronprog.blogspot.com http://longlivemusic.blogspot.com
http://www.gnu.org/software/src-highlite
http://www.gnu.org/software/gengetopt
http://www.gnu.org/software/gengen http://doublecpp.sourceforge.net
Re: Can't install Linux Tools [message #494404 is a reply to message #481527] Fri, 30 October 2009 14:33 Go to previous message
Andrew Overholt is currently offline Andrew Overholt
Messages: 55
Registered: July 2009
Member
Dropins isn't the best way to install things, but I suggest you ask the p2 team as they are experts in this area. i suggest using the UI to install from our update site or from a zip.
Re: Can't install Linux Tools [message #566405 is a reply to message #9971] Tue, 09 June 2009 21:18 Go to previous message
Andrew Overholt is currently offline Andrew Overholt
Messages: 55
Registered: July 2009
Member
On Tue, 2009-06-09 at 16:06 +0000, Ermin Hasičević wrote:
> I have Eclipse 3.5RC3 and CDT 6.0 (installed from latest CDT 6.0
> master archive!) on my computer.

Our update site is for Ganymede (CDT 5) dependencies. You can install
from a zip of our Galileo builds instead. Grab the latest one here:

https://build.eclipse.org/hudson/job/cbi-linuxtools-Galileo/

After adding the zip as an archive in the update dialog, if you see
nothing listed in main pane it's because we have no categories.
Un-check the "group by categories" option at the bottom.

Our forth-coming (July) 0.3 release will target Galileo.

HTH,

Andrew
Re: Can't install Linux Tools [message #566867 is a reply to message #9994] Fri, 07 August 2009 08:30 Go to previous message
Mikael Springer is currently offline Mikael Springer
Messages: 20
Registered: July 2009
Junior Member
Hi.

I download the latest Galileo build as archive.zip. In Eclipse 3.5 I go
to Preferences/"Install/Update"/Available Software Sites and click Add.
I then click "Archive..." and selects the archive.zip file I downloaded.
The site is added with the following URL:

jar:file:/home/micke/dev/galileo/update-sites/linux-tools/ar chive.zip!/

The URL looks exactly like this. It looks a bit strange to me. Is this
correct?

When I try to install anything from this site in the install dialog I
get an error saying "No repository found at
jar:file:/home/micke/dev/galileo/update-sites/linux-tools/ar chive.zip!/. "

What am I doing wrong?

Regards, Micke.

Andrew Overholt wrote:
> On Tue, 2009-06-09 at 16:06 +0000, Ermin Hasičević wrote:
>> I have Eclipse 3.5RC3 and CDT 6.0 (installed from latest CDT 6.0
>> master archive!) on my computer.
>
> Our update site is for Ganymede (CDT 5) dependencies. You can install
> from a zip of our Galileo builds instead. Grab the latest one here:
>
> https://build.eclipse.org/hudson/job/cbi-linuxtools-Galileo/
>
> After adding the zip as an archive in the update dialog, if you see
> nothing listed in main pane it's because we have no categories.
> Un-check the "group by categories" option at the bottom.
>
> Our forth-coming (July) 0.3 release will target Galileo.
>
> HTH,
>
> Andrew
>
Re: Can't install Linux Tools [message #566875 is a reply to message #9994] Sat, 08 August 2009 13:55 Go to previous message
Lorenzo Bettini is currently offline Lorenzo Bettini
Messages: 1362
Registered: July 2009
Senior Member
Andrew Overholt wrote:
> On Tue, 2009-06-09 at 16:06 +0000, Ermin Hasičević wrote:
>> I have Eclipse 3.5RC3 and CDT 6.0 (installed from latest CDT 6.0
>> master archive!) on my computer.
>
> Our update site is for Ganymede (CDT 5) dependencies. You can install
> from a zip of our Galileo builds instead. Grab the latest one here:
>
> https://build.eclipse.org/hudson/job/cbi-linuxtools-Galileo/
>
> After adding the zip as an archive in the update dialog, if you see
> nothing listed in main pane it's because we have no categories.
> Un-check the "group by categories" option at the bottom.
>
> Our forth-coming (July) 0.3 release will target Galileo.
>

Hi

this version does not seem to be available yet (see also my thread
"autotools in Galileo")

--
Lorenzo Bettini, PhD in Computer Science, DI, Univ. Torino
ICQ# lbetto, 16080134 (GNU/Linux User # 158233)
HOME: http://www.lorenzobettini.it MUSIC: http://www.purplesucker.com
http://www.myspace.com/supertrouperabba
BLOGS: http://tronprog.blogspot.com http://longlivemusic.blogspot.com
http://www.gnu.org/software/src-highlite
http://www.gnu.org/software/gengetopt
http://www.gnu.org/software/gengen http://doublecpp.sourceforge.net
Re: Can't install Linux Tools [message #566884 is a reply to message #566867] Wed, 12 August 2009 19:41 Go to previous message
Andrew Overholt is currently offline Andrew Overholt
Messages: 55
Registered: July 2009
Member
We're readying our 0.3 release with a plan of releasing it one week from day (the 19th of August). If you want to try it now, with an Eclipse SDK 3.5, use this update site:

http://download.eclipse.org/technology/linuxtools/updates-ni ghtly

If you can't use the update site, you can grab a zip of the latest build from here:

https://build.eclipse.org/hudson/job/cbi-linuxtools-Galileo/ lastSuccessfulBuild/artifact/

Click on build/<the directory with the big name including 200908something>
Download linuxtools-Update-incubation-<same big date-string as above>.zip
Use it as an archive as you've tried with the update manager
The URI will indeed look funny with the jar and the ! but it is correct

Please let us know if it doesn't work.

Thanks and sorry for the delay,

Andrew
Re: Can't install Linux Tools [message #566915 is a reply to message #566884] Fri, 21 August 2009 12:07 Go to previous message
Lorenzo Bettini is currently offline Lorenzo Bettini
Messages: 1362
Registered: July 2009
Senior Member
Andrew Overholt wrote:
> We're readying our 0.3 release with a plan of releasing it one week from
> day (the 19th of August). If you want to try it now, with an Eclipse
> SDK 3.5, use this update site:
>
> http://download.eclipse.org/technology/linuxtools/updates-ni ghtly
>
> If you can't use the update site, you can grab a zip of the latest build
> from here:
>
> https://build.eclipse.org/hudson/job/cbi-linuxtools-Galileo/ lastSuccessfulBuild/artifact/
>
>
> Click on build/<the directory with the big name including 200908something>
> Download linuxtools-Update-incubation-<same big date-string as above>.zip
> Use it as an archive as you've tried with the update manager
> The URI will indeed look funny with the jar and the ! but it is correct
>
> Please let us know if it doesn't work.
>
> Thanks and sorry for the delay,
>
> Andrew

Hi

I downloaded the zip, and extracted it in the dropins folder, but
eclipse does not seem to detect it...

dropins/
linuxtools/
eclipse/
<plugins> contents
<features> contents

where am I going wrong?

thanks in advance
Lorenzo
--
Lorenzo Bettini, PhD in Computer Science, DI, Univ. Torino
ICQ# lbetto, 16080134 (GNU/Linux User # 158233)
HOME: http://www.lorenzobettini.it MUSIC: http://www.purplesucker.com
http://www.myspace.com/supertrouperabba
BLOGS: http://tronprog.blogspot.com http://longlivemusic.blogspot.com
http://www.gnu.org/software/src-highlite
http://www.gnu.org/software/gengetopt
http://www.gnu.org/software/gengen http://doublecpp.sourceforge.net
Re: Can't install Linux Tools [message #567364 is a reply to message #481527] Fri, 30 October 2009 14:33 Go to previous message
Andrew Overholt is currently offline Andrew Overholt
Messages: 55
Registered: July 2009
Member
Dropins isn't the best way to install things, but I suggest you ask the p2 team as they are experts in this area. i suggest using the UI to install from our update site or from a zip.
Previous Topic:ubuntu launching Eclipse
Next Topic:linux-tools oprofile x64
Goto Forum:
  


Current Time: Wed Oct 01 04:08:16 GMT 2014

Powered by FUDForum. Page generated in 0.02010 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software