Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » Problem with IAC
Problem with IAC [message #109242] Fri, 17 August 2007 00:50
Eclipse User
Originally posted by: gcadien.gmail.com

I'm using Eclipse 3.3 and just installed TPTP to try and do some
profiling. I'm running on Ubuntu 7.04 IA32 and using Sun JDK 1.6_01.

I created a simple test application and tried to profile it. I get the
following error:

org.eclipse.core.runtime.CoreException
Agent Controller is unavailable under port 10002. Make sure that the service is started and the port number is correct under preferences.

java.lang.NullPointerException
at org.eclipse.tptp.platform.iac.administrator.internal.startst op.AutoStartStop.hasProcessTerminated(AutoStartStop.java:275 )
at org.eclipse.tptp.platform.iac.administrator.internal.startst op.AutoStartStop.startIAC(AutoStartStop.java:113)
at org.eclipse.tptp.platform.execution.client.core.internal.Nod eImpl.connect(NodeImpl.java:117)
at org.eclipse.tptp.platform.execution.util.internal.AgentContr ollerPool$1$EstablishConnection.run(AgentControllerPool.java :161)
at java.lang.Thread.run(Thread.java:619)

When I go to Window->Preferences->Agent Controller Integrated Agent
Controller is enabled and the correct java executable to be used is filled
in.

Also, from the Profile Configurations Dialog, if I click and Attach to
Agent and try to create a new Launch Configuration I get the following:

An internal error occurred during: "Fetching children of host".
java.lang.NullPointerException


Thanks,

-geoff
Previous Topic:[AGR] Ant execution blues
Next Topic:Does AGR need the Agent Controller for a standard local_deployment on Linux?
Goto Forum:
  


Current Time: Thu Sep 18 15:43:47 GMT 2014

Powered by FUDForum. Page generated in 0.02105 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software