Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Update problems(Indigo fails to upgrade from 3.7.0 to 3.7.2)
Update problems [message #851128] Fri, 20 April 2012 17:17 Go to next message
Ernesto Posse is currently offline Ernesto PosseFriend
Messages: 46
Registered: March 2011
Member
I have Eclipse 3.7.0 and I'm trying to update to 3.7.2. I have download.eclipse.org/releases/indigo in the software sources, and when I check for updates, it fails saying that

"There were no installable units selected when the plan was computed."

The list of components to update shows

Eclipse Platform 3.7.2.M20120208-0800

with an un-ticked check-box. It won't let me select it directly, but then I click on "Select All" which selects it. Then I click "Next" and it shows the message below:

Cannot complete the install because of a conflicting dependency.
Software being installed: Eclipse Platform 3.7.2.M20120208-0800 (org.eclipse.platform.ide 3.7.2.M20120208-0800)
Software currently installed: Shared profile 1.0.0.1308009974132 (SharedProfile_PlatformProfile 1.0.0.1308009974132)
Only one of the following can be installed at once:
org.eclipse.rcp.configuration_root.gtk.linux.x86_64 1.0.0.M20120208-0800
org.eclipse.rcp.configuration_root.gtk.linux.x86_64 1.0.0.I20110613-1736
Cannot satisfy dependency:
From: Shared profile 1.0.0.1308009974132 (SharedProfile_PlatformProfile 1.0.0.1308009974132)
To: org.eclipse.rcp.configuration_root.gtk.linux.x86_64 [1.0.0.I20110613-1736]
Cannot satisfy dependency:
From: Eclipse Platform 3.7.2.M20120208-0800 (org.eclipse.platform.ide 3.7.2.M20120208-0800)
To: org.eclipse.rcp.configuration.feature.group [1.0.0.M20120208-0800]
Cannot satisfy dependency:
From: Eclipse Product Configuration 1.0.0.M20120208-0800 (org.eclipse.rcp.configuration.feature.group 1.0.0.M20120208-0800)
To: org.eclipse.rcp.configuration_root.gtk.linux.x86_64 [1.0.0.M20120208-0800]


What is the problem and how do I fix it?

Thanks!

Notes:

- I installed a minimal installation of Indigo 3.7.0, specifically the Platform Runtime Binary (eclipse-platform-3.7-linux-gtk-x86_64.tar.gz)

- I run it on Ubuntu 11.10

- I have only two other products, namely PyDev and EclipseFP, No JDT, CDT, etc.
Re: Update problems [message #852312 is a reply to message #851128] Sat, 21 April 2012 22:33 Go to previous message
Jorge Rocha is currently offline Jorge RochaFriend
Messages: 1
Registered: April 2012
Junior Member
Almost the same with me. I've installed eclipse from the repositories.

I was able to do the update only after:

sudo chown -R user:user /usr/lib/eclipse/ /usr/share/eclipse/


Or you can try to do the update as root:

sudo eclipse


and then do the update.
Previous Topic:Eclipse software update: NPE popup on saving edited source
Next Topic:Import and Exit options disabled
Goto Forum:
  


Current Time: Sat Dec 20 19:32:53 GMT 2014

Powered by FUDForum. Page generated in 0.02203 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software