Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » cant target my aplication
cant target my aplication [message #849579] Thu, 19 April 2012 09:13 Go to next message
Javier Martinez is currently offline Javier Martinez
Messages: 7
Registered: April 2012
Junior Member
When i launch my aplication, first i launch a loading screen and then the main aplication, but i can only map the loading screen.
if i try to map my main aplication, i cant.
forgive my horrible english.. thanks
Re: cant target my aplication [message #849594 is a reply to message #849579] Thu, 19 April 2012 09:27 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1149
Registered: July 2009
Senior Member
Hi,

Can you provide some additional details please? What kind of application is it? What platform are you working on? Do any errors come, are there any log entries? Can you not map any components at all, or are there just some that can't be mapped (if so which ones)? What steps are you taking?

Best regards,
Alex
Re: cant target my aplication [message #849619 is a reply to message #849594] Thu, 19 April 2012 09:57 Go to previous messageGo to next message
Javier Martinez is currently offline Javier Martinez
Messages: 7
Registered: April 2012
Junior Member
index.php/fa/7985/0/Windows xp profesional, eclipse 1.2.0

swt aplication, using eclipse to develop it and maven to compile it.
No errors come, no log entries. i have no problems mapping loading screen, but i cant map nothing in the main screen.

connect to aut, then start aut, open my test suite with object mapping editor and try to map it, but i cant, no green square.

my aplication takes 2-3 minutes to launch. maybe this could be a problem...
  • Attachment: step1.JPG
    (Size: 66.21KB, Downloaded 301 times)
Re: cant target my aplication [message #849653 is a reply to message #849619] Thu, 19 April 2012 10:40 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1149
Registered: July 2009
Senior Member
Is your AUT a pure SWT AUT? These are quite rare - I would suspect it is more likely an RCP application - if you set the project and AUT toolkit to RCP, does this solve the problem?
Re: cant target my aplication [message #849665 is a reply to message #849653] Thu, 19 April 2012 10:56 Go to previous messageGo to next message
Javier Martinez is currently offline Javier Martinez
Messages: 7
Registered: April 2012
Junior Member
its a pure SWT.if i run it like rcp, my running AUTs tab is empty even if my application is running...
Re: cant target my aplication [message #849688 is a reply to message #849665] Thu, 19 April 2012 11:20 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1149
Registered: July 2009
Senior Member
Ok, thanks for the clarification. Did I read correctly above that it uses Eclipse 1.2.0? And which SWT version does it use?

Best regards,
Alex
Re: cant target my aplication [message #849696 is a reply to message #849579] Thu, 19 April 2012 11:25 Go to previous messageGo to next message
Achim Loerke is currently offline Achim Loerke
Messages: 335
Registered: July 2009
Location: Braunschweig, Germany
Senior Member

Quote:
first i launch a loading screen and then the main aplication


Does this actually mean you are using two different applications, the first launching the second (main) application?

If so you have to start the AUTAgent in lenient mode (see here) and adjust AUT id's to allow a numbering scheme (see here).

Achim
Re: cant target my aplication [message #849836 is a reply to message #849696] Thu, 19 April 2012 13:46 Go to previous messageGo to next message
Javier Martinez is currently offline Javier Martinez
Messages: 7
Registered: April 2012
Junior Member
Alex:
SWT version 3.2.3, jubula 1.2.0 and eclipse 3.6 (Helios)

Achim:
Im not using 2 applications. my loading screen shows while my main screen is collecting data, and then it is closed, but its not 2 apps.

i was thinking about disable my load screen if i cant fix the problem... and see if it works, but its my last option...
Re: cant target my aplication [message #850686 is a reply to message #849836] Fri, 20 April 2012 08:30 Go to previous messageGo to next message
Javier Martinez is currently offline Javier Martinez
Messages: 7
Registered: April 2012
Junior Member
starting the AUTAgent in lenient mode didnt help. any ideas?
Re: cant target my aplication [message #850711 is a reply to message #850686] Fri, 20 April 2012 08:56 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1149
Registered: July 2009
Senior Member
Hi,

If you only have one application, lenient mode won't be the answer.

The only possibility I can think of is perhaps this ticket. If that's not it, then I'm afraid I'm stuck on this one. Please enter a ticket with the details you have entered here, a description of your application (components it uses, how it is started etc). If you can produce a small example application that reproduces the behaviour, that would be very helpful to help us analyse the problem.

Best regards,
Alex
Re: cant target my aplication [message #869406 is a reply to message #850711] Thu, 03 May 2012 10:58 Go to previous messageGo to next message
Javier Martinez is currently offline Javier Martinez
Messages: 7
Registered: April 2012
Junior Member
Hi
I solved my first problem making some modifications to the loading screen, but now i have a new problem.
There are some components i cant map, like the Ktable. does jubula support Ktable on SWT applications┬┐?
Again, sorry for my poor english.
Thanks.
Re: cant target my aplication [message #870424 is a reply to message #869406] Tue, 08 May 2012 06:46 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1149
Registered: July 2009
Senior Member
Hi,

I'd not heard of the KTable before. A quick Google confirms that it is a custom-drawn component, so it would be reasonable to assume that it is not supported out of the box. For unsupported components, you can either write an extension or have one written for you by the team.

HTH,
Alex
Re: cant target my aplication [message #871530 is a reply to message #870424] Mon, 14 May 2012 10:51 Go to previous messageGo to next message
Javier Martinez is currently offline Javier Martinez
Messages: 7
Registered: April 2012
Junior Member
Can i write extensions for SWT applications?
I was following this tutorial: subshell.com/en/subshell/blog/Extending-Jubula-For-Custom-SWT-Controls-In-RCP-Applications100.html but i dont use the Jubula extension to test RCP applications (rcp-support.zip) because its an SWT application.
Can i just ignore that step?
Thanks.
Re: cant target my aplication [message #871568 is a reply to message #871530] Mon, 14 May 2012 12:46 Go to previous message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1149
Registered: July 2009
Senior Member
Hi,

Yes, Jubula is extensible for SWT applications. You'll not need the step with the RCP-Support, but you will have to place the extension where it can be found by Jubula. The best thing to do would be to look at the Extension Manual and do an analogous implementation to that.

HTH,
Alex
Previous Topic:Store window title
Next Topic:No suitable driver error when running Jubula on 64-bit CentOS
Goto Forum:
  


Current Time: Tue Sep 16 23:45:58 GMT 2014

Powered by FUDForum. Page generated in 0.02726 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software