Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » IMP » Issue with IMP source code checkout and build
Issue with IMP source code checkout and build [message #9824] Fri, 12 October 2007 14:48 Go to next message
Eclipse User
Originally posted by: sandip.sahoo1980.gmail.com

Hi,

I have made CVS checkout and import IMP source code from the site into fresh
Eclipse 3.2.2 as specified here http://sourceforge.net/cvs/?group_id=201858

But there are a lot of errors coming when building because the following
plug-ins which are referenced in this project not available.

** com.ibm.watson.smapifier

** com.ibm.watson.smapi

** polyglot

**java_cup.runtime.lr_parser (jar not available)

** lpg.runtime

** x10.compiler

** x10.runtime


Please suggest me how to resolve the above problem.

Regards,

Sandip
Re: Issue with IMP source code checkout and build [message #9846 is a reply to message #9824] Fri, 12 October 2007 17:48 Go to previous messageGo to next message
Eclipse User
Originally posted by: regenmacher.online.de

Building your own IMP from source you need to install lpg, polyglot, ... ...

details: http://eclipse-imp.sourceforge.net/installing/index.html

michael

"Sandip Sahoo" <sandip.sahoo1980@gmail.com> schrieb im Newsbeitrag
news:feofin$d1i$1@build.eclipse.org...
> Hi,
>
> I have made CVS checkout and import IMP source code from the site into
> fresh Eclipse 3.2.2 as specified here
> http://sourceforge.net/cvs/?group_id=201858
>
> But there are a lot of errors coming when building because the following
> plug-ins which are referenced in this project not available.
>
> ** com.ibm.watson.smapifier
>
> ** com.ibm.watson.smapi
>
> ** polyglot
>
> **java_cup.runtime.lr_parser (jar not available)
>
> ** lpg.runtime
>
> ** x10.compiler
>
> ** x10.runtime
>
>
> Please suggest me how to resolve the above problem.
>
> Regards,
>
> Sandip
>
>
Re: Issue with IMP source code checkout and build [message #9868 is a reply to message #9846] Mon, 15 October 2007 18:43 Go to previous messageGo to next message
Stan Sutton is currently offline Stan Sutton
Messages: 121
Registered: July 2009
Senior Member
As of a couple of hours ago we have some better documentation on how to
get the projects built:

http://eclipse-imp.sourceforge.net/developers/index.html

This is the start of documentation aimed at IMP developers (i.e., people
who will be developing for IMP), as opposed to IMP users (i.e., people
who will be using IMP to create a language IDE). In any case, it has
more extensive information about how to obtain and build the various
projects relating to IMP.

As Michael has already written, you have to separately obtain and
install lpg and polyglot. You can separately obtain the X10 projects if
you want to run X10 (from x10.sourceforge.net), but that's not a central
part of IMP--just an example of an IMP IDE (and there are others in the
release, such as the LPG IDE).

The big problem for the moment is that we originally neglected to
release three projects that should be on the repository:

org.eclipse.imp.smapi
(recently renamed from com.ibm.watson.smapi)

org.eclipse.imp.smapifier
(recently renamed from com.ibm.watson.smapifier)

org.eclipse.imp.lpg.metatooling

We have just submitted these to SourceForge to be included in our CVS
repository, so now it is a question of waiting for that to happen. I
will look into whether we can make these projects available separately.

Regards,

Stan Sutton





Michael Strothjohann wrote:
> Building your own IMP from source you need to install lpg, polyglot, ...
> ...
>
> details: http://eclipse-imp.sourceforge.net/installing/index.html
>
> michael
>
> "Sandip Sahoo" <sandip.sahoo1980@gmail.com> schrieb im Newsbeitrag
> news:feofin$d1i$1@build.eclipse.org...
>> Hi,
>>
>> I have made CVS checkout and import IMP source code from the site into
>> fresh Eclipse 3.2.2 as specified here
>> http://sourceforge.net/cvs/?group_id=201858
>>
>> But there are a lot of errors coming when building because the
>> following plug-ins which are referenced in this project not available.
>>
>> ** com.ibm.watson.smapifier
>>
>> ** com.ibm.watson.smapi
>>
>> ** polyglot
>>
>> **java_cup.runtime.lr_parser (jar not available)
>>
>> ** lpg.runtime
>>
>> ** x10.compiler
>>
>> ** x10.runtime
>>
>>
>> Please suggest me how to resolve the above problem.
>>
>> Regards,
>>
>> Sandip
>>
>>
>
Re: Issue with IMP source code checkout and build [message #9914 is a reply to message #9868] Tue, 16 October 2007 03:08 Go to previous message
Eclipse User
Originally posted by: sandip.sahoo1980.gmail.com

Thanks!

I will try to do the same as you suggested below and let you know.


"Stanley Sutton" <suttons@us.ibm.com> wrote in message
news:ff0qec$mps$1@build.eclipse.org...
>
> As of a couple of hours ago we have some better documentation on how to
> get the projects built:
>
> http://eclipse-imp.sourceforge.net/developers/index.html
>
> This is the start of documentation aimed at IMP developers (i.e., people
> who will be developing for IMP), as opposed to IMP users (i.e., people who
> will be using IMP to create a language IDE). In any case, it has more
> extensive information about how to obtain and build the various projects
> relating to IMP.
>
> As Michael has already written, you have to separately obtain and install
> lpg and polyglot. You can separately obtain the X10 projects if you want
> to run X10 (from x10.sourceforge.net), but that's not a central part of
> IMP--just an example of an IMP IDE (and there are others in the release,
> such as the LPG IDE).
>
> The big problem for the moment is that we originally neglected to release
> three projects that should be on the repository:
>
> org.eclipse.imp.smapi
> (recently renamed from com.ibm.watson.smapi)
>
> org.eclipse.imp.smapifier
> (recently renamed from com.ibm.watson.smapifier)
>
> org.eclipse.imp.lpg.metatooling
>
> We have just submitted these to SourceForge to be included in our CVS
> repository, so now it is a question of waiting for that to happen. I will
> look into whether we can make these projects available separately.
>
> Regards,
>
> Stan Sutton
>
>
>
>
>
> Michael Strothjohann wrote:
>> Building your own IMP from source you need to install lpg, polyglot, ...
>> ...
>>
>> details: http://eclipse-imp.sourceforge.net/installing/index.html
>>
>> michael
>>
>> "Sandip Sahoo" <sandip.sahoo1980@gmail.com> schrieb im Newsbeitrag
>> news:feofin$d1i$1@build.eclipse.org...
>>> Hi,
>>>
>>> I have made CVS checkout and import IMP source code from the site into
>>> fresh Eclipse 3.2.2 as specified here
>>> http://sourceforge.net/cvs/?group_id=201858
>>>
>>> But there are a lot of errors coming when building because the following
>>> plug-ins which are referenced in this project not available.
>>>
>>> ** com.ibm.watson.smapifier
>>>
>>> ** com.ibm.watson.smapi
>>>
>>> ** polyglot
>>>
>>> **java_cup.runtime.lr_parser (jar not available)
>>>
>>> ** lpg.runtime
>>>
>>> ** x10.compiler
>>>
>>> ** x10.runtime
>>>
>>>
>>> Please suggest me how to resolve the above problem.
>>>
>>> Regards,
>>>
>>> Sandip
>>>
>>>
>>
Re: Issue with IMP source code checkout and build [message #567200 is a reply to message #9824] Fri, 12 October 2007 17:48 Go to previous message
Michael Strothjohann is currently offline Michael Strothjohann
Messages: 52
Registered: July 2009
Member
Building your own IMP from source you need to install lpg, polyglot, ... ...

details: http://eclipse-imp.sourceforge.net/installing/index.html

michael

"Sandip Sahoo" <sandip.sahoo1980@gmail.com> schrieb im Newsbeitrag
news:feofin$d1i$1@build.eclipse.org...
> Hi,
>
> I have made CVS checkout and import IMP source code from the site into
> fresh Eclipse 3.2.2 as specified here
> http://sourceforge.net/cvs/?group_id=201858
>
> But there are a lot of errors coming when building because the following
> plug-ins which are referenced in this project not available.
>
> ** com.ibm.watson.smapifier
>
> ** com.ibm.watson.smapi
>
> ** polyglot
>
> **java_cup.runtime.lr_parser (jar not available)
>
> ** lpg.runtime
>
> ** x10.compiler
>
> ** x10.runtime
>
>
> Please suggest me how to resolve the above problem.
>
> Regards,
>
> Sandip
>
>
Re: Issue with IMP source code checkout and build [message #567211 is a reply to message #9846] Mon, 15 October 2007 18:43 Go to previous message
Stan Sutton is currently offline Stan Sutton
Messages: 121
Registered: July 2009
Senior Member
As of a couple of hours ago we have some better documentation on how to
get the projects built:

http://eclipse-imp.sourceforge.net/developers/index.html

This is the start of documentation aimed at IMP developers (i.e., people
who will be developing for IMP), as opposed to IMP users (i.e., people
who will be using IMP to create a language IDE). In any case, it has
more extensive information about how to obtain and build the various
projects relating to IMP.

As Michael has already written, you have to separately obtain and
install lpg and polyglot. You can separately obtain the X10 projects if
you want to run X10 (from x10.sourceforge.net), but that's not a central
part of IMP--just an example of an IMP IDE (and there are others in the
release, such as the LPG IDE).

The big problem for the moment is that we originally neglected to
release three projects that should be on the repository:

org.eclipse.imp.smapi
(recently renamed from com.ibm.watson.smapi)

org.eclipse.imp.smapifier
(recently renamed from com.ibm.watson.smapifier)

org.eclipse.imp.lpg.metatooling

We have just submitted these to SourceForge to be included in our CVS
repository, so now it is a question of waiting for that to happen. I
will look into whether we can make these projects available separately.

Regards,

Stan Sutton





Michael Strothjohann wrote:
> Building your own IMP from source you need to install lpg, polyglot, ...
> ...
>
> details: http://eclipse-imp.sourceforge.net/installing/index.html
>
> michael
>
> "Sandip Sahoo" <sandip.sahoo1980@gmail.com> schrieb im Newsbeitrag
> news:feofin$d1i$1@build.eclipse.org...
>> Hi,
>>
>> I have made CVS checkout and import IMP source code from the site into
>> fresh Eclipse 3.2.2 as specified here
>> http://sourceforge.net/cvs/?group_id=201858
>>
>> But there are a lot of errors coming when building because the
>> following plug-ins which are referenced in this project not available.
>>
>> ** com.ibm.watson.smapifier
>>
>> ** com.ibm.watson.smapi
>>
>> ** polyglot
>>
>> **java_cup.runtime.lr_parser (jar not available)
>>
>> ** lpg.runtime
>>
>> ** x10.compiler
>>
>> ** x10.runtime
>>
>>
>> Please suggest me how to resolve the above problem.
>>
>> Regards,
>>
>> Sandip
>>
>>
>
Re: Issue with IMP source code checkout and build [message #567260 is a reply to message #9868] Tue, 16 October 2007 03:08 Go to previous message
Eclipse User
Originally posted by: sandip.sahoo1980.gmail.com

Thanks!

I will try to do the same as you suggested below and let you know.


"Stanley Sutton" <suttons@us.ibm.com> wrote in message
news:ff0qec$mps$1@build.eclipse.org...
>
> As of a couple of hours ago we have some better documentation on how to
> get the projects built:
>
> http://eclipse-imp.sourceforge.net/developers/index.html
>
> This is the start of documentation aimed at IMP developers (i.e., people
> who will be developing for IMP), as opposed to IMP users (i.e., people who
> will be using IMP to create a language IDE). In any case, it has more
> extensive information about how to obtain and build the various projects
> relating to IMP.
>
> As Michael has already written, you have to separately obtain and install
> lpg and polyglot. You can separately obtain the X10 projects if you want
> to run X10 (from x10.sourceforge.net), but that's not a central part of
> IMP--just an example of an IMP IDE (and there are others in the release,
> such as the LPG IDE).
>
> The big problem for the moment is that we originally neglected to release
> three projects that should be on the repository:
>
> org.eclipse.imp.smapi
> (recently renamed from com.ibm.watson.smapi)
>
> org.eclipse.imp.smapifier
> (recently renamed from com.ibm.watson.smapifier)
>
> org.eclipse.imp.lpg.metatooling
>
> We have just submitted these to SourceForge to be included in our CVS
> repository, so now it is a question of waiting for that to happen. I will
> look into whether we can make these projects available separately.
>
> Regards,
>
> Stan Sutton
>
>
>
>
>
> Michael Strothjohann wrote:
>> Building your own IMP from source you need to install lpg, polyglot, ...
>> ...
>>
>> details: http://eclipse-imp.sourceforge.net/installing/index.html
>>
>> michael
>>
>> "Sandip Sahoo" <sandip.sahoo1980@gmail.com> schrieb im Newsbeitrag
>> news:feofin$d1i$1@build.eclipse.org...
>>> Hi,
>>>
>>> I have made CVS checkout and import IMP source code from the site into
>>> fresh Eclipse 3.2.2 as specified here
>>> http://sourceforge.net/cvs/?group_id=201858
>>>
>>> But there are a lot of errors coming when building because the following
>>> plug-ins which are referenced in this project not available.
>>>
>>> ** com.ibm.watson.smapifier
>>>
>>> ** com.ibm.watson.smapi
>>>
>>> ** polyglot
>>>
>>> **java_cup.runtime.lr_parser (jar not available)
>>>
>>> ** lpg.runtime
>>>
>>> ** x10.compiler
>>>
>>> ** x10.runtime
>>>
>>>
>>> Please suggest me how to resolve the above problem.
>>>
>>> Regards,
>>>
>>> Sandip
>>>
>>>
>>
Previous Topic:Providing a Sample Application
Next Topic:Regarding the IMP project!
Goto Forum:
  


Current Time: Tue Jul 22 21:43:11 EDT 2014

Powered by FUDForum. Page generated in 0.01819 seconds