Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » conflicting dependency( on Eclipse Workbench User Guide with PDT)
conflicting dependency [message #847457] Tue, 17 April 2012 06:19 Go to next message
Ruben de Vries is currently offline Ruben de Vries
Messages: 3
Registered: April 2012
Junior Member
Not sure where I should be posting this (pretty sure this isn't the best spot but I couldn't find a better spot).

I think the error below says it all ... Hope some1 can help so I can run JDT and PDT along side each other
I'm running the eclipse-php package (PDT)

Cannot complete the install because of a conflicting dependency.
  Software being installed: Eclipse Java Development Tools 3.7.2.v20120120-1414-7z8gFcuFMP7BW5XTz0jLTnz0l9B1 (org.eclipse.jdt.feature.group 3.7.2.v20120120-1414-7z8gFcuFMP7BW5XTz0jLTnz0l9B1)
  Software currently installed: Eclipse for PHP Developers 3.0.2.v2011102768 (org.zend.php.product 3.0.2.v2011102768)
  Only one of the following can be installed at once: 
    Eclipse Workbench User Guide 3.7.1.r372_v20111202 (org.eclipse.platform.doc.user 3.7.1.r372_v20111202)
    Eclipse Workbench User Guide 3.7.0.v20110601-0800 (org.eclipse.platform.doc.user 3.7.0.v20110601-0800)
  Cannot satisfy dependency:
    From: Eclipse Java Development Tools 3.7.2.v20120120-1414-7z8gFcuFMP7BW5XTz0jLTnz0l9B1 (org.eclipse.jdt.feature.group 3.7.2.v20120120-1414-7z8gFcuFMP7BW5XTz0jLTnz0l9B1)
    To: org.eclipse.platform.feature.group 3.7.2
  Cannot satisfy dependency:
    From: Eclipse Platform 3.7.1.r37x_v20110729-9gF7UHOxFtniV7mI3T556iZN9AU8bEZ1lHMcVK (org.eclipse.platform.feature.group 3.7.1.r37x_v20110729-9gF7UHOxFtniV7mI3T556iZN9AU8bEZ1lHMcVK)
    To: org.eclipse.platform.doc.user [3.7.0.v20110601-0800]
  Cannot satisfy dependency:
    From: Eclipse Platform 3.7.2.v20120207-1839-9gF7UHPDFxGjd-PqDr2jX_4yKaumkoHTz04_q-q (org.eclipse.platform.feature.group 3.7.2.v20120207-1839-9gF7UHPDFxGjd-PqDr2jX_4yKaumkoHTz04_q-q)
    To: org.eclipse.platform.doc.user [3.7.1.r372_v20111202]
  Cannot satisfy dependency:
    From: Eclipse for PHP Developers 3.0.2.v2011102768 (org.zend.php.product 3.0.2.v2011102768)
    To: org.eclipse.platform.feature.group [3.7.1.r37x_v20110729-9gF7UHOxFtniV7mI3T556iZN9AU8bEZ1lHMcVK]

[Updated on: Tue, 17 April 2012 06:58]

Report message to a moderator

Re: conflicting dependency [message #847458 is a reply to message #847457] Tue, 17 April 2012 06:22 Go to previous messageGo to next message
Ruben de Vries is currently offline Ruben de Vries
Messages: 3
Registered: April 2012
Junior Member
it's probally more PDT related since they depend on an older version?
Re: conflicting dependency [message #849237 is a reply to message #847458] Wed, 18 April 2012 21:39 Go to previous messageGo to next message
Toshihiro Izumi is currently offline Toshihiro Izumi
Messages: 338
Registered: July 2009
Location: Japan
Senior Member
>Software currently installed: Eclipse for PHP Developers 3.0.2.v2011102768 (org.zend.php.product 3.0.2.v2011102768)
Zend-pdt(zend-sdk) is not updatable. I strongly recommend to discard zend-pdt and install eclipse and then install pdt from indigo repository.
Re: conflicting dependency [message #849692 is a reply to message #849237] Thu, 19 April 2012 07:22 Go to previous message
Ruben de Vries is currently offline Ruben de Vries
Messages: 3
Registered: April 2012
Junior Member
Okay, will do, don't know why I had the zend version anyway Smile
Previous Topic:xdebug woes
Next Topic:How do I run my PHP file as a PHP CLI Application
Goto Forum:
  


Current Time: Thu Apr 17 23:50:26 EDT 2014

Powered by FUDForum. Page generated in 0.03150 seconds