Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » CPU hogging
CPU hogging [message #9757] Thu, 18 October 2007 09:53 Go to next message
Eclipse UserFriend
Originally posted by:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<body bgcolor="#ffffff" text="#000000">
I just noticed my CPU peaking due to my Eclipse Java process, and on
taking several thread dumps I always found this one:<br>
<blockquote><tt>"Worker-78" prio=10 tid=0x00002aaaf49a1400 nid=0x28f3
runnable [0x0000000041038000..0x0000000041038d90]</tt><br>
<tt>   java.lang.Thread.State: RUNNABLE</tt><br>
<tt>        at
java.util.regex.Pattern$BmpCharProperty.match( 366) </tt><br>
<tt>        at java.util.regex.Pattern$Curly.match(</tt> <br>
<tt>        at java.util.regex.Pattern$Curly.match0(</tt ><br>
<tt>        at java.util.regex.Pattern$Curly.match(</tt> <br>
<tt>        at java.util.regex.Pattern$Start.match(</tt> <br>
<tt>        at</tt><br>
<tt>        at java.util.regex.Matcher.find(</tt><br>
<tt>        at$AddConsole HyperlinkOperation.runImpl( </tt><br>
<tt>        at .run( </tt><br>
<tt>        at </tt><br>
<tt>        at Task( </tt><br>
<tt>        at TaskExternal( </tt><br>
<tt>        at </tt><br>
<tt>        at$ </tt><br>
<tt>        at
org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator .java:49) </tt><br>
<tt>        at ( </tt><br>
<tt>        at Default( </tt><br>
<tt>        at ( </tt><br>
<tt>        at
org.eclipse.ui.internal.console.PatternMatchListener.matchFo und( </tt><br>
<tt>        at
org.eclipse.ui.internal.console.ConsolePatternMatcher$MatchJ </tt><br>
<tt>        at</tt ><br>
I have no clue what it's doing, as there is no SVN operation going on.
When I enable "Show system operations" in the Progress View, I can see
three active jobs: "System: Flush Cache Job", "System: Match Job" and
"System: Task List Saver".<br>
Restarting Eclipse fortunately resolves this.<br>
Re: CPU hogging [message #9915 is a reply to message #9757] Tue, 30 October 2007 11:57 Go to previous message
Eclipse UserFriend
Originally posted by:

Dear Jörg,

Thank you for reporting the issue. You can track state of your report with
Eclipse Bugzilla:
Previous Topic:How do I obtain working copy information?
Next Topic:Subversive / Subclipse Plugin - Pre-commit actions
Goto Forum:

Current Time: Mon Oct 05 21:44:47 GMT 2015

Powered by FUDForum. Page generated in 0.02632 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software