Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » using p2 to replace a plugin in 3.4m6
using p2 to replace a plugin in 3.4m6 [message #107302] Tue, 01 April 2008 06:04 Go to next message
Francis Upton IV is currently offline Francis Upton IV
Messages: 472
Registered: July 2009
Location: Oakland, CA
Senior Member
I'm trying to replace the pde.build plugin with a patched version
(patched for https://bugs.eclipse.org/bugs/show_bug.cgi?id=224098).

I'm using a headless build by launching the antrunner from the command
line and pointing to a build script in the pde.build plugin.

Back in the bad old days before p2 (3.4m5 and before) I would simply
rename the plugin (a directory in this case) and put my patched plugin
directory in the plugins directory.

However this does not work so well in m6.

I have tried putting the patched plugin (directory) in the dropins
directory, and it just executes the old one.

I have tried putting the patched plugin (directory) in the plugins
directory (with an identical name), and something is wrong with the
execution (the ${eclipse.pdebuild.scripts} variable is not set in the
ant script).

I have tried deleting the existing plugin and putting the new plugin in
the dropins directory and p2 complains about the missing existing
plugin, and seems to execute the new plugin incorrectly (as above).

What's the supported p2 way of replacing a plugin?


Re: using p2 to replace a plugin in 3.4m6 [message #107325 is a reply to message #107302] Tue, 01 April 2008 11:18 Go to previous messageGo to next message
Francis Upton IV is currently offline Francis Upton IV
Messages: 472
Registered: July 2009
Location: Oakland, CA
Senior Member
Word is that plugin replacement in this manner is not supported in m6,
it will be in m7.

The best way to do this is to export the plugin with the same qualifier
and copy it to the plugins directory of the kit.

Francis Upton wrote:
> I'm trying to replace the pde.build plugin with a patched version
> (patched for https://bugs.eclipse.org/bugs/show_bug.cgi?id=224098).
>
> I'm using a headless build by launching the antrunner from the command
> line and pointing to a build script in the pde.build plugin.
>
> Back in the bad old days before p2 (3.4m5 and before) I would simply
> rename the plugin (a directory in this case) and put my patched plugin
> directory in the plugins directory.
>
> However this does not work so well in m6.
>
> I have tried putting the patched plugin (directory) in the dropins
> directory, and it just executes the old one.
>
> I have tried putting the patched plugin (directory) in the plugins
> directory (with an identical name), and something is wrong with the
> execution (the ${eclipse.pdebuild.scripts} variable is not set in the
> ant script).
>
> I have tried deleting the existing plugin and putting the new plugin in
> the dropins directory and p2 complains about the missing existing
> plugin, and seems to execute the new plugin incorrectly (as above).
>
> What's the supported p2 way of replacing a plugin?


Re: using p2 to replace a plugin in 3.4m6 [message #107372 is a reply to message #107325] Wed, 02 April 2008 10:48 Go to previous message
Pascal Rapicault is currently offline Pascal Rapicault
Messages: 286
Registered: July 2009
Location: Ottawa
Senior Member
Correct.

"Francis Upton" <francisu@ieee.org> wrote in message
news:fstjo3$9r2$1@build.eclipse.org...
> Word is that plugin replacement in this manner is not supported in m6, it
> will be in m7.
>
> The best way to do this is to export the plugin with the same qualifier
> and copy it to the plugins directory of the kit.
>
> Francis Upton wrote:
>> I'm trying to replace the pde.build plugin with a patched version
>> (patched for https://bugs.eclipse.org/bugs/show_bug.cgi?id=224098).
>>
>> I'm using a headless build by launching the antrunner from the command
>> line and pointing to a build script in the pde.build plugin.
>>
>> Back in the bad old days before p2 (3.4m5 and before) I would simply
>> rename the plugin (a directory in this case) and put my patched plugin
>> directory in the plugins directory.
>>
>> However this does not work so well in m6.
>>
>> I have tried putting the patched plugin (directory) in the dropins
>> directory, and it just executes the old one.
>>
>> I have tried putting the patched plugin (directory) in the plugins
>> directory (with an identical name), and something is wrong with the
>> execution (the ${eclipse.pdebuild.scripts} variable is not set in the ant
>> script).
>>
>> I have tried deleting the existing plugin and putting the new plugin in
>> the dropins directory and p2 complains about the missing existing plugin,
>> and seems to execute the new plugin incorrectly (as above).
>>
>> What's the supported p2 way of replacing a plugin?
Previous Topic:3.4M6 with p2 broken
Next Topic:importing existing projects programmatically
Goto Forum:
  


Current Time: Tue Jul 29 06:55:45 EDT 2014

Powered by FUDForum. Page generated in 0.03013 seconds