Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Errors when attempting to build C++ project
icon9.gif  Errors when attempting to build C++ project [message #844012] Fri, 13 April 2012 11:47 Go to next message
e nygma is currently offline e nygma
Messages: 2
Registered: April 2012
Junior Member
When building a project for the first time since launching Eclipse, it builds successfully.

However, when trying to build the next time, I get:

Errors occurred during the build.
Errors running builder 'CDT Builder' on project '<PROJECT NAME>'.
java.lang.IllegalArgumentException


Where <PROJECT NAME> is as it sounds.

As a workaround, I find that right clicking on the .cpp source file in project manager, Properties > C/C++ Build and clicking 'apply defaults', and then retrying the build will work. But you need to keep repeating this process every time you wish to build.

I am running Eclipse Indigo under Ubuntu Oneiric 11.10.

Anyone know if this is just a bug, or how it can be corrected?

Any help would be much appreciated.
Re: Errors when attempting to build C++ project [message #852545 is a reply to message #844012] Sun, 22 April 2012 00:57 Go to previous messageGo to next message
Marc-Andre Laperle is currently offline Marc-Andre Laperle
Messages: 171
Registered: July 2009
Senior Member
Can you post the full call stack of the exception? It should be in the Error log. Which version of CDT are you using? There is a bug in 8.0.2 when you try to build a second time a project that contains special characters, see https://bugs.eclipse.org/bugs/show_bug.cgi?id=377295
Re: Errors when attempting to build C++ project [message #852546 is a reply to message #844012] Sun, 22 April 2012 00:57 Go to previous messageGo to next message
Marc-Andre Laperle is currently offline Marc-Andre Laperle
Messages: 171
Registered: July 2009
Senior Member
Can you post the full call stack of the exception? It should be in the Error log. Which version of CDT are you using? There is a bug in 8.0.2 when you try to build a second time a project that contains special characters, see https://bugs.eclipse.org/bugs/show_bug.cgi?id=377295
Re: Errors when attempting to build C++ project [message #852553 is a reply to message #844012] Sun, 22 April 2012 00:57 Go to previous messageGo to next message
Marc-Andre Laperle is currently offline Marc-Andre Laperle
Messages: 171
Registered: July 2009
Senior Member
Can you post the full call stack of the exception? It should be in the Error log. Which version of CDT are you using? There is a bug in 8.0.2 when you try to build a second time a project that contains special characters, see https://bugs.eclipse.org/bugs/show_bug.cgi?id=377295
Re: Errors when attempting to build C++ project [message #852554 is a reply to message #844012] Sun, 22 April 2012 00:57 Go to previous messageGo to next message
Marc-Andre Laperle is currently offline Marc-Andre Laperle
Messages: 171
Registered: July 2009
Senior Member
Can you post the full call stack of the exception? It should be in the Error log. Which version of CDT are you using? There is a bug in 8.0.2 when you try to build a second time a project that contains special characters, see https://bugs.eclipse.org/bugs/show_bug.cgi?id=377295
Re: Errors when attempting to build C++ project [message #852558 is a reply to message #844012] Sun, 22 April 2012 00:57 Go to previous messageGo to next message
Marc-Andre Laperle is currently offline Marc-Andre Laperle
Messages: 171
Registered: July 2009
Senior Member
Can you post the full call stack of the exception? It should be in the Error log. Which version of CDT are you using? There is a bug in 8.0.2 when you try to build a second time a project that contains special characters, see https://bugs.eclipse.org/bugs/show_bug.cgi?id=377295
Re: Errors when attempting to build C++ project [message #852559 is a reply to message #844012] Sun, 22 April 2012 00:57 Go to previous messageGo to next message
Marc-Andre Laperle is currently offline Marc-Andre Laperle
Messages: 171
Registered: July 2009
Senior Member
Can you post the full call stack of the exception? It should be in the Error log. Which version of CDT are you using? There is a bug in 8.0.2 when you try to build a second time a project that contains special characters, see https://bugs.eclipse.org/bugs/show_bug.cgi?id=377295
Re: Errors when attempting to build C++ project [message #852563 is a reply to message #844012] Sun, 22 April 2012 00:57 Go to previous messageGo to next message
Marc-Andre Laperle is currently offline Marc-Andre Laperle
Messages: 171
Registered: July 2009
Senior Member
Can you post the full call stack of the exception? It should be in the Error log. Which version of CDT are you using? There is a bug in 8.0.2 when you try to build a second time a project that contains special characters, see https://bugs.eclipse.org/bugs/show_bug.cgi?id=377295
Re: Errors when attempting to build C++ project [message #852564 is a reply to message #844012] Sun, 22 April 2012 00:57 Go to previous messageGo to next message
Marc-Andre Laperle is currently offline Marc-Andre Laperle
Messages: 171
Registered: July 2009
Senior Member
Can you post the full call stack of the exception? It should be in the Error log. Which version of CDT are you using? There is a bug in 8.0.2 when you try to build a second time a project that contains special characters, see https://bugs.eclipse.org/bugs/show_bug.cgi?id=377295
Re: Errors when attempting to build C++ project [message #852568 is a reply to message #844012] Sun, 22 April 2012 00:57 Go to previous messageGo to next message
Marc-Andre Laperle is currently offline Marc-Andre Laperle
Messages: 171
Registered: July 2009
Senior Member
Can you post the full call stack of the exception? It should be in the Error log. Which version of CDT are you using? There is a bug in 8.0.2 when you try to build a second time a project that contains special characters, see https://bugs.eclipse.org/bugs/show_bug.cgi?id=377295
Re: Errors when attempting to build C++ project [message #852569 is a reply to message #844012] Sun, 22 April 2012 00:57 Go to previous messageGo to next message
Marc-Andre Laperle is currently offline Marc-Andre Laperle
Messages: 171
Registered: July 2009
Senior Member
Can you post the full call stack of the exception? It should be in the Error log. Which version of CDT are you using? There is a bug in 8.0.2 when you try to build a second time a project that contains special characters, see https://bugs.eclipse.org/bugs/show_bug.cgi?id=377295
Re: Errors when attempting to build C++ project [message #852575 is a reply to message #844012] Sun, 22 April 2012 00:57 Go to previous messageGo to next message
Marc-Andre Laperle is currently offline Marc-Andre Laperle
Messages: 171
Registered: July 2009
Senior Member
Can you post the full call stack of the exception? It should be in the Error log. Which version of CDT are you using? There is a bug in 8.0.2 when you try to build a second time a project that contains special characters, see https://bugs.eclipse.org/bugs/show_bug.cgi?id=377295
Re: Errors when attempting to build C++ project [message #852576 is a reply to message #844012] Sun, 22 April 2012 00:57 Go to previous messageGo to next message
Marc-Andre Laperle is currently offline Marc-Andre Laperle
Messages: 171
Registered: July 2009
Senior Member
Can you post the full call stack of the exception? It should be in the Error log. Which version of CDT are you using? There is a bug in 8.0.2 when you try to build a second time a project that contains special characters, see https://bugs.eclipse.org/bugs/show_bug.cgi?id=377295
Re: Errors when attempting to build C++ project [message #852582 is a reply to message #844012] Sun, 22 April 2012 00:57 Go to previous messageGo to next message
Marc-Andre Laperle is currently offline Marc-Andre Laperle
Messages: 171
Registered: July 2009
Senior Member
Can you post the full call stack of the exception? It should be in the Error log. Which version of CDT are you using? There is a bug in 8.0.2 when you try to build a second time a project that contains special characters, see https://bugs.eclipse.org/bugs/show_bug.cgi?id=377295
Re: Errors when attempting to build C++ project [message #852583 is a reply to message #844012] Sun, 22 April 2012 00:57 Go to previous messageGo to next message
Marc-Andre Laperle is currently offline Marc-Andre Laperle
Messages: 171
Registered: July 2009
Senior Member
Can you post the full call stack of the exception? It should be in the Error log. Which version of CDT are you using? There is a bug in 8.0.2 when you try to build a second time a project that contains special characters, see https://bugs.eclipse.org/bugs/show_bug.cgi?id=377295
Re: Errors when attempting to build C++ project [message #852590 is a reply to message #844012] Sun, 22 April 2012 00:57 Go to previous messageGo to next message
Marc-Andre Laperle is currently offline Marc-Andre Laperle
Messages: 171
Registered: July 2009
Senior Member
Can you post the full call stack of the exception? It should be in the Error log. Which version of CDT are you using? There is a bug in 8.0.2 when you try to build a second time a project that contains special characters, see https://bugs.eclipse.org/bugs/show_bug.cgi?id=377295
Re: Errors when attempting to build C++ project [message #852591 is a reply to message #844012] Sun, 22 April 2012 00:57 Go to previous messageGo to next message
Marc-Andre Laperle is currently offline Marc-Andre Laperle
Messages: 171
Registered: July 2009
Senior Member
Can you post the full call stack of the exception? It should be in the Error log. Which version of CDT are you using? There is a bug in 8.0.2 when you try to build a second time a project that contains special characters, see https://bugs.eclipse.org/bugs/show_bug.cgi?id=377295
Re: Errors when attempting to build C++ project [message #852598 is a reply to message #844012] Sun, 22 April 2012 00:57 Go to previous messageGo to next message
Marc-Andre Laperle is currently offline Marc-Andre Laperle
Messages: 171
Registered: July 2009
Senior Member
Can you post the full call stack of the exception? It should be in the Error log. Which version of CDT are you using? There is a bug in 8.0.2 when you try to build a second time a project that contains special characters, see https://bugs.eclipse.org/bugs/show_bug.cgi?id=377295
Re: Errors when attempting to build C++ project [message #852599 is a reply to message #844012] Sun, 22 April 2012 00:57 Go to previous messageGo to next message
Marc-Andre Laperle is currently offline Marc-Andre Laperle
Messages: 171
Registered: July 2009
Senior Member
Can you post the full call stack of the exception? It should be in the Error log. Which version of CDT are you using? There is a bug in 8.0.2 when you try to build a second time a project that contains special characters, see https://bugs.eclipse.org/bugs/show_bug.cgi?id=377295
Re: Errors when attempting to build C++ project [message #852606 is a reply to message #844012] Sun, 22 April 2012 00:57 Go to previous messageGo to next message
Marc-Andre Laperle is currently offline Marc-Andre Laperle
Messages: 171
Registered: July 2009
Senior Member
Can you post the full call stack of the exception? It should be in the Error log. Which version of CDT are you using? There is a bug in 8.0.2 when you try to build a second time a project that contains special characters, see https://bugs.eclipse.org/bugs/show_bug.cgi?id=377295
Re: Errors when attempting to build C++ project [message #852607 is a reply to message #844012] Sun, 22 April 2012 00:57 Go to previous messageGo to next message
Marc-Andre Laperle is currently offline Marc-Andre Laperle
Messages: 171
Registered: July 2009
Senior Member
Can you post the full call stack of the exception? It should be in the Error log. Which version of CDT are you using? There is a bug in 8.0.2 when you try to build a second time a project that contains special characters, see https://bugs.eclipse.org/bugs/show_bug.cgi?id=377295
Re: Errors when attempting to build C++ project [message #852614 is a reply to message #844012] Sun, 22 April 2012 00:57 Go to previous messageGo to next message
Marc-Andre Laperle is currently offline Marc-Andre Laperle
Messages: 171
Registered: July 2009
Senior Member
Can you post the full call stack of the exception? It should be in the Error log. Which version of CDT are you using? There is a bug in 8.0.2 when you try to build a second time a project that contains special characters, see https://bugs.eclipse.org/bugs/show_bug.cgi?id=377295
Re: Errors when attempting to build C++ project [message #852615 is a reply to message #844012] Sun, 22 April 2012 00:57 Go to previous messageGo to next message
Marc-Andre Laperle is currently offline Marc-Andre Laperle
Messages: 171
Registered: July 2009
Senior Member
Can you post the full call stack of the exception? It should be in the Error log. Which version of CDT are you using? There is a bug in 8.0.2 when you try to build a second time a project that contains special characters, see https://bugs.eclipse.org/bugs/show_bug.cgi?id=377295
Re: Errors when attempting to build C++ project [message #866479 is a reply to message #852545] Mon, 30 April 2012 18:42 Go to previous messageGo to next message
Chris Conrad is currently offline Chris Conrad
Messages: 1
Registered: April 2012
Junior Member
I am having this same problem and it is extremely frustrating, what exactly do I need to post?

regards,
Chris
Re: Errors when attempting to build C++ project [message #866550 is a reply to message #866479] Mon, 30 April 2012 19:33 Go to previous messageGo to next message
Marc-Andre Laperle is currently offline Marc-Andre Laperle
Messages: 171
Registered: July 2009
Senior Member
Chris Conrad wrote on Mon, 30 April 2012 18:42
I am having this same problem and it is extremely frustrating, what exactly do I need to post?


Check the error log for errors and paste the errors here. To open the Error log, click on Window -> Show view -> Error log (it might be in Others...)
Re: Errors when attempting to build C++ project [message #869093 is a reply to message #844012] Wed, 02 May 2012 20:04 Go to previous messageGo to next message
Diego Castillo is currently offline Diego Castillo
Messages: 1
Registered: May 2012
Junior Member
I have the same problem.

Log

java.lang.IllegalArgumentException
at java.net.URI.create(Unknown Source)
at java.net.URI.resolve(Unknown Source)
at org.eclipse.cdt.managedbuilder.internal.core.AdditionalInput.getArtifactTimeStamp(AdditionalInput.java:376)
at org.eclipse.cdt.managedbuilder.internal.core.AdditionalInput.needsRebuild(AdditionalInput.java:337)
at org.eclipse.cdt.managedbuilder.internal.core.InputType.needsRebuild(InputType.java:1619)
at org.eclipse.cdt.managedbuilder.internal.core.Tool.needsRebuild(Tool.java:3307)
at org.eclipse.cdt.managedbuilder.internal.core.ToolChain.needsRebuild(ToolChain.java:2068)
at org.eclipse.cdt.managedbuilder.internal.core.ToolChain.saveRebuildState(ToolChain.java:2101)
at org.eclipse.cdt.managedbuilder.internal.core.ToolChain.setRebuildState(ToolChain.java:2085)
at org.eclipse.cdt.managedbuilder.internal.core.FolderInfo.setRebuildState(FolderInfo.java:355)
at org.eclipse.cdt.managedbuilder.internal.core.Configuration.setRebuildState(Configuration.java:1726)
at org.eclipse.cdt.managedbuilder.internal.core.CommonBuilder.build(CommonBuilder.java:760)
at org.eclipse.cdt.managedbuilder.internal.core.CommonBuilder.build(CommonBuilder.java:504)
at org.eclipse.cdt.managedbuilder.internal.core.CommonBuilder.build(CommonBuilder.java:450)
at org.eclipse.core.internal.events.BuildManager$2.run(BuildManager.java:728)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:199)
at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:239)
at org.eclipse.core.internal.events.BuildManager$1.run(BuildManager.java:292)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:295)
at org.eclipse.core.internal.events.BuildManager.basicBuildLoop(BuildManager.java:351)
at org.eclipse.core.internal.events.BuildManager.build(BuildManager.java:374)
at org.eclipse.core.internal.resources.Workspace.buildInternal(Workspace.java:513)
at org.eclipse.core.internal.resources.Workspace.build(Workspace.java:432)
at org.eclipse.ui.actions.BuildAction$1.runInWorkspace(BuildAction.java:305)
at org.eclipse.core.internal.resources.InternalWorkspaceJob.run(InternalWorkspaceJob.java:38)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
Caused by: java.net.URISyntaxException: Illegal character in path at index 6: Prueba 8.exe
at java.net.URI$Parser.fail(Unknown Source)
at java.net.URI$Parser.checkChars(Unknown Source)
at java.net.URI$Parser.parseHierarchical(Unknown Source)
at java.net.URI$Parser.parse(Unknown Source)
at java.net.URI.<init>(Unknown Source)
... 28 more
Re: Errors when attempting to build C++ project [message #869172 is a reply to message #869093] Wed, 02 May 2012 23:06 Go to previous message
Marc-Andre Laperle is currently offline Marc-Andre Laperle
Messages: 171
Registered: July 2009
Senior Member
Diego Castillo wrote on Wed, 02 May 2012 20:04
I have the same problem.

Log

java.lang.IllegalArgumentException
at java.net.URI.create(Unknown Source)
at java.net.URI.resolve(Unknown Source)
at org.eclipse.cdt.managedbuilder.internal.core.AdditionalInput.getArtifactTimeStamp(AdditionalInput.java:376)
at org.eclipse.cdt.managedbuilder.internal.core.AdditionalInput.needsRebuild(AdditionalInput.java:337)


This is indeed bug 377295, it's fixed in the next version (8.1).

You can get a nighly build of 8.1.0 with this update site:
http://download.eclipse.org/tools/cdt/builds/juno/nightly

You will need Eclipse 3.8 or 4.2 to install CDT 8.1.
Previous Topic:Indexer problem with typedef for iterator and std::vector::insert
Next Topic:[Windows] application running on external cmd.exe command prompt
Goto Forum:
  


Current Time: Wed Aug 20 20:44:20 EDT 2014

Powered by FUDForum. Page generated in 0.09528 seconds