Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Report loses rich text formatting when exported to PDF(Exporting does not retain formatting such as indentations and list indentations)
Report loses rich text formatting when exported to PDF [message #841832] Wed, 11 April 2012 15:25 Go to next message
A N is currently offline A N
Messages: 15
Registered: December 2011
Junior Member
I have a data row on a report that retrieves a description from a database. This description contains rich text formatting. When I view the report in the web viewer, the formatting is correct. However, when I export the report to PDF, it seems the formatting is lost for the PDF file. Any ideas? Or is this a known limitation?

Thanks.
Re: Report loses rich text formatting when exported to PDF [message #843029 is a reply to message #841832] Thu, 12 April 2012 14:57 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Are you using a dynamic text element? What does the Rich Text look like?

Jason

On 4/11/2012 3:25 PM, A N wrote:
> I have a data row on a report that retrieves a description from a
> database. This description contains rich text formatting. When I view
> the report in the web viewer, the formatting is correct. However, when I
> export the report to PDF, it seems the formatting is lost for the PDF
> file. Any ideas? Or is this a known limitation?
>
> Thanks.
Re: Report loses rich text formatting when exported to PDF [message #843053 is a reply to message #841832] Thu, 12 April 2012 14:57 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Are you using a dynamic text element? What does the Rich Text look like?

Jason

On 4/11/2012 3:25 PM, A N wrote:
> I have a data row on a report that retrieves a description from a
> database. This description contains rich text formatting. When I view
> the report in the web viewer, the formatting is correct. However, when I
> export the report to PDF, it seems the formatting is lost for the PDF
> file. Any ideas? Or is this a known limitation?
>
> Thanks.
Re: Report loses rich text formatting when exported to PDF [message #843086 is a reply to message #841832] Thu, 12 April 2012 14:57 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Are you using a dynamic text element? What does the Rich Text look like?

Jason

On 4/11/2012 3:25 PM, A N wrote:
> I have a data row on a report that retrieves a description from a
> database. This description contains rich text formatting. When I view
> the report in the web viewer, the formatting is correct. However, when I
> export the report to PDF, it seems the formatting is lost for the PDF
> file. Any ideas? Or is this a known limitation?
>
> Thanks.
Re: Report loses rich text formatting when exported to PDF [message #843979 is a reply to message #843086] Fri, 13 April 2012 11:06 Go to previous messageGo to next message
A N is currently offline A N
Messages: 15
Registered: December 2011
Junior Member
The element is a dynamic text element. I have attached an image of what the element looks like on the web viewer and what the element looks like when exported to a document.

In the image, I have also shown that the problem occurs when exporting to a Word document as well. Notice that the indentations and the lists are formatted incorrectly.

I am using BIRT 3.7.1.

Thanks.
  • Attachment: rtscreen.png
    (Size: 13.98KB, Downloaded 119 times)
Re: Report loses rich text formatting when exported to PDF [message #844040 is a reply to message #843979] Fri, 13 April 2012 12:14 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Can you log a bugzilla for this?

Jason

On 4/13/2012 11:06 AM, A N wrote:
> The element is a dynamic text element. I have attached an image of what the element looks like on the web viewer and what the element looks like when exported to a document.
>
> In the image, I have also shown that the problem occurs when exporting to a Word document as well. Notice that the indentations and the lists are formatted incorrectly.
>
> I am using BIRT 3.7.1.
>
> Thanks.
Re: Report loses rich text formatting when exported to PDF [message #844145 is a reply to message #844040] Fri, 13 April 2012 14:43 Go to previous messageGo to next message
A N is currently offline A N
Messages: 15
Registered: December 2011
Junior Member
Sure, I have just logged a bug. It is listed as Bug 376769.

Thanks.
Re: Report loses rich text formatting when exported to PDF [message #846703 is a reply to message #844145] Mon, 16 April 2012 10:56 Go to previous message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Thanks for logging this.

Jason

On 4/13/2012 2:43 PM, A N wrote:
> Sure, I have just logged a bug. It is listed as Bug 376769.
>
> Thanks.
Previous Topic:Table inside a Grid (pagination problem)
Next Topic:Is there way to create accessible reports in BIRT?
Goto Forum:
  


Current Time: Sat Aug 23 03:49:28 EDT 2014

Powered by FUDForum. Page generated in 0.01799 seconds