Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Unable to update Eclipse to 3.6 or 3.7 from 3.5.2(Unable to update Eclipse to 3.6 or 3.7 from 3.5.2)
Unable to update Eclipse to 3.6 or 3.7 from 3.5.2 [message #841800] Wed, 11 April 2012 18:40 Go to next message
Capt Frank is currently offline Capt FrankFriend
Messages: 10
Registered: April 2012
Junior Member
I have installed
Version: 3.5.2
Build id: M20100211-1343

It has been working fine but doing some droid development and needed to update the ADT but need 3.6.x+. Following all the instruction I can find it should be easy to update but has been a nightmare to figure out why I can',

followed these instructions and no dice:
<newbie will not post link>://help.eclipse.org/helios/index.jsp?topic=/org.eclipse.platform.doc.user/tasks/tasks-129.htm
The update button for the eclipse platform is grayed out. ADT 18.x is ok to update except for the dependency of 3.6.x+ lol

Tried both indigo and Helios. Added both to window->preferences->install/update ->available SW
added both
<newbie will not post link>//download.eclipse.org/releases/helios/
<newbie will not post link>://download.eclipse.org/releases/indigo

no help. Running
2.6.32-33-generic #72-Ubuntu SMP Fri Jul 29 21:07:13 UTC 2011 x86_64 GNU/Linux
java version "1.7.0_01"
Java(TM) SE Runtime Environment (build 1.7.0_01-b08)
Java HotSpot(TM) 64-Bit Server VM (build 21.1-b02, mixed mode)


Any thoughts?
Re: Unable to update Eclipse to 3.6 or 3.7 from 3.5.2 [message #841867 is a reply to message #841800] Wed, 11 April 2012 20:12 Go to previous messageGo to next message
David Wegener is currently offline David WegenerFriend
Messages: 1351
Registered: July 2009
Senior Member
You are going to have to provide more detail on what you have tried, what results you are seeing, and what results you are expecting.
Re: Unable to update Eclipse to 3.6 or 3.7 from 3.5.2 [message #842300 is a reply to message #841800] Thu, 12 April 2012 07:01 Go to previous messageGo to next message
Libor Jelinek is currently offline Libor JelinekFriend
Messages: 143
Registered: January 2012
Location: Prague, Czech Rep.
Senior Member

According to my up-to-now experience Eclipse is very "predisposed" to crash, get broke workspace and Eclipse binaries on updates, installing new software etc.

Instead of spend tree days of deep analysis what happen, I just backup workspace to somewhere else, delete workspace and/or Eclipse binaries, then File / Import projects from backup folder to this vanilla fresh workspace/Eclipse.
Re: Unable to update Eclipse to 3.6 or 3.7 from 3.5.2 [message #842764 is a reply to message #841867] Thu, 12 April 2012 15:51 Go to previous messageGo to next message
Capt Frank is currently offline Capt FrankFriend
Messages: 10
Registered: April 2012
Junior Member
Sorry I thought I did. The ppinters above are the exact directions are that I followed but where I shoudl have been able to update the eclipse platform that showed 3.5.2 to 3.6 per directions the update... button was greyed out unlike what the directions indicated.
Re: Unable to update Eclipse to 3.6 or 3.7 from 3.5.2 [message #842765 is a reply to message #842300] Thu, 12 April 2012 15:54 Go to previous messageGo to next message
Capt Frank is currently offline Capt FrankFriend
Messages: 10
Registered: April 2012
Junior Member
Yea I'm starting to think I need to just do a fresh install and forget trying to update the product as it does not work per published directions.
Re: Unable to update Eclipse to 3.6 or 3.7 from 3.5.2 [message #842776 is a reply to message #841867] Thu, 12 April 2012 15:52 Go to previous messageGo to next message
Eclipse UserFriend
Sorry I thought I did. The ppinters above are the exact directions are that I followed but where I shoudl have been able to update the eclipse platform that showed 3.5.2 to 3.6 per directions the update... button was greyed out unlike what the directions indicated.
Re: Unable to update Eclipse to 3.6 or 3.7 from 3.5.2 [message #842777 is a reply to message #842300] Thu, 12 April 2012 15:54 Go to previous messageGo to next message
Eclipse UserFriend
Yea I'm starting to think I need to just do a fresh install and forget trying to update the product as it does not work per published directions.
Re: Unable to update Eclipse to 3.6 or 3.7 from 3.5.2 [message #842780 is a reply to message #842300] Thu, 12 April 2012 16:02 Go to previous message
Capt Frank is currently offline Capt FrankFriend
Messages: 10
Registered: April 2012
Junior Member
Libor Jelínek wrote on Thu, 12 April 2012 03:01
According to my up-to-now experience Eclipse is very "predisposed" to crash, get broke workspace and Eclipse binaries on updates, installing new software etc.

Instead of spend tree days of deep analysis what happen, I just backup workspace to somewhere else, delete workspace and/or Eclipse binaries, then File / Import projects from backup folder to this vanilla fresh workspace/Eclipse.


I'm starting to think this is the only option as following the directions it does not even give me the option to update from 3.5.2 to 3.6 via update option when I click on the eclipse platform.
Re: Unable to update Eclipse to 3.6 or 3.7 from 3.5.2 [message #842786 is a reply to message #841867] Thu, 12 April 2012 15:52 Go to previous message
Eclipse UserFriend
Sorry I thought I did. The ppinters above are the exact directions are that I followed but where I shoudl have been able to update the eclipse platform that showed 3.5.2 to 3.6 per directions the update... button was greyed out unlike what the directions indicated.
Re: Unable to update Eclipse to 3.6 or 3.7 from 3.5.2 [message #842787 is a reply to message #842300] Thu, 12 April 2012 15:54 Go to previous message
Eclipse UserFriend
Yea I'm starting to think I need to just do a fresh install and forget trying to update the product as it does not work per published directions.
Re: Unable to update Eclipse to 3.6 or 3.7 from 3.5.2 [message #842795 is a reply to message #841867] Thu, 12 April 2012 15:52 Go to previous message
Capt Frank is currently offline Capt FrankFriend
Messages: 10
Registered: April 2012
Junior Member
Sorry I thought I did. The ppinters above are the exact directions are that I followed but where I shoudl have been able to update the eclipse platform that showed 3.5.2 to 3.6 per directions the update... button was greyed out unlike what the directions indicated.
Re: Unable to update Eclipse to 3.6 or 3.7 from 3.5.2 [message #842796 is a reply to message #842300] Thu, 12 April 2012 15:54 Go to previous message
Capt Frank is currently offline Capt FrankFriend
Messages: 10
Registered: April 2012
Junior Member
Yea I'm starting to think I need to just do a fresh install and forget trying to update the product as it does not work per published directions.
Re: Unable to update Eclipse to 3.6 or 3.7 from 3.5.2 [message #842797 is a reply to message #842300] Thu, 12 April 2012 16:02 Go to previous message
Capt Frank is currently offline Capt FrankFriend
Messages: 10
Registered: April 2012
Junior Member
Libor Jelínek wrote on Thu, 12 April 2012 03:01
> According to my up-to-now experience Eclipse is very "predisposed" to crash, get broke workspace and Eclipse binaries on updates, installing new software etc.
>
> Instead of spend tree days of deep analysis what happen, I just backup workspace to somewhere else, delete workspace and/or Eclipse binaries, then File / Import projects from backup folder to this vanilla fresh workspace/Eclipse.


I'm starting to think this is the only option as following the directions it does not even give me the option to update from 3.5.2 to 3.6 via update option when I click on the eclipse platform.
Re: Unable to update Eclipse to 3.6 or 3.7 from 3.5.2 [message #842805 is a reply to message #842300] Thu, 12 April 2012 16:02 Go to previous message
Capt Frank is currently offline Capt FrankFriend
Messages: 10
Registered: April 2012
Junior Member
Libor Jelínek wrote on Thu, 12 April 2012 03:01
> According to my up-to-now experience Eclipse is very "predisposed" to crash, get broke workspace and Eclipse binaries on updates, installing new software etc.
>
> Instead of spend tree days of deep analysis what happen, I just backup workspace to somewhere else, delete workspace and/or Eclipse binaries, then File / Import projects from backup folder to this vanilla fresh workspace/Eclipse.


I'm starting to think this is the only option as following the directions it does not even give me the option to update from 3.5.2 to 3.6 via update option when I click on the eclipse platform.
Previous Topic:Touch-typing: How to avoid using the mouse in Eclipse
Next Topic:Printing code in eclipse font size too large
Goto Forum:
  


Current Time: Thu Dec 18 16:31:08 GMT 2014

Powered by FUDForum. Page generated in 0.63119 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software