Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Indexer freezes at 0%
Indexer freezes at 0% [message #841347] Wed, 11 April 2012 07:24 Go to next message
Michael Keller is currently offline Michael KellerFriend
Messages: 1
Registered: April 2012
Junior Member
Hello,

I'm trying to use eclipse with my C-project.

After a svn-checkout and modification of the include paths the indexer in Eclipse runs and indexes all the sources and includes. Most of the time this first indexer run succeeds.

Then, after some sourcecode editing, ans some steps like "clean", "build" and "refresh" of the project, the indexer starts again and then it is very likely, that it will freeze at 0% and even after hours it will not finish.

I assume, that it might be a thread-deadlock, so I will attach a thread dump to the post, that I made with visualvm at the time the indexer was frozen.

The details of the system I am using:

JVM: Java HotSpot(TM) Client VM (20.0-b11, mixed mode)
Java: version 1.6.0_25, vendor Sun Microsystems Inc.
Java Home: C:\Program Files\Java\jre6
JVM Flags: <none>

Eclipse IDE for C/C++ Developers

Version: Indigo Service Release 1
Build id: 20110916-0149

I am starting eclipse with a maximum of 1024MB of Heap Space.


Thanks in advance


Michael

Re: Indexer freezes at 0% [message #841892 is a reply to message #841347] Wed, 11 April 2012 20:45 Go to previous message
Yevgeny Shifrin is currently offline Yevgeny ShifrinFriend
Messages: 207
Registered: July 2009
Senior Member
Hi,

I would suggest opening a bug at https://bugs.eclipse.org/bugs/enter_bug.cgi?product=CDT&format=guided with all relevant information.

Thanks,
Yevgeny
Previous Topic:Synchronized Project Settings problem
Next Topic:Installation help
Goto Forum:
  


Current Time: Thu Dec 18 15:36:00 GMT 2014

Powered by FUDForum. Page generated in 0.02202 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software