Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » M2M (model-to-model transformation) » [ATL] xsi:schemaLocation is lost in the resulatant xmi file
[ATL] xsi:schemaLocation is lost in the resulatant xmi file [message #105002] Fri, 15 May 2009 15:56 Go to next message
Mikai Yang is currently offline Mikai YangFriend
Messages: 149
Registered: July 2009
Senior Member
Hi,
There is no corresponding xsi:schemaLocation in the output xmi file, leading to error when opending this file in the model editor. What can I do about it?
Thanks.
Michael.
Re: [ATL] xsi:schemaLocation is lost in the resulatant xmi file [message #671638 is a reply to message #105002] Wed, 18 May 2011 14:37 Go to previous messageGo to next message
Patrick Schmitt is currently offline Patrick SchmittFriend
Messages: 87
Registered: July 2009
Member
I have exactly the same problem.

Converting XMI to XMI with a ATL script inside Eclipse launch configuration.


Any suggestions ??
Re: [ATL] xsi:schemaLocation is lost in the resulatant xmi file [message #671747 is a reply to message #671638] Wed, 18 May 2011 21:10 Go to previous messageGo to next message
Cesar Caves is currently offline Cesar CavesFriend
Messages: 29
Registered: July 2009
Junior Member
I also have the same problem.
Right now, if I want to open the resultant *.xmi file with the Sample Ecore Model Editor, previously I have to add the "xsi:schemaLocation" attribute to the file header editing it directly, opening it with the Text Editor.
To know exactly what the correct value should be, what I do is to create a sample model conforming to the meta-model in question by right clicking on the meta-model *.ecore file and selecting "Create dynamic instance". The empty sample model that is automatically created contains the "xsi:schemaLocation" attribute with the right value.
But if someone know how to get the output *.xmi file from an ATL transfo. with this attribute, would be very appreciated.

Regards,

C├ęsar
Re: [ATL] xsi:schemaLocation is lost in the resulatant xmi file [message #671845 is a reply to message #671747] Thu, 19 May 2011 07:25 Go to previous messageGo to next message
Sylvain EVEILLARD is currently offline Sylvain EVEILLARDFriend
Messages: 523
Registered: July 2009
Senior Member
EMF has an option for that (see this). Unfortunately ATL don't handle this option. You still have the option to launch the transformation in Java where you will be able to re-serialize the resource using this option.
Re: [ATL] xsi:schemaLocation is lost in the resulatant xmi file [message #671889 is a reply to message #671845] Thu, 19 May 2011 09:25 Go to previous messageGo to next message
Patrick Schmitt is currently offline Patrick SchmittFriend
Messages: 87
Registered: July 2009
Member
Maybe we should file a Bug for that topic? would be nice enhacement
Re: [ATL] xsi:schemaLocation is lost in the resulatant xmi file [message #671925 is a reply to message #671889] Thu, 19 May 2011 11:37 Go to previous message
Sylvain EVEILLARD is currently offline Sylvain EVEILLARDFriend
Messages: 523
Registered: July 2009
Senior Member
You can also use your own implementation of an EMF resource using the file extension. In which case you can use ATL launch configurations and still get the correct result.
Previous Topic:[ATL] Looking for Packages
Next Topic:[Xtend] Setting class attributes which are of a custom EDataType type.
Goto Forum:
  


Current Time: Sat Nov 22 10:30:53 GMT 2014

Powered by FUDForum. Page generated in 0.02675 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software