Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Epsilon » installing epsilon on galileo(dependency error)
installing epsilon on galileo [message #837272] Thu, 05 April 2012 09:15 Go to next message
Helle Hvid Hansen is currently offline Helle Hvid Hansen
Messages: 2
Registered: April 2012
Junior Member
Hi,

I am trying to install Epsilon on Galileo (linux 64-bits), but I am getting dependency errors that I don't know how to resolve (I admit that I am not a very experienced eclipse user). The interim update site and the stable update site seem to point to the same Epsilon version, but I tried installing from both, and the error I get differs, as shown below.

(In case you are wondering: I need to work with Galileo because some of the other required plugins don't work well in Indigo)

Thanks in advance!

Helle

---- Error when installing epsilon from interim site:

Cannot complete the install because one or more required items could not be found.
Software currently installed: Epsilon Core (Incubation) 0.9.1.201204041101 (org.eclipse.epsilon.feature.feature.group 0.9.1.201204041101)
Missing requirement: EUnit EMF Compare Integration (Incubation) 0.9.1.201204041101 (org.eclipse.epsilon.eunit.dt.diff.emf 0.9.1.201204041101) requires 'bundle org.eclipse.emf.compare.ui 0.0.0' but it could not be found
Cannot satisfy dependency:
From: Epsilon Core (Incubation) 0.9.1.201204041101 (org.eclipse.epsilon.feature.feature.group 0.9.1.201204041101)
To: org.eclipse.epsilon.eunit.dt.diff.emf [0.9.1.201204041101]

---- Error when installing epsilon from stable update site:

Cannot complete the install because one or more required items could not be found.
Software currently installed: Epsilon Concordance (Incubation) 0.9.1.201107251201 (org.eclipse.epsilon.concordance.feature.feature.group 0.9.1.201107251201)
Missing requirement: Epsilon EMF Model Support (Incubation) 0.9.1.201107251201 (org.eclipse.epsilon.emc.emf 0.9.1.201107251201) requires 'bundle org.eclipse.emf.compare.match 0.0.0' but it could not be found
Cannot satisfy dependency:
From: Epsilon Concordance (Incubation) 0.9.1.201107251201 (org.eclipse.epsilon.concordance.feature.feature.group 0.9.1.201107251201)
To: org.eclipse.epsilon.hutn.xmi 0.0.0
Cannot satisfy dependency:
From: Human Usable Textual Notation XMI Bridge (Incubation) 0.8.1.201107251201 (org.eclipse.epsilon.hutn.xmi 0.8.1.201107251201)
To: bundle org.eclipse.epsilon.emc.emf 0.0.0
Re: installing epsilon on galileo [message #837281 is a reply to message #837272] Thu, 05 April 2012 09:26 Go to previous messageGo to next message
Dimitris Kolovos is currently offline Dimitris Kolovos
Messages: 838
Registered: July 2009
Senior Member
Hi Helle,

I'm looking at this now.

Cheers,
Dimitris
Re: installing epsilon on galileo [message #837543 is a reply to message #837281] Thu, 05 April 2012 16:16 Go to previous messageGo to next message
Dimitris Kolovos is currently offline Dimitris Kolovos
Messages: 838
Registered: July 2009
Senior Member
Hi Helle,

This actually seems to be working fine for me. I downloaded a copy of the Eclipse Galileo Modelling distribution from http://eclipsesource.com/en/downloads/eclipse-galileo-download/, went to Help->Install new software, added the Epsilon update site (http://download.eclipse.org/epsilon/updates/), selected the "Contact all update sites ..." option and Epsilon installed without problems.

Cheers,
Dimitris
Re: installing epsilon on galileo [message #838045 is a reply to message #837543] Fri, 06 April 2012 09:39 Go to previous messageGo to next message
Helle Hvid Hansen is currently offline Helle Hvid Hansen
Messages: 2
Registered: April 2012
Junior Member
Hi Dimitris,

Thanks for looking into this. I was trying to install in a galileo that was preinstalled on my machine. Installing Epsilon in a fresh galileo indeed works! Sorry for the hassle.

All the best,
Helle
Re: installing epsilon on galileo [message #839847 is a reply to message #838045] Mon, 09 April 2012 05:30 Go to previous message
Maarten Bezemer is currently offline Maarten Bezemer
Messages: 109
Registered: February 2012
Senior Member
You seem to be missing the EMF Compare framework (I cannot post links..?! so you have to Google 'EMF Compare' and click the first hit)
If you are not using the Eclipse Galileo Modelling distribution,you need to install this framework manually. (I needed to do so as I use Eclipse from the Ubuntu repositories)
Previous Topic:[Eugenia] Phantom nodes
Next Topic:Inheritance in rules [SOLVED]
Goto Forum:
  


Current Time: Wed Aug 27 07:01:34 EDT 2014

Powered by FUDForum. Page generated in 0.01738 seconds