Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Where do general Eclipse questions go?(Can't get Marketplace or Update service to work under Helios)
Where do general Eclipse questions go? [message #835030] Mon, 02 April 2012 17:56 Go to next message
Karl Krasnowsky is currently offline Karl Krasnowsky
Messages: 9
Registered: March 2011
Location: Beaverton, OR
Junior Member

Windows 7 64,
Eclipse Helios 64,
Java SDK 1.6.25

Hey,
Before going down the route of filing a bug on this, thought I'd try to find a resolution before I went down another rabbit hole.

Installed new version (to me) of eclipse Helios on above mentioned system. Company is behind a firewall so I needed to configure network connection settings accordingly.
Went to Marketplace and installed subversion services from Subclipse, Maven services from JBoss tools and a couple of other items...

Seemed to work fine at first... Now I perform a Check For Updates process...
Takes forever as it creeps up to 50% of completion and just spins there for, well, forever from what I can tell. So I cancel the process and the log has this:

org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.IllegalArgumentException: Cannot create an update wizard on an unresolved operation)
at org.eclipse.swt.SWT.error(SWT.java:4083)
at org.eclipse.swt.SWT.error(SWT.java:3998)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:137)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4041)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3660)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2640)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2604)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2438)
at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:671)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:664)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:115)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:620)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:575)
at org.eclipse.equinox.launcher.Main.run(Main.java:1408)
at org.eclipse.equinox.launcher.Main.main(Main.java:1384)
Caused by: java.lang.IllegalArgumentException: Cannot create an update wizard on an unresolved operation
at org.eclipse.core.runtime.Assert.isLegal(Assert.java:63)
at org.eclipse.equinox.internal.p2.ui.dialogs.UpdateWizard.<init>(UpdateWizard.java:76)
at org.eclipse.equinox.p2.ui.ProvisioningUI.openUpdateWizard(ProvisioningUI.java:227)
at org.eclipse.equinox.internal.p2.ui.sdk.UpdateHandler.doExecute(UpdateHandler.java:42)
at org.eclipse.equinox.internal.p2.ui.sdk.PreloadingRepositoryHandler$3$1.run(PreloadingRepositoryHandler.java:101)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:134)
... 23 more


Is there a known problem in Helios that can be adjusted for this? Can't find anything directly mentioning this in bugzilla databbase, though there seem to be a ton of items that involve update issues.

Where do I go with this, it's not exactly blocking us, but it soon will be.
Should I fall back to Galileo?

Re: Where do general Eclipse questions go? [message #835692 is a reply to message #835030] Tue, 03 April 2012 15:02 Go to previous message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2269
Registered: July 2009
Senior Member
No, in fact you should be starting from Indigo SR2. Any bugs you find in Helios or Galileo at this point aren't likely to be fixed in anything earlier than Juno.

It's possible that one or more of the plug-ins you've installed has tried to be helpful in managing your proxy settings; check your Preference pages to make sure that's not an issue.


---
Nitin Dahyabhai
Eclipse WTP, IBM
Previous Topic:Installing ATF (Ajax Toolkit framework)
Next Topic:classpath issue
Goto Forum:
  


Current Time: Thu Sep 18 13:48:35 GMT 2014

Powered by FUDForum. Page generated in 0.29641 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software