Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » OCL » errors in Eclipse Modeling Tools for Indigo Packages
errors in Eclipse Modeling Tools for Indigo Packages [message #833970] Sun, 01 April 2012 07:29 Go to next message
Lucy Chan is currently offline Lucy Chan
Messages: 29
Registered: March 2012
Junior Member
I download the Eclipse Modeling Tools for Indigo Packages. And try to install the OCL Examples and Editors from the help->install new software in Eclipse. But during the installing, it shows some errors as follows:
An error occurred while collecting items to be installed
session context was:(profile=epp.package.modeling,

phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=,

action=).
Comparison method violates its general contract!
Comparison method violates its general contract!
I just feel puzzled, and for my experiment I need this tool. so I hope someone can give me some solutions. Thanks sincerely.
Re: errors in Eclipse Modeling Tools for Indigo Packages [message #834021 is a reply to message #833970] Sun, 01 April 2012 09:09 Go to previous messageGo to next message
Ed Willink is currently offline Ed Willink
Messages: 4046
Registered: July 2009
Senior Member
Hi Lucy

I've never seen this problem, but rummaging through Bugzilla it would
appear to be commonly related to an Eclipse 3.7.0 to 3.7.1 upgrade using
Java 7. There is a workaround in
https://bugs.eclipse.org/bugs/show_bug.cgi?id=317785#c45. However
https://bugs.eclipse.org/bugs/show_bug.cgi?id=364735 suggests there is
some outstanding issue.

If you are indeed upgrading from 3.7.0, try the workaround. Otherwise
try just installing 3.7.2 directly.

Regards

Ed Willink


On 01/04/2012 08:29, Lucy Chan wrote:
> Comparison method violates its general contract
Re: errors in Eclipse Modeling Tools for Indigo Packages [message #834053 is a reply to message #834021] Sun, 01 April 2012 10:16 Go to previous messageGo to next message
Lucy Chan is currently offline Lucy Chan
Messages: 29
Registered: March 2012
Junior Member
Dear Ed Willink,
I have solved the problem by using a lower edition. I feel so thankful for your support these days. Your help is greatly appreciated. I will keep contact in this forum. Thanks very much.
Best Regards
Lucy
Re: errors in Eclipse Modeling Tools for Indigo Packages [message #834096 is a reply to message #834053] Sun, 01 April 2012 11:49 Go to previous message
Ed Willink is currently offline Ed Willink
Messages: 4046
Registered: July 2009
Senior Member
Hi Lucy

Glad the problem's solved.

For my (other's) benefit could you identify the Platform, EMF and OCL
versions you were trying to use.

At present OCL is very restrictive on exact versions. Some other
projects such as Acceleo and Xtext are much more tolerant. I would like
to be more tolerant on OCL too.

Regards

Ed Willink

On 01/04/2012 11:16, Lucy Chan wrote:
> Dear Ed Willink,
> I have solved the problem by using a lower edition. I feel so
> thankful for your support these days. Your help is greatly
> appreciated. I will keep contact in this forum. Thanks very much.
> Best Regards
> Lucy
Previous Topic:problems about EMF Incubating components
Next Topic:A strange result in OCL query
Goto Forum:
  


Current Time: Sun Sep 21 16:29:51 GMT 2014

Powered by FUDForum. Page generated in 0.02718 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software