Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » SWT error while trying to create JavaServer Faces project
SWT error while trying to create JavaServer Faces project [message #832488] Fri, 30 March 2012 07:54 Go to next message
Alex Averbuch is currently offline Alex AverbuchFriend
Messages: 13
Registered: March 2012
Junior Member
Hi,
FYI, I also posted this in the "Web Tools Project (WTP)" forum, as I wasn't sure which one to place the issue in.

I'm currently learning how to develop JavaServer Faces web applications, using Eclipse. To do so I'm following a tutorial (as I've posted less than 25 comments, I can't share the link to the tutorial in this thread).

However, Eclipse gives me an error when I try to create a JavaServer Faces project.
Any/all help in resolving this is greatly appreciated!

Here's what I did:

(1) File->New->Dynamic Web Project

(2) On "Dynamic Web Project" page
Project name: "JSFProject"
Configuration: JavaServer Faces V2.0 Project
<press> Next

(3) On "Java" page
<press> Next

(4) On "Web Module" page
<select> "Generate web.xml deployment descriptor"
<press> Next

(5) On "JSF Capabilities" page
Because this is the first time I'm creating a JSF project, I need to install/download a JSF implementation.
<press> "Download library..."

(6) After pressing the "Download library..." button I get this error:

Unhandled event loop exception
No more handles [MOZILLA_FIVE_HOME='/usr/lib64/xulrunner-addons'] (java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons:
Can't load /opt/eclipse/eclipse_v3.6.2/configuration/org.eclipse.osgi/bundles/151/1/.cp/libswt-mozilla-gtk-3659.so
no swt-mozilla-gtk in java.library.path
Can't load library: /tmp/swtlib-64/libswt-mozilla-gtk-3659.so
Can't load library: /tmp/swtlib-64/libswt-mozilla-gtk.so
)


Any ideas?

Regards,
Alex
Re: SWT error while trying to create JavaServer Faces project [message #832522 is a reply to message #832488] Fri, 30 March 2012 08:40 Go to previous messageGo to next message
Alex Averbuch is currently offline Alex AverbuchFriend
Messages: 13
Registered: March 2012
Junior Member
ok... through Synaptic Package Manager I just installed all "libswt-*" packages.
It seems as though "libswt-mozilla-gtk" is no longer included in the 11.10 Ubuntu distribution.

Here are all the "libswt" packages on my operating system:

alex@alex-laptop:~$ locate libswt
/home/alex/.swt/lib/linux/x86_64/libswt-webkit12-gtk-3735.so
/home/alex/.swt/lib/linux/x86_64/libswt-webkit12-gtk-3740.so
/opt/eclipse/eclipse_v3.6.2/configuration/org.eclipse.osgi/bundles/151/1/.cp/libswt-atk-gtk-3659.so
/opt/eclipse/eclipse_v3.6.2/configuration/org.eclipse.osgi/bundles/151/1/.cp/libswt-cairo-gtk-3659.so
/opt/eclipse/eclipse_v3.6.2/configuration/org.eclipse.osgi/bundles/151/1/.cp/libswt-gnome-gtk-3659.so
/opt/eclipse/eclipse_v3.6.2/configuration/org.eclipse.osgi/bundles/151/1/.cp/libswt-gtk-3659.so
/opt/eclipse/eclipse_v3.6.2/configuration/org.eclipse.osgi/bundles/151/1/.cp/libswt-mozilla-gtk-3659.so
/opt/eclipse/eclipse_v3.6.2/configuration/org.eclipse.osgi/bundles/151/1/.cp/libswt-pi-gtk-3659.so
/opt/eclipse/eclipse_v3.6.2/configuration/org.eclipse.osgi/bundles/151/1/.cp/libswt-xpcominit-gtk-3659.so
/usr/lib/jni/libswt-atk-gtk-3659.so
/usr/lib/jni/libswt-awt-gtk-3659.so
/usr/lib/jni/libswt-gtk-3659.so
/usr/lib/jni/libswt-pi-gtk-3659.so
/usr/share/doc/libswt-gtk-3.6-java
/usr/share/doc/libswt-gtk-3.6-jni
/usr/share/doc/libswt-gtk-3.6-java/README.Debian
/usr/share/doc/libswt-gtk-3.6-java/README.gz
/usr/share/doc/libswt-gtk-3.6-java/changelog.Debian.gz
/usr/share/doc/libswt-gtk-3.6-java/copyright
/usr/share/doc/libswt-gtk-3.6-jni/changelog.Debian.gz
/usr/share/doc/libswt-gtk-3.6-jni/copyright
/usr/share/java-config/libswt-gtk-3.6-java
/var/lib/dpkg/info/libswt-gtk-3.6-java.list
/var/lib/dpkg/info/libswt-gtk-3.6-java.md5sums
/var/lib/dpkg/info/libswt-gtk-3.6-java.postinst
/var/lib/dpkg/info/libswt-gtk-3.6-java.prerm
/var/lib/dpkg/info/libswt-gtk-3.6-jni.list
/var/lib/dpkg/info/libswt-gtk-3.6-jni.md5sums

Has anyone come across this problem before?

FYI, my software versions are: Ubuntu 11.10 & Eclipse 3.62 & Java6/Java7 (I change from time to time)


At the moment I'm trying to find out if it's possible to get this combination working, or if I'll need to upgrade to a later Eclipse version.
Re: SWT error while trying to create JavaServer Faces project [message #832535 is a reply to message #832522] Fri, 30 March 2012 08:54 Go to previous message
Alex Averbuch is currently offline Alex AverbuchFriend
Messages: 13
Registered: March 2012
Junior Member
SOLVED!

Cause: Ubuntu recently upgrade to "xulrunner-2.0", an many version of Eclipse are not compatible with it.

Solution: install "xulrunner-1.9.2" directly from Synaptic Package Manager
Previous Topic:Java SWT Image and Transparency
Next Topic:Problem with asyncExec() - freeze app
Goto Forum:
  


Current Time: Thu Nov 27 05:00:19 GMT 2014

Powered by FUDForum. Page generated in 0.10584 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software