Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Installing JDT onto CDT Eclipse(Error when setting up JDT onto CDT)
Installing JDT onto CDT Eclipse [message #832296] Fri, 30 March 2012 01:56 Go to next message
Joshua Weaver is currently offline Joshua WeaverFriend
Messages: 1
Registered: March 2012
Junior Member
I have installed the CDT Eclipse version, added the Galileo Install source, and seem to have an error. When adding the JDT I get the series of errors that follows. I have installed using the same process before with no issues. I do not believe I have any issues. The current setup is the JDK 6u31 and Newest CDT Eclipse 3.7.2 64 bit. Thanks for the help.

Cannot complete the install because of a conflicting dependency.
Software being installed: Eclipse Java Development Tools 3.5.2.r352_v20100108-7r88FEwFI0WTuoBl0iaG0tyhfZH6 (org.eclipse.jdt.feature.group 3.5.2.r352_v20100108-7r88FEwFI0WTuoBl0iaG0tyhfZH6)
Software currently installed: Eclipse IDE for C/C++ Developers 1.4.2.20120213-0813 (epp.package.cpp 1.4.2.20120213-0813)
Only one of the following can be installed at once:
Simple Configurator Manipulator 2.0.0.v20110502-1955 (org.eclipse.equinox.simpleconfigurator.manipulator 2.0.0.v20110502-1955)
Simple Configurator Manipulator 1.0.101.R35x_v20100209 (org.eclipse.equinox.simpleconfigurator.manipulator 1.0.101.R35x_v20100209)
Simple Configurator Manipulator 2.0.0.v20110815-1438 (org.eclipse.equinox.simpleconfigurator.manipulator 2.0.0.v20110815-1438)
Simple Configurator Manipulator 1.0.100.v20090520-1905 (org.eclipse.equinox.simpleconfigurator.manipulator 1.0.100.v20090520-1905)
Only one of the following can be installed at once:
Eclipse Platform 3.7.1.v201109091335 (org.eclipse.platform 3.7.1.v201109091335)
Eclipse Platform 3.7.0.v201106131736 (org.eclipse.platform 3.7.0.v201106131736)
Eclipse Platform 3.3.201.v200909170800 (org.eclipse.platform 3.3.201.v200909170800)
Eclipse Platform 3.3.202.v201002111343 (org.eclipse.platform 3.3.202.v201002111343)
Eclipse Platform 3.7.2.v201202080800 (org.eclipse.platform 3.7.2.v201202080800)
Cannot satisfy dependency:
From: Eclipse IDE for C/C++ Developers 1.4.2.20120213-0813 (epp.package.cpp 1.4.2.20120213-0813)
To: org.eclipse.epp.package.cpp.feature.feature.group [1.4.2.20120213-0813]
Cannot satisfy dependency:
From: Eclipse IDE for C/C++ Developers 1.4.2.20120213-0813 (epp.package.cpp 1.4.2.20120213-0813)
To: org.eclipse.platform.ide 0.0.0
Cannot satisfy dependency:
From: EPP CPP Feature 1.4.2.20120213-0813 (org.eclipse.epp.package.cpp.feature.feature.group 1.4.2.20120213-0813)
To: org.eclipse.platform.feature.group [3.7.2.v20120207-1839-9gF7UHPDFxGjd-PqDr2jX_4yKaumkoHTz04_q-q]
Cannot satisfy dependency:
From: Equinox p2 Core Function 1.0.1.v20110906-1605-8290FZ9FVKHVRKtmx3fpNuo02129 (org.eclipse.equinox.p2.core.feature.feature.group 1.0.1.v20110906-1605-8290FZ9FVKHVRKtmx3fpNuo02129)
To: org.eclipse.equinox.simpleconfigurator.manipulator [2.0.0.v20110815-1438]
Cannot satisfy dependency:
From: Equinox p2 Provisioning for IDEs. 2.1.2.R37x_v20110815-1155-6-Bk8pYWZz0qUTX5I15GZWwbXkrl (org.eclipse.equinox.p2.user.ui.feature.group 2.1.2.R37x_v20110815-1155-6-Bk8pYWZz0qUTX5I15GZWwbXkrl)
To: org.eclipse.equinox.p2.core.feature.feature.group [1.0.1.v20110906-1605-8290FZ9FVKHVRKtmx3fpNuo02129]
Cannot satisfy dependency:
From: Eclipse Java Development Tools 3.5.2.r352_v20100108-7r88FEwFI0WTuoBl0iaG0tyhfZH6 (org.eclipse.jdt.feature.group 3.5.2.r352_v20100108-7r88FEwFI0WTuoBl0iaG0tyhfZH6)
To: org.eclipse.jdt.junit [3.5.2.r352_v20100113-0800]
Cannot satisfy dependency:
From: Java Development Tools JUnit support 3.5.2.r352_v20100113-0800 (org.eclipse.jdt.junit 3.5.2.r352_v20100113-0800)
To: bundle org.eclipse.equinox.simpleconfigurator.manipulator [1.0.100,2.0.0)
Cannot satisfy dependency:
From: Eclipse Platform 3.5.1.R35x_v20090910-9gEeG1_FthkNDSP2odXdThaOu9GFDPn83DGB7 (org.eclipse.platform.feature.group 3.5.1.R35x_v20090910-9gEeG1_FthkNDSP2odXdThaOu9GFDPn83DGB7)
To: org.eclipse.platform [3.3.201.v200909170800]
Cannot satisfy dependency:
From: Eclipse Platform 3.5.2.R35x_v20100210-0800-9hEiFzmFst-TiEn9hNYgDWg1XN8ulH_JvCNGB (org.eclipse.platform.feature.group 3.5.2.R35x_v20100210-0800-9hEiFzmFst-TiEn9hNYgDWg1XN8ulH_JvCNGB)
To: org.eclipse.platform [3.3.202.v201002111343]
Cannot satisfy dependency:
From: Eclipse Platform 3.7.0.v20110530-9gF7UHNFFt4cwE-pkZDJ7oz-mj4OSEIlu9SEv0f (org.eclipse.platform.feature.group 3.7.0.v20110530-9gF7UHNFFt4cwE-pkZDJ7oz-mj4OSEIlu9SEv0f)
To: org.eclipse.platform [3.7.0.v201106131736]
Cannot satisfy dependency:
From: Eclipse Platform 3.7.1.r37x_v20110729-9gF7UHOxFtniV7mI3T556iZN9AU8bEZ1lHMcVK (org.eclipse.platform.feature.group 3.7.1.r37x_v20110729-9gF7UHOxFtniV7mI3T556iZN9AU8bEZ1lHMcVK)
To: org.eclipse.platform [3.7.1.v201109091335]
Cannot satisfy dependency:
From: Eclipse Platform 3.7.2.v20120207-1839-9gF7UHPDFxGjd-PqDr2jX_4yKaumkoHTz04_q-q (org.eclipse.platform.feature.group 3.7.2.v20120207-1839-9gF7UHPDFxGjd-PqDr2jX_4yKaumkoHTz04_q-q)
To: org.eclipse.platform [3.7.2.v201202080800]
Cannot satisfy dependency:
From: Eclipse Platform 3.5.1.M20090917-0800 (org.eclipse.platform.ide 3.5.1.M20090917-0800)
To: org.eclipse.platform.feature.group [3.5.1.R35x_v20090910-9gEeG1_FthkNDSP2odXdThaOu9GFDPn83DGB7]
Cannot satisfy dependency:
From: Eclipse Platform 3.5.2.M20100211-1343 (org.eclipse.platform.ide 3.5.2.M20100211-1343)
To: org.eclipse.platform.feature.group [3.5.2.R35x_v20100210-0800-9hEiFzmFst-TiEn9hNYgDWg1XN8ulH_JvCNGB]
Cannot satisfy dependency:
From: Eclipse Platform 3.7.0.I20110613-1736 (org.eclipse.platform.ide 3.7.0.I20110613-1736)
To: org.eclipse.platform.feature.group [3.7.0.v20110530-9gF7UHNFFt4cwE-pkZDJ7oz-mj4OSEIlu9SEv0f]
Cannot satisfy dependency:
From: Eclipse Platform 3.7.1.M20110909-1335 (org.eclipse.platform.ide 3.7.1.M20110909-1335)
To: org.eclipse.platform.feature.group [3.7.1.r37x_v20110729-9gF7UHOxFtniV7mI3T556iZN9AU8bEZ1lHMcVK]
Cannot satisfy dependency:
From: Eclipse Platform 3.7.2.M20120208-0800 (org.eclipse.platform.ide 3.7.2.M20120208-0800)
To: org.eclipse.equinox.p2.user.ui.feature.group [2.1.2.R37x_v20110815-1155-6-Bk8pYWZz0qUTX5I15GZWwbXkrl]
Re: Installing JDT onto CDT Eclipse [message #834766 is a reply to message #832296] Mon, 02 April 2012 11:14 Go to previous message
Satyam Kandula is currently offline Satyam KandulaFriend
Messages: 444
Registered: July 2009
Senior Member
You may be choosing a wrong version of JDT. Note that Galileo is 3.5 and you tell that you have 3.7 CDT. You may want to try installing 3.7 JDT.
Previous Topic:suggestion needed for best way to load a class from many projects in the workspace
Next Topic:Where can I get the test plugins?
Goto Forum:
  


Current Time: Sun Dec 21 17:30:03 GMT 2014

Powered by FUDForum. Page generated in 0.46421 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software