Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » OCL » lack a class "QueryDelegateTextViewer"(error in the implementation of "OCL interpreter example")
lack a class "QueryDelegateTextViewer" [message #831022] Wed, 28 March 2012 07:08 Go to next message
Lucy Chan is currently offline Lucy Chan
Messages: 29
Registered: March 2012
Junior Member
I just download the package named "org.eclipse.examples.interpreter", but it some errors.
In the file "OCLQueryDelegateTextViewer.java", it shows an error about missing a "QueryDelegateTextViewer" class in org.eclipse.emf.edit.ui.jar.
Actually, I downloat the jar package named "org.eclipse.emf.edit.ui_2.5.0.v200906010115". In the package, I cannot find the QueryDelegateTextViewer.class in the org.eclipse.emf.edit.ui file, which just contains EditUIMarkerHelper.class, EditUIUtil$EclipseUtil.class and EditUIUtil.class. I just wonder if the problem is caused by the version of jar package and how I can solved the problem.
If you have some suggestions, leave message for me or send me an email, my email address is chenluxiabc@yahoo.com.cn
thanks very much in advance
Re: lack a class "QueryDelegateTextViewer" [message #831158 is a reply to message #831022] Wed, 28 March 2012 10:50 Go to previous messageGo to next message
Ed Willink is currently offline Ed Willink
Messages: 3838
Registered: July 2009
Senior Member
Hi

On the one hand you are mixing and matching by using Indigo sources on
Galileo so mismatches are not surprising.

On the other hand (https://bugs.eclipse.org/bugs/show_bug.cgi?id=375548
raised) there should be a lower bound that tells you that you need
emf.edit.ui 2.7.

Regards

Ed Willink


On 28/03/2012 07:08, Lucy Chan wrote:
> I just download the package named "org.eclipse.examples.interpreter",
> but it some errors. In the file "OCLQueryDelegateTextViewer.java", it
> shows an error about missing a "QueryDelegateTextViewer" class in
> org.eclipse.emf.edit.ui.jar.
> Actually, I downloat the jar package named
> "org.eclipse.emf.edit.ui_2.5.0.v200906010115". In the package, I
> cannot find the QueryDelegateTextViewer.class in the
> org.eclipse.emf.edit.ui file, which just contains
> EditUIMarkerHelper.class, EditUIUtil$EclipseUtil.class and
> EditUIUtil.class. I just wonder if the problem is caused by the
> version of jar package and how I can solved the problem.
> If you have some suggestions, leave message for me or send me an
> email, my email address is mailto:chenluxiabc@xxxxxxxx.cn
> thanks very much in advance
Re: lack a class "QueryDelegateTextViewer" [message #831163 is a reply to message #831158] Wed, 28 March 2012 10:52 Go to previous messageGo to next message
Ed Willink is currently offline Ed Willink
Messages: 3838
Registered: July 2009
Senior Member
Hi

If you want to use Galileo, download the Galileo source and just delete
all code concerned with QueryDelegateTextViewer. You may also need to
trim delegate code in ocl.ecore, since that was introduced in Helios.

As from Helios, there is a new Console based on Xtext in
org.eclipse.ocl.examples.xtext.console.

Regards

Ed Willink

On 28/03/2012 10:50, Ed Willink wrote:
> Hi
>
> On the one hand you are mixing and matching by using Indigo sources on
> Galileo so mismatches are not surprising.
>
> On the other hand
> (https://bugs.eclipse.org/bugs/show_bug.cgi?id=375548 raised) there
> should be a lower bound that tells you that you need emf.edit.ui 2.7.
>
> Regards
>
> Ed Willink
>
>
> On 28/03/2012 07:08, Lucy Chan wrote:
>> I just download the package named "org.eclipse.examples.interpreter",
>> but it some errors. In the file "OCLQueryDelegateTextViewer.java", it
>> shows an error about missing a "QueryDelegateTextViewer" class in
>> org.eclipse.emf.edit.ui.jar.
>> Actually, I downloat the jar package named
>> "org.eclipse.emf.edit.ui_2.5.0.v200906010115". In the package, I
>> cannot find the QueryDelegateTextViewer.class in the
>> org.eclipse.emf.edit.ui file, which just contains
>> EditUIMarkerHelper.class, EditUIUtil$EclipseUtil.class and
>> EditUIUtil.class. I just wonder if the problem is caused by the
>> version of jar package and how I can solved the problem.
>> If you have some suggestions, leave message for me or send me an
>> email, my email address is mailto:chenluxiabc@xxxxxxxx.cn
>> thanks very much in advance
>
Re: lack a class "QueryDelegateTextViewer" [message #831613 is a reply to message #831158] Thu, 29 March 2012 01:14 Go to previous message
Lucy Chan is currently offline Lucy Chan
Messages: 29
Registered: March 2012
Junior Member
Thanks a lot for your suggestion. I will search for the org.eclipse.emf.edit.ui 2.7. Besides, if you can suggest me some other tools to make OCL verification?
Previous Topic:Problem about OCLinEcore
Next Topic:derived attribute in OCLinEcore editor
Goto Forum:
  


Current Time: Wed Apr 16 03:28:05 EDT 2014

Powered by FUDForum. Page generated in 0.01933 seconds