Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » TPTP 4.4 failure
TPTP 4.4 failure [message #102104] Sat, 30 June 2007 12:28 Go to next message
Eclipse User
Originally posted by: n.sherlock.gmail.com

Hey all,

I downloaded the latest Eclipse 3.3, and grabbed TPTP 4.4 from the
update manager, but I can't seem to get it to do anything :). I didn't
touch any of the settings. When try to profile any application with
"Java Profiling (JRE 1.5 or newer) > Execution time analysis", I get
this message:

org.eclipse.core.runtime.CoreException
Agent Controller is unavailable under port 10006. Make sure that the
service is started and the port number is correct under preferences.

org.eclipse.tptp.platform.execution.exceptions.AgentControll erUnavailableException
at
org.eclipse.tptp.platform.jvmti.client.internal.launcher.uti l.AgentControllerDelegate.getConnection(AgentControllerDeleg ate.java:226)
at
org.eclipse.tptp.platform.jvmti.client.internal.launcher.uti l.AgentControllerDelegate.getConnection(AgentControllerDeleg ate.java:71)
at
org.eclipse.tptp.platform.jvmti.client.internal.launcher.TID elegateHelper.connectToAgentController(TIDelegateHelper.java :388)
at
org.eclipse.tptp.platform.jvmti.client.internal.launcher.TID elegateHelper.launch(TIDelegateHelper.java:308)
at
org.eclipse.tptp.platform.jvmti.client.internal.launcher.TIJ avaLauncherDelegate.launch(TIJavaLauncherDelegate.java:37)
at
org.eclipse.tptp.trace.ui.internal.launcher.core.LauncherUti lity.delegateInit(LauncherUtility.java:1153)
at
org.eclipse.tptp.trace.ui.provisional.launcher.PrimaryLaunch Delegate.run(PrimaryLaunchDelegate.java:196)
at java.lang.Thread.run(Unknown Source)

If I click the "Test connection" button in the Hosts preferences page,
Eclipse locks hard and I have to kill it in Task manager. Where do I
start in diagnosing this problem?

Cheers,
Nicholas Sherlock
Re: TPTP 4.4 failure [message #102121 is a reply to message #102104] Sun, 01 July 2007 07:25 Go to previous messageGo to next message
Asaf Yaffe is currently offline Asaf Yaffe
Messages: 333
Registered: July 2009
Senior Member
Nicholas,

Which O/S and Architecture are you using?

Thanks,
Asaf

--

Asaf Yaffe
Eclipse TPTP Committer, JVMTI Profiler
Re: TPTP 4.4 failure [message #102134 is a reply to message #102121] Sun, 01 July 2007 09:19 Go to previous messageGo to next message
Eclipse User
Originally posted by: n.sherlock.gmail.com

Asaf Yaffe wrote:
> Nicholas,
>
> Which O/S and Architecture are you using?

Windows XP SP2, running on Sun JRE 1.6.0_01-b06.

Cheers,
Nicholas Sherlock
Re: TPTP 4.4 failure [message #102150 is a reply to message #102134] Sun, 01 July 2007 17:11 Go to previous messageGo to next message
Charlie Kelly is currently offline Charlie Kelly
Messages: 276
Registered: July 2009
Senior Member
Hi Nicholas,

I had the same problem.
The problem "went away" when I used a 1.5 JRE.

Charlie


Nicholas Sherlock wrote:
> Asaf Yaffe wrote:
>> Nicholas,
>>
>> Which O/S and Architecture are you using?
>
> Windows XP SP2, running on Sun JRE 1.6.0_01-b06.
>
> Cheers,
> Nicholas Sherlock
Re: TPTP 4.4 failure [message #102164 is a reply to message #102150] Sun, 01 July 2007 22:44 Go to previous messageGo to next message
Eclipse User
Originally posted by: n.sherlock.gmail.com

Charlie Kelly wrote:
> Hi Nicholas,
>
> I had the same problem.
> The problem "went away" when I used a 1.5 JRE.
>
> Charlie

Ohhh, I was hopeful, but no change when running on Sun JRE 1.5.0_10-b03. :(

Cheers,
Nicholas Sherlock
Re: TPTP 4.4 failure [message #102184 is a reply to message #102164] Mon, 02 July 2007 07:39 Go to previous messageGo to next message
Igor Alelekov is currently offline Igor Alelekov
Messages: 139
Registered: July 2009
Senior Member
Hi Nicholas,

Is Integrated Agent Controller enabled in your preferences
(Window/Preferences/Agent Controller/Integrated Agent Controller)?

Regards,
Igor
Re: TPTP 4.4 failure [message #102973 is a reply to message #102184] Wed, 04 July 2007 11:58 Go to previous messageGo to next message
Eclipse User
Originally posted by: n.sherlock.gmail.com

Igor Alelekov wrote:
> Hi Nicholas,
>
> Is Integrated Agent Controller enabled in your preferences
> (Window/Preferences/Agent Controller/Integrated Agent Controller)?

Yes, it is enabled. Setting security to accept "all" instead of
"localhost" doesn't help either. Disabling Windows Firewall doesn't help.

Cheers,
Nicholas Sherlock
Re: TPTP 4.4 failure [message #103166 is a reply to message #102973] Thu, 05 July 2007 15:35 Go to previous messageGo to next message
Eclipse User
Originally posted by: adam.giemza.gmx.de

Hey Nicholas,

is it working now? I wanted to profile my application as well, without any
result. Same System configuration.

Greets,
Adam
Re: TPTP 4.4 failure [message #103479 is a reply to message #103166] Sun, 08 July 2007 03:37 Go to previous messageGo to next message
Eclipse User
Originally posted by: n.sherlock.gmail.com

Adam Giemza wrote:
> Hey Nicholas,
>
> is it working now? I wanted to profile my application as well, without any
> result. Same System configuration.

Sorry, I wish it were, but I haven't had any more luck getting it to work.

Cheers,
Nicholas Sherlock
Re: TPTP 4.4 failure [message #105062 is a reply to message #102104] Mon, 16 July 2007 17:43 Go to previous messageGo to next message
Eclipse User
Originally posted by: meackerman.rmanet.com

similiar problem here. Windows XP SP2. Eclipse 3.3 TPTP 4.4. Java
1.6.0_01

Fresh install of Eclipse.


org.eclipse.core.runtime.CoreException
Agent Controller is unavailable under port 10010. Make sure that the
service is started and the port number is correct under preferences.

org.eclipse.tptp.platform.execution.exceptions.AgentControll erUnavailableException
at
org.eclipse.tptp.platform.jvmti.client.internal.launcher.uti l.AgentControllerDelegate.getConnection(AgentControllerDeleg ate.java:226)
at
org.eclipse.tptp.platform.jvmti.client.internal.launcher.uti l.AgentControllerDelegate.getConnection(AgentControllerDeleg ate.java:71)
at
org.eclipse.tptp.platform.jvmti.client.internal.launcher.TID elegateHelper.connectToAgentController(TIDelegateHelper.java :388)
at
org.eclipse.tptp.platform.jvmti.client.internal.launcher.TID elegateHelper.launch(TIDelegateHelper.java:308)
at
org.eclipse.tptp.platform.jvmti.client.internal.launcher.TIJ avaLauncherDelegate.launch(TIJavaLauncherDelegate.java:37)
at
org.eclipse.tptp.trace.ui.internal.launcher.core.LauncherUti lity.delegateInit(LauncherUtility.java:1153)
at
org.eclipse.tptp.trace.ui.provisional.launcher.PrimaryLaunch Delegate.run(PrimaryLaunchDelegate.java:196)
at java.lang.Thread.run(Thread.java:595)
Re: TPTP 4.4 failure [message #105911 is a reply to message #105062] Fri, 20 July 2007 09:43 Go to previous messageGo to next message
Eclipse User
Originally posted by: cl.silistix.com

I remember reading somewhere that something (TPTP/AGR/Agent Controller)
doesn't support java 1.6.
You might try switching down to 1.5 and seeing if that works.

Mark Ackerman wrote:
> similiar problem here. Windows XP SP2. Eclipse 3.3 TPTP 4.4. Java
> 1.6.0_01
> Fresh install of Eclipse.
>
>
> org.eclipse.core.runtime.CoreException
> Agent Controller is unavailable under port 10010. Make sure that the
> service is started and the port number is correct under preferences.
>
> org.eclipse.tptp.platform.execution.exceptions.AgentControll erUnavailableException
>
> at
> org.eclipse.tptp.platform.jvmti.client.internal.launcher.uti l.AgentControllerDelegate.getConnection(AgentControllerDeleg ate.java:226)
>
> at
> org.eclipse.tptp.platform.jvmti.client.internal.launcher.uti l.AgentControllerDelegate.getConnection(AgentControllerDeleg ate.java:71)
>
> at
> org.eclipse.tptp.platform.jvmti.client.internal.launcher.TID elegateHelper.connectToAgentController(TIDelegateHelper.java :388)
>
> at
> org.eclipse.tptp.platform.jvmti.client.internal.launcher.TID elegateHelper.launch(TIDelegateHelper.java:308)
>
> at
> org.eclipse.tptp.platform.jvmti.client.internal.launcher.TIJ avaLauncherDelegate.launch(TIJavaLauncherDelegate.java:37)
>
> at
> org.eclipse.tptp.trace.ui.internal.launcher.core.LauncherUti lity.delegateInit(LauncherUtility.java:1153)
>
> at
> org.eclipse.tptp.trace.ui.provisional.launcher.PrimaryLaunch Delegate.run(PrimaryLaunchDelegate.java:196)
>
> at java.lang.Thread.run(Thread.java:595)
>
>
Re: TPTP 4.4 failure [message #105982 is a reply to message #102104] Fri, 20 July 2007 13:27 Go to previous messageGo to next message
Charlie Kelly is currently offline Charlie Kelly
Messages: 276
Registered: July 2009
Senior Member
Hi Nicholas,

I'm a newbie to TPTP and just downloaded the "all in one" distribution
for Europa and had a similar problem. Changing two things solved the
problems:

1) switched from JRE 1.6 to JRE 1.5
2) turned off Norton Internet security, which was blocking accessing to
host.

Hope this helps.

Charlie


Nicholas Sherlock wrote:
> Hey all,
>
> I downloaded the latest Eclipse 3.3, and grabbed TPTP 4.4 from the
> update manager, but I can't seem to get it to do anything :). I didn't
> touch any of the settings. When try to profile any application with
> "Java Profiling (JRE 1.5 or newer) > Execution time analysis", I get
> this message:
>
> org.eclipse.core.runtime.CoreException
> Agent Controller is unavailable under port 10006. Make sure that the
> service is started and the port number is correct under preferences.
>
> org.eclipse.tptp.platform.execution.exceptions.AgentControll erUnavailableException
>
> at
> org.eclipse.tptp.platform.jvmti.client.internal.launcher.uti l.AgentControllerDelegate.getConnection(AgentControllerDeleg ate.java:226)
>
> at
> org.eclipse.tptp.platform.jvmti.client.internal.launcher.uti l.AgentControllerDelegate.getConnection(AgentControllerDeleg ate.java:71)
>
> at
> org.eclipse.tptp.platform.jvmti.client.internal.launcher.TID elegateHelper.connectToAgentController(TIDelegateHelper.java :388)
>
> at
> org.eclipse.tptp.platform.jvmti.client.internal.launcher.TID elegateHelper.launch(TIDelegateHelper.java:308)
>
> at
> org.eclipse.tptp.platform.jvmti.client.internal.launcher.TIJ avaLauncherDelegate.launch(TIJavaLauncherDelegate.java:37)
>
> at
> org.eclipse.tptp.trace.ui.internal.launcher.core.LauncherUti lity.delegateInit(LauncherUtility.java:1153)
>
> at
> org.eclipse.tptp.trace.ui.provisional.launcher.PrimaryLaunch Delegate.run(PrimaryLaunchDelegate.java:196)
>
> at java.lang.Thread.run(Unknown Source)
>
> If I click the "Test connection" button in the Hosts preferences page,
> Eclipse locks hard and I have to kill it in Task manager. Where do I
> start in diagnosing this problem?
>
> Cheers,
> Nicholas Sherlock
Re: TPTP 4.4 failure [message #105996 is a reply to message #103479] Fri, 20 July 2007 16:22 Go to previous messageGo to next message
Eclipse User
Originally posted by: rick.ingham.expeditors.com

Are your Window/Preferences/General/NetworkConnections set to use a proxy?

I turned of the proxy setting and then everything worked.

I think this is a bug. I don't think it should use the proxy settings at
all. Even if it should, I had localhost in the proxy exclusion list, but
it was still trying to connect to the agent controller through the proxy.

If you have the proxy enabled, try disabling it.

I had the same symptom that it appeared even Test Connnection locked up
Eclipse, but in reality, it just took a long time for it to time out on
the proxy connection. It would come back, eventually.
Re: TPTP 4.4 failure [message #106191 is a reply to message #105911] Mon, 23 July 2007 16:08 Go to previous messageGo to next message
Eclipse User
Originally posted by: meackerman.rmanet.com

Since we rely on some 1.6 features, there's no going back to 1.5.

Guess we'll just have to look at using a different profiling tool.
Re: TPTP 4.4 failure [message #106257 is a reply to message #106191] Tue, 24 July 2007 10:41 Go to previous messageGo to next message
Asaf Yaffe is currently offline Asaf Yaffe
Messages: 333
Registered: July 2009
Senior Member
Mark Ackerman wrote:
> Since we rely on some 1.6 features, there's no going back to 1.5.
> Guess we'll just have to look at using a different profiling tool.
>

Have you tried using the standalone Agent Controller? It usually works
without problems with Java 6 VMs. Just make sure to specify a Java 6 JVM
after AC installation, when running the SetConfig script.

Thanks,
Asaf

--
Asaf Yaffe
Eclipse TPTP Committer, JVMTI Profiler
Re: TPTP 4.4 failure [message #108250 is a reply to message #106257] Thu, 09 August 2007 20:52 Go to previous messageGo to next message
Eclipse User
Originally posted by: meackerman.rmanet.com

Ok downloaded the standalone agent controller. Couldn't get it to start
as a windows service, but it ran as an application.

Started profiling my application, but the profiling is really slow.
Re: TPTP 4.4 failure [message #108599 is a reply to message #108250] Sun, 12 August 2007 13:27 Go to previous message
Asaf Yaffe is currently offline Asaf Yaffe
Messages: 333
Registered: July 2009
Senior Member
Mark Ackerman wrote:
> Ok downloaded the standalone agent controller. Couldn't get it to start
> as a windows service, but it ran as an application.
>
> Started profiling my application, but the profiling is really slow.

You can greatly improve the profiling performance by defining filters
which exclude irrelevant parts (packages, classes and methods) of your
application. Please refer to the TPTP documentation for more information
on defining and using filters.

HTH,
Asaf

--
Asaf Yaffe
Eclipse TPTP Committer, JVMTI Profiler
Previous Topic:Log view - Analyze selection: 90% CPU usage
Next Topic:STACK_INFORMATION option info needed
Goto Forum:
  


Current Time: Fri Oct 31 07:13:01 GMT 2014

Powered by FUDForum. Page generated in 0.02869 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software