Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » pkg-config missing/cannot be installed(cdt in 3.7.0 and 3.7.2 lacks pkg-config plugin)
pkg-config missing/cannot be installed [message #827021] Thu, 22 March 2012 19:53
Sergei Vorobyov is currently offline Sergei VorobyovFriend
Messages: 1
Registered: March 2012
Junior Member
Hi,

despite some extensive effort, I could not install the pkg-config support for cdt.

The stock Eclipse 3.7.0 which comes with Ubuntu 11.10 has corrupt dependencies and "install new software" does not work (refuses to install).

The newest 3.7.2 i installed instead suffers the same, and "pkg-config" never appears on the "preferences" menu, no matter you try, as described in the documentation.

The plugin web site on eclipse.org does not have the plugin code.

Neither does the referenced project web site, which contains the docs and .png images of the screenshots, but no plugin itself.

Apparently (judging by the forums posting) this problem persists for several years.

The ugly roundabouts like adding pkg-config ... to the misc compiler keys don't allow for fully using the IDE benefits and it verbosely complains about "errors" and unmet dependencies, while the code compiles flawlessly.

Any recipes on where to get and how to install the pkg-config plugin?

Many thanks!
Previous Topic:jre location problem
Next Topic:Http 400 bad request
Goto Forum:
  


Current Time: Mon Nov 24 20:22:20 GMT 2014

Powered by FUDForum. Page generated in 0.01953 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software