Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Drill through feature issue in UNIX(Drill through feature issue in UNIX)
Drill through feature issue in UNIX [message #826806] Thu, 22 March 2012 14:27 Go to next message
Annette Rego is currently offline Annette Rego
Messages: 11
Registered: March 2012
Junior Member
I have linked birt report inside master report using drill through feature of BIRT. In 'Link to' option i have given report name. This feature works fine in windows. It trys to open report using url

servername/reporting/frameset?__report=report%2FOfferDetail.rptdesign&__format=html&RP_OfferId=OY_P_AAAB_11113_1N&__overwrite=true&__locale=en_US&__designer=false

But in UNIX, it trys to open report using the url,
servername/reporting/frameset?__report=..%2F..%2F..%2F..%2F..%2F..%2F..%2F..%2F..%2Fdata%2Frnpersappdev1%2Fapps%2FWebSphere%2FAppServer6%2Fprofiles%2FAppSrv01%2FinstalledApps%2Frnpersappdev1Node01Cell%2FReporting.ear%2Fbirt.war%2Freport%2FOfferDetail.rptdesign&__format=html&RP_OfferId=OY_P_AAAB_11113_1N&__overwrite=true&__locale=en_US&__designer=false

which is not the valid url.I am using websphere. Any idea how to solve this issue?
Re: Drill through feature issue in UNIX [message #826877 is a reply to message #826806] Thu, 22 March 2012 15:56 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Can you post the report and your web.xml?

Jason

On 3/22/2012 10:27 AM, Annette Rego wrote:
> I have linked birt report inside master report using drill through
> feature of BIRT. In 'Link to' option i have given report name. This
> feature works fine in windows. It trys to open report using url
>
> servername/reporting/frameset?__report=report%2FOfferDetail.rptdesign&__format=html&RP_OfferId=OY_P_AAAB_11113_1N&__overwrite=true&__locale=en_US&__designer=false
>
>
> But in UNIX, it trys to open report using the url,
> servername/reporting/frameset?__report=..%2F..%2F..%2F..%2F..%2F..%2F..%2F..%2F..%2Fdata%2Frnpersappdev1%2Fapps%2FWebSphere%2FAppServer6%2Fprofiles%2FAppSrv01%2FinstalledApps%2Frnpersappdev1Node01Cell%2FReporting.ear%2Fbirt.war%2Freport%2FOfferDetail.rptdesign&__format=html&RP_OfferId=OY_P_AAAB_11113_1N&__overwrite=true&__locale=en_US&__designer=false
>
>
> which is not the valid url.I am using websphere. Any idea how to solve
> this issue?
>
Re: Drill through feature issue in UNIX [message #827582 is a reply to message #826806] Fri, 23 March 2012 14:34 Go to previous messageGo to next message
Annette Rego is currently offline Annette Rego
Messages: 11
Registered: March 2012
Junior Member
I have uploaded sample reports and my web.xml to illustrate the problem

master report url is
servername:9080/reporting/run?__report=report/master_report.rptdesign

linked report url in UNIX is coming as
localhost:9080/reporting/run?__report=..%2F..%2F..%2F..%2F..%2F..%2F..%2F..%2F..%2Fdata%2Frnpersappdev1%2Fapps%2FWebSphere%2FAppServer6%2Fprofiles%2FAppSrv01%2FinstalledApps%2Frnpersappdev1Node01Cell%2FReporting.ear%2Fbirt.war%2Freport%2Flinked_report.rptdesign&__format=html&customerName=Blauer+See+Auto%2C+Co.&__locale=en_US&__designer=false

linked report url in Windows is coming as
localhost:9080/reporting/run?__report=report%2Flinked_report.rptdesign&__format=html&customerName=Blauer+See+Auto%2C+Co.&__locale=en_US&__designer=false






Re: Drill through feature issue in UNIX [message #827615 is a reply to message #827582] Fri, 23 March 2012 15:19 Go to previous messageGo to next message
Annette Rego is currently offline Annette Rego
Messages: 11
Registered: March 2012
Junior Member
I am using birt 3.7.1
Re: Drill through feature issue in UNIX [message #827759 is a reply to message #827615] Fri, 23 March 2012 19:03 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Do you have both reports in the same directory? If you deploy the
viewer just as a war, do you get the issue?

Jason


On 3/23/2012 11:19 AM, Annette Rego wrote:
> I am using birt 3.7.1
Re: Drill through feature issue in UNIX [message #827875 is a reply to message #827759] Fri, 23 March 2012 22:53 Go to previous messageGo to next message
Annette Rego is currently offline Annette Rego
Messages: 11
Registered: March 2012
Junior Member
Yes both the reports are in same directory. I tried with war file also its not working. It works perfectly in windows.
Re: Drill through feature issue in UNIX [message #830736 is a reply to message #827875] Wed, 28 March 2012 02:19 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Can you try changing this setting in the web.xml:
<context-param>
<param-name>WORKING_FOLDER_ACCESS_ONLY</param-name>
<param-value>true</param-value>
</context-param>

to false?

Jason

n 3/23/2012 6:53 PM, Annette Rego wrote:
> Yes both the reports are in same directory. I tried with war file also
> its not working. It works perfectly in windows.
Re: Drill through feature issue in UNIX [message #831389 is a reply to message #830736] Wed, 28 March 2012 21:05 Go to previous message
Annette Rego is currently offline Annette Rego
Messages: 11
Registered: March 2012
Junior Member
After Changing settings in the web.xml its working fine. Thank you very much Smile

[Updated on: Wed, 28 March 2012 21:06]

Report message to a moderator

Previous Topic:Birt Report Accessing XML Marklogic DataSource Deployed Viewer in Tomcat Application
Next Topic:Data set expressions and design element expressions
Goto Forum:
  


Current Time: Sat Oct 25 01:34:27 GMT 2014

Powered by FUDForum. Page generated in 0.01835 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software