Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » XML Schema Definition (XSD) » xerces version
xerces version [message #9288] Wed, 08 January 2003 10:09 Go to next message
Eclipse User
Originally posted by: Michael.Hartmeier.softwareag.com

I've seen a change from "plugins/org.apache.xerces_4_0_5 to 4_0_7 in
Eclipse 2.0.2. Does that mean you require "xerces_4_0_7" starting from
Build 20021127_0721VL?

What are the 'official' numbers for "xerces_4_0_5" and "4_0_7"?

Michael
Re: xerces version [message #9383 is a reply to message #9288] Mon, 20 January 2003 12:21 Go to previous messageGo to next message
Shane Curcuru is currently offline Shane Curcuru
Messages: 30
Registered: July 2009
Member
Excellent question! I thought the XSD plugin would still basically work
with the 4.0.5 version of Xerces from Eclipse, although I haven't tested it
lately.

I'm not sure what you mean by 'official' numbers though. As far as I can
tell, the version numbers reported in the Xerces plugin you get with
Eclipse builds does not correspond directly to any public Xerces builds
from Apache, nor with any specific XML4J builds from IBM. You'd need to
ask whoever's in charge of Eclipse's integration of Xerces to find out
exactly what actual Xerces code from Apache is in each build in Eclipse -
unfortunately I'm not sure who that is (although I imagine it's in the CVS
logs).

- Shane

On Wed, 8 Jan 2003 10:09:16 +0000 (UTC), Michael Hartmeier
<Michael.Hartmeier@softwareag.com> wrote:

> I've seen a change from "plugins/org.apache.xerces_4_0_5 to 4_0_7 in
> Eclipse 2.0.2. Does that mean you require "xerces_4_0_7" starting from
> Build 20021127_0721VL?
>
> What are the 'official' numbers for "xerces_4_0_5" and "4_0_7"?
>
> Michael
Re: xerces version [message #9451 is a reply to message #9383] Mon, 20 January 2003 15:15 Go to previous messageGo to next message
Eclipse User
Originally posted by: Michael.Hartmeier.softwareag.com

I just checked the about.html file of the xerces plugin: it mentions that
it's based on xerces 2.0.0. (2.0.0 is what I meant with 'offical version').

I'm using XSD (build 20021023_1900TL) stand-allone, i.e. I include your
XSD jar files, the required EMF jar files and xerces jar files.

Currently, I'm using xerces 2.1 (because I simply didn't know that the
xerces plugin uses such an old version). This seems to work fine for XSD,
the only problem I found so far is simple type validation: I get
method-not-found errors because xerces APIs have changed in this area.
That's ok for me, I can avoid calling these methods (even though it would
be nice to use them ...).

Do you recommend to step back to xerces 2.0? I'd like to avoid this
because this might trigger problems in other areas of my project. I'd even
prefer to switch to xerces 2.2.1 ... Are there any plans to use a more
recent xerces version for eclipse/eclipse xsd anytime soon? Probably not
because Eclipse 2.1M4 still uses the xerces 4.0.7 plugin ...

Michael

Shane Curcuru wrote:

> Excellent question! I thought the XSD plugin would still basically work
> with the 4.0.5 version of Xerces from Eclipse, although I haven't tested it
> lately.

> I'm not sure what you mean by 'official' numbers though. As far as I can
> tell, the version numbers reported in the Xerces plugin you get with
> Eclipse builds does not correspond directly to any public Xerces builds
> from Apache, nor with any specific XML4J builds from IBM. You'd need to
> ask whoever's in charge of Eclipse's integration of Xerces to find out
> exactly what actual Xerces code from Apache is in each build in Eclipse -
> unfortunately I'm not sure who that is (although I imagine it's in the CVS
> logs).

> - Shane

> On Wed, 8 Jan 2003 10:09:16 +0000 (UTC), Michael Hartmeier
> <Michael.Hartmeier@softwareag.com> wrote:

> > I've seen a change from "plugins/org.apache.xerces_4_0_5 to 4_0_7 in
> > Eclipse 2.0.2. Does that mean you require "xerces_4_0_7" starting from
> > Build 20021127_0721VL?
> >
> > What are the 'official' numbers for "xerces_4_0_5" and "4_0_7"?
> >
> > Michael
Re: xerces version [message #9547 is a reply to message #9451] Fri, 24 January 2003 11:51 Go to previous message
Eclipse User
Originally posted by: merks.ca.ibm.com

Michael,

I'm pretty much stuck with needing to track whatever version of Xerces is in
Eclipse and I'm not involved in the plans or decisions involving changes to that
version. If a newer version works adequately for you, that's a good thing, but
only the Eclipse Xerces version is tested and supported for XSD.


Michael Hartmeier wrote:

> I just checked the about.html file of the xerces plugin: it mentions that
> it's based on xerces 2.0.0. (2.0.0 is what I meant with 'offical version').
>
> I'm using XSD (build 20021023_1900TL) stand-allone, i.e. I include your
> XSD jar files, the required EMF jar files and xerces jar files.
>
> Currently, I'm using xerces 2.1 (because I simply didn't know that the
> xerces plugin uses such an old version). This seems to work fine for XSD,
> the only problem I found so far is simple type validation: I get
> method-not-found errors because xerces APIs have changed in this area.
> That's ok for me, I can avoid calling these methods (even though it would
> be nice to use them ...).
>
> Do you recommend to step back to xerces 2.0? I'd like to avoid this
> because this might trigger problems in other areas of my project. I'd even
> prefer to switch to xerces 2.2.1 ... Are there any plans to use a more
> recent xerces version for eclipse/eclipse xsd anytime soon? Probably not
> because Eclipse 2.1M4 still uses the xerces 4.0.7 plugin ...
>
> Michael
>
> Shane Curcuru wrote:
>
> > Excellent question! I thought the XSD plugin would still basically work
> > with the 4.0.5 version of Xerces from Eclipse, although I haven't tested it
> > lately.
>
> > I'm not sure what you mean by 'official' numbers though. As far as I can
> > tell, the version numbers reported in the Xerces plugin you get with
> > Eclipse builds does not correspond directly to any public Xerces builds
> > from Apache, nor with any specific XML4J builds from IBM. You'd need to
> > ask whoever's in charge of Eclipse's integration of Xerces to find out
> > exactly what actual Xerces code from Apache is in each build in Eclipse -
> > unfortunately I'm not sure who that is (although I imagine it's in the CVS
> > logs).
>
> > - Shane
>
> > On Wed, 8 Jan 2003 10:09:16 +0000 (UTC), Michael Hartmeier
> > <Michael.Hartmeier@softwareag.com> wrote:
>
> > > I've seen a change from "plugins/org.apache.xerces_4_0_5 to 4_0_7 in
> > > Eclipse 2.0.2. Does that mean you require "xerces_4_0_7" starting from
> > > Build 20021127_0721VL?
> > >
> > > What are the 'official' numbers for "xerces_4_0_5" and "4_0_7"?
> > >
> > > Michael

--
Ed Merks
Re: xerces version [message #564605 is a reply to message #9288] Mon, 20 January 2003 12:21 Go to previous message
Shane Curcuru is currently offline Shane Curcuru
Messages: 30
Registered: July 2009
Member
Excellent question! I thought the XSD plugin would still basically work
with the 4.0.5 version of Xerces from Eclipse, although I haven't tested it
lately.

I'm not sure what you mean by 'official' numbers though. As far as I can
tell, the version numbers reported in the Xerces plugin you get with
Eclipse builds does not correspond directly to any public Xerces builds
from Apache, nor with any specific XML4J builds from IBM. You'd need to
ask whoever's in charge of Eclipse's integration of Xerces to find out
exactly what actual Xerces code from Apache is in each build in Eclipse -
unfortunately I'm not sure who that is (although I imagine it's in the CVS
logs).

- Shane

On Wed, 8 Jan 2003 10:09:16 +0000 (UTC), Michael Hartmeier
<Michael.Hartmeier@softwareag.com> wrote:

> I've seen a change from "plugins/org.apache.xerces_4_0_5 to 4_0_7 in
> Eclipse 2.0.2. Does that mean you require "xerces_4_0_7" starting from
> Build 20021127_0721VL?
>
> What are the 'official' numbers for "xerces_4_0_5" and "4_0_7"?
>
> Michael
Re: xerces version [message #564681 is a reply to message #9383] Mon, 20 January 2003 15:15 Go to previous message
Michael Hartmeier is currently offline Michael Hartmeier
Messages: 21
Registered: July 2009
Junior Member
I just checked the about.html file of the xerces plugin: it mentions that
it's based on xerces 2.0.0. (2.0.0 is what I meant with 'offical version').

I'm using XSD (build 20021023_1900TL) stand-allone, i.e. I include your
XSD jar files, the required EMF jar files and xerces jar files.

Currently, I'm using xerces 2.1 (because I simply didn't know that the
xerces plugin uses such an old version). This seems to work fine for XSD,
the only problem I found so far is simple type validation: I get
method-not-found errors because xerces APIs have changed in this area.
That's ok for me, I can avoid calling these methods (even though it would
be nice to use them ...).

Do you recommend to step back to xerces 2.0? I'd like to avoid this
because this might trigger problems in other areas of my project. I'd even
prefer to switch to xerces 2.2.1 ... Are there any plans to use a more
recent xerces version for eclipse/eclipse xsd anytime soon? Probably not
because Eclipse 2.1M4 still uses the xerces 4.0.7 plugin ...

Michael

Shane Curcuru wrote:

> Excellent question! I thought the XSD plugin would still basically work
> with the 4.0.5 version of Xerces from Eclipse, although I haven't tested it
> lately.

> I'm not sure what you mean by 'official' numbers though. As far as I can
> tell, the version numbers reported in the Xerces plugin you get with
> Eclipse builds does not correspond directly to any public Xerces builds
> from Apache, nor with any specific XML4J builds from IBM. You'd need to
> ask whoever's in charge of Eclipse's integration of Xerces to find out
> exactly what actual Xerces code from Apache is in each build in Eclipse -
> unfortunately I'm not sure who that is (although I imagine it's in the CVS
> logs).

> - Shane

> On Wed, 8 Jan 2003 10:09:16 +0000 (UTC), Michael Hartmeier
> <Michael.Hartmeier@softwareag.com> wrote:

> > I've seen a change from "plugins/org.apache.xerces_4_0_5 to 4_0_7 in
> > Eclipse 2.0.2. Does that mean you require "xerces_4_0_7" starting from
> > Build 20021127_0721VL?
> >
> > What are the 'official' numbers for "xerces_4_0_5" and "4_0_7"?
> >
> > Michael
Re: xerces version [message #564793 is a reply to message #9451] Fri, 24 January 2003 11:51 Go to previous message
Ed Merks is currently offline Ed Merks
Messages: 26048
Registered: July 2009
Senior Member
Michael,

I'm pretty much stuck with needing to track whatever version of Xerces is in
Eclipse and I'm not involved in the plans or decisions involving changes to that
version. If a newer version works adequately for you, that's a good thing, but
only the Eclipse Xerces version is tested and supported for XSD.


Michael Hartmeier wrote:

> I just checked the about.html file of the xerces plugin: it mentions that
> it's based on xerces 2.0.0. (2.0.0 is what I meant with 'offical version').
>
> I'm using XSD (build 20021023_1900TL) stand-allone, i.e. I include your
> XSD jar files, the required EMF jar files and xerces jar files.
>
> Currently, I'm using xerces 2.1 (because I simply didn't know that the
> xerces plugin uses such an old version). This seems to work fine for XSD,
> the only problem I found so far is simple type validation: I get
> method-not-found errors because xerces APIs have changed in this area.
> That's ok for me, I can avoid calling these methods (even though it would
> be nice to use them ...).
>
> Do you recommend to step back to xerces 2.0? I'd like to avoid this
> because this might trigger problems in other areas of my project. I'd even
> prefer to switch to xerces 2.2.1 ... Are there any plans to use a more
> recent xerces version for eclipse/eclipse xsd anytime soon? Probably not
> because Eclipse 2.1M4 still uses the xerces 4.0.7 plugin ...
>
> Michael
>
> Shane Curcuru wrote:
>
> > Excellent question! I thought the XSD plugin would still basically work
> > with the 4.0.5 version of Xerces from Eclipse, although I haven't tested it
> > lately.
>
> > I'm not sure what you mean by 'official' numbers though. As far as I can
> > tell, the version numbers reported in the Xerces plugin you get with
> > Eclipse builds does not correspond directly to any public Xerces builds
> > from Apache, nor with any specific XML4J builds from IBM. You'd need to
> > ask whoever's in charge of Eclipse's integration of Xerces to find out
> > exactly what actual Xerces code from Apache is in each build in Eclipse -
> > unfortunately I'm not sure who that is (although I imagine it's in the CVS
> > logs).
>
> > - Shane
>
> > On Wed, 8 Jan 2003 10:09:16 +0000 (UTC), Michael Hartmeier
> > <Michael.Hartmeier@softwareag.com> wrote:
>
> > > I've seen a change from "plugins/org.apache.xerces_4_0_5 to 4_0_7 in
> > > Eclipse 2.0.2. Does that mean you require "xerces_4_0_7" starting from
> > > Build 20021127_0721VL?
> > >
> > > What are the 'official' numbers for "xerces_4_0_5" and "4_0_7"?
> > >
> > > Michael

--
Ed Merks
Previous Topic:Problem Including schemas
Next Topic:XSDPrototypicalSchema and classpath
Goto Forum:
  


Current Time: Wed Sep 17 19:52:42 GMT 2014

Powered by FUDForum. Page generated in 0.04706 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software