Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit » EGit on linux does not show "Team-->commit" option
EGit on linux does not show "Team-->commit" option [message #825641] Wed, 21 March 2012 00:17 Go to next message
ted y is currently offline ted y
Messages: 9
Registered: March 2012
Junior Member
I installed the latest Egit plugin from egit download page for the "main p2 " release
for my eclipse 3.6
"Version: Helios Service Release 2
Build id: 20110218-0911
"

after I created a project, and shared it, the files in the project do not show any "+" signs in front of them; nor does the "Team" right-click menu show options for "commit", "merge" etc.


in fact it only shows options for "Apply Patch" , "show local history"


what am I doing wrong?

Thanks
Yang
Re: EGit on linux does not show "Team-->commit" option [message #825665 is a reply to message #825641] Wed, 21 March 2012 01:08 Go to previous messageGo to next message
Kevin Sawicki is currently offline Kevin Sawicki
Messages: 47
Registered: September 2011
Member
How did you share it?

Do you have a repository for it listed in the Git Repositories view?

If you see the repository for the project in the Git Repositories view you may want to try removing the project from the workspace and then running the Import Project... action from the Git Repositories view context menu and using the wizard to reimport the project. They then should have the proper Team menu with all the options and the decorations.
Re: EGit on linux does not show "Team-->commit" option [message #826226 is a reply to message #825665] Wed, 21 March 2012 16:37 Go to previous messageGo to next message
ted y is currently offline ted y
Messages: 9
Registered: March 2012
Junior Member
Thanks.

I shared the project using right click menu---> "Team"---> "share project", then choose the git option.
please see attached Git1.png --- Git4.png

I do see this project in the repositories view

I also tried deleting the project and re-importing it from git, but it seems to be the same.
(see Git5.png)


  • Attachment: Git1.png
    (Size: 117.81KB, Downloaded 178 times)
  • Attachment: Git2.png
    (Size: 120.41KB, Downloaded 131 times)
  • Attachment: Git3.png
    (Size: 106.49KB, Downloaded 126 times)
  • Attachment: Git4.png
    (Size: 111.12KB, Downloaded 120 times)
  • Attachment: Git5.png
    (Size: 129.83KB, Downloaded 127 times)
Re: EGit on linux does not show "Team-->commit" option [message #826347 is a reply to message #826226] Wed, 21 March 2012 20:43 Go to previous messageGo to next message
Kevin Sawicki is currently offline Kevin Sawicki
Messages: 47
Registered: September 2011
Member
What version of EGit are you using?
Re: EGit on linux does not show "Team-->commit" option [message #826491 is a reply to message #826347] Thu, 22 March 2012 02:04 Go to previous messageGo to next message
ted y is currently offline ted y
Messages: 9
Registered: March 2012
Junior Member
the latest from the download site 1.3.0.201202151440-r

I tried it with both eclipse Helios and Indigo
Re: EGit on linux does not show "Team-->commit" option [message #826987 is a reply to message #826491] Thu, 22 March 2012 14:56 Go to previous messageGo to next message
Kevin Sawicki is currently offline Kevin Sawicki
Messages: 47
Registered: September 2011
Member
So you re-imported by selecting the repository from the Git Repositories view and running the Import Project... context menu action?
Re: EGit on linux does not show "Team-->commit" option [message #827802 is a reply to message #826491] Fri, 23 March 2012 16:20 Go to previous messageGo to next message
Philippe is currently offline Philippe
Messages: 100
Registered: July 2009
Senior Member
This release seems to have small problem on Linux !

I have problems (see my previous message) in the Project Navigator / Package
Explorer where the new files and the modified files always appear 'Tracked'.

Regards
--
Philippe Bastiani
Re: EGit on linux does not show "Team-->commit" option [message #828672 is a reply to message #826987] Sun, 25 March 2012 01:39 Go to previous messageGo to next message
ted y is currently offline ted y
Messages: 9
Registered: March 2012
Junior Member
Thanks.

now I see what you mean. I just followed your steps and it works!

previously I imported it through "File"-->"Import" -->"from git repository" ---> as general project , and that doesn't work



Re: EGit on linux does not show "Team-->commit" option [message #828678 is a reply to message #826987] Sun, 25 March 2012 01:39 Go to previous messageGo to next message
ted y is currently offline ted y
Messages: 9
Registered: March 2012
Junior Member
Thanks.

now I see what you mean. I just followed your steps and it works!

previously I imported it through "File"-->"Import" -->"from git repository" ---> as general project , and that doesn't work
Re: EGit on linux does not show "Team-->commit" option [message #828681 is a reply to message #826987] Sun, 25 March 2012 01:39 Go to previous messageGo to next message
ted y is currently offline ted y
Messages: 9
Registered: March 2012
Junior Member
Thanks.

now I see what you mean. I just followed your steps and it works!

previously I imported it through "File"-->"Import" -->"from git repository" ---> as general project , and that doesn't work
Re: EGit on linux does not show "Team-->commit" option [message #828687 is a reply to message #826987] Sun, 25 March 2012 01:39 Go to previous messageGo to next message
ted y is currently offline ted y
Messages: 9
Registered: March 2012
Junior Member
Thanks.

now I see what you mean. I just followed your steps and it works!

previously I imported it through "File"-->"Import" -->"from git repository" ---> as general project , and that doesn't work
Re: EGit on linux does not show "Team-->commit" option [message #847229 is a reply to message #826987] Tue, 17 April 2012 01:41 Go to previous messageGo to next message
Jermaine Rattray is currently offline Jermaine Rattray
Messages: 1
Registered: April 2012
Junior Member
I can confirm I was experiencing the same issue, and your suggestion fixed it.

IDE:
Eclipse Java EE IDE for Web Developers.
Version: Indigo Service Release 2
Build id: 20120216-1857

EGit: 1.3.0.2012151440-r

OS: Windows 7 Ultimate (64-Bit)
Re: EGit on linux does not show "Team-->commit" option [message #853623 is a reply to message #847229] Mon, 23 April 2012 03:21 Go to previous messageGo to next message
Ivan V is currently offline Ivan V
Messages: 22
Registered: March 2010
Junior Member
I can confirm the same behaviour on OS X 10.7.3, Indigo SR 2 and EGit 1.3.0.2012151440-r. Kevin Sawicki's post solved it. Thanks.

Where does the other Git representation come from? It's quite confusing.
Re: EGit on linux does not show "Team-->commit" option [message #869947 is a reply to message #826226] Fri, 04 May 2012 22:26 Go to previous message
Rahul Banerjee is currently offline Rahul Banerjee
Messages: 1
Registered: May 2012
Junior Member
Thank you, ted!

I had this problem (egit not tracking modified files via the ">" symbol) after re-importing the project.

Your instructions solved it. Thanks!
Previous Topic:Key shortcut to 'Show Annotations'
Next Topic:Commit view opened from stash entry lacks diff tab
Goto Forum:
  


Current Time: Thu Apr 17 23:51:07 EDT 2014

Powered by FUDForum. Page generated in 0.03321 seconds