Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » Unresolved imports in OSGi servlet
Unresolved imports in OSGi servlet [message #101592] Mon, 19 November 2007 14:48 Go to next message
Eclipse User
Originally posted by: user.domain.invalid

Hello all,

I have a servlet that runs under equinox using the
org.eclipse.equinox.http.registry extension point. The basic servlet
runs fine but when I introduced some code that depends on EMF I get the
following error:

19-Nov-2007 13:49:44 org.mortbay.jetty.servlet.ServletHandler handle
WARNING: Error for /servlet
java.lang.Error: Unresolved compilation problems:
The import org.eclipse.emf cannot be resolved

I'm pretty sure EMF is included as a bundle in the OSGI runtime as
confirmed by the following, but as you can see the EMF bundle is not
exporting the org.eclipse.emf.* subpackages that I'm referencing:

osgi> ss -s active
Framework is launched.

604 ACTIVE org.eclipse.emf_2.3.0.v200709252135
1034 ACTIVE org.eclipse.emf.ecore_2.3.1.v200709252135
1214 ACTIVE cwi.reo.container_1.0.0

osgi> bundle org.eclipse.emf
initial@reference :file:../myplugins/eclipse/plugins/org.eclipse.emf_2.3.0.v20 0709252135.jar/
[604]
Id=604, Status=ACTIVE Data
Root=/ufs/maraikar/workspace/.metadata/.plugins/org.eclipse. pde.core/OSGi
Framework/org.eclipse.osgi/bundles/604/data
No registered services.
No services in use.
No exported packages
No imported packages
No fragment bundles
Named class space
org.eclipse.emf; bundle-version="2.3.0.v200709252135"[provided]
No required bundles

Any ideas on what I'm doing wrong? Here's my OSGi MANIFEST:

Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Reo Container Plug-in
Bundle-SymbolicName: cwi.reo.container;singleton:=true
Bundle-Version: 1.0.0
Bundle-Activator: cwi.reo.container.Activator
Import-Package: javax.servlet;version="2.4.0",
javax.servlet.http;version="2.4.0",
javax.servlet.jsp;version="2.0.0",
org.osgi.framework;version="1.3.0"
Eclipse-LazyStart: true
Export-Package: cwi.reo.container
Require-Bundle: org.eclipse.emf,
org.eclipse.core.runtime,
org.eclipse.gmf.runtime.notation,
org.eclipse.emf.ecore.xmi,
org.eclipse.equinox.http.registry,
org.eclipse.equinox.jsp.jasper,
org.eclipse.equinox.jsp.jasper.registry,
cwi.ea,
cwi.ea.casimulator,
cwi.ea.extensions.constraints,
cwi.ea.extensions.portNames
Bundle-ClassPath: .,
lib/commons-fileupload-1.2.jar,
lib/commons-io-1.3.2.jar


Thanx.
Ziyan
Re: Unresolved imports in OSGi servlet [message #103709 is a reply to message #101592] Fri, 11 January 2008 19:43 Go to previous message
Thomas Watson is currently offline Thomas Watson
Messages: 427
Registered: July 2009
Senior Member
user@domain.invalid wrote:
> Hello all,
>
> I have a servlet that runs under equinox using the
> org.eclipse.equinox.http.registry extension point. The basic servlet
> runs fine but when I introduced some code that depends on EMF I get the
> following error:
>
> 19-Nov-2007 13:49:44 org.mortbay.jetty.servlet.ServletHandler handle
> WARNING: Error for /servlet
> java.lang.Error: Unresolved compilation problems:
> The import org.eclipse.emf cannot be resolved
>
>

This indicates that the class file did not even compile correctly in
your workspace. Did you try putting a direct requirement on the
org.eclipse.emf bundle?

Tom.
Previous Topic:issues using <mail> ant task for pde build and test automation
Next Topic:Classloader Issue
Goto Forum:
  


Current Time: Tue Sep 16 17:34:30 GMT 2014

Powered by FUDForum. Page generated in 0.03365 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software