Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » Getting Browser to work in Arch Linux(SWTError: No more handles [Unknown Mozilla path])
Getting Browser to work in Arch Linux [message #822246] Fri, 16 March 2012 11:02 Go to next message
lim jiewmeng is currently offline lim jiewmengFriend
Messages: 2
Registered: March 2012
Junior Member
On my Arch Linux, Eclipse 3.7 with Google Window Builder/SWT application, I am getting

Exception in thread "main" org.eclipse.swt.SWTError: No more handles [Unknown Mozilla path (MOZILLA_FIVE_HOME not set)]
    at org.eclipse.swt.SWT.error(SWT.java:4308)
    at org.eclipse.swt.browser.Mozilla.initMozilla(Mozilla.java:1826)
    at org.eclipse.swt.browser.Mozilla.create(Mozilla.java:687)
    at org.eclipse.swt.browser.Browser.<init>(Browser.java:99)
    at octopus.EventSummaryComposite.<init>(EventSummaryComposite.java:33)
    at octopus.EventEditingComposite.<init>(EventEditingComposite.java:45)
    at octopus.EventManagementController.<init>(EventManagementController.java:31)
    at octopus.MainController.<init>(MainController.java:38)
    at octopus.MainController.main(MainController.java:85)


I believe I need to install XULrunner or something. But when I install xulrunner in Arch, I get xulrunner and eclipse are in conflict. So I tried installing pywebkitgtk & libwebkit3 (I think the later is whats required?).

Then I added

-Dorg.eclipse.swt.browser.DefaultType=webkit 
-Dorg.eclipse.swt.browser.UseWebKitGTK=true


in /usr/share/eclipse/eclipse.ini. But when I run, I still get the same error. It appears webkit is still not used. How can I fix this?

Stackoverflow Question: stackoverflow.com/questions/9695271/swt-browser-eclipse/9695581#comment12373986_9695581
Re: Getting Browser to work in Arch Linux [message #824032 is a reply to message #822246] Mon, 19 March 2012 07:00 Go to previous message
Lakshmi ShanmugamFriend
Messages: 274
Registered: July 2009
Location: India
Senior Member
Hi,

Is the Browser created with style SWT.NONE or SWT.MOZILLA?
If its SWT.NONE, it will try to use Webkit first. See faq --> http://eclipse.org/swt/faq.php#browserwebkitgtk

If its SWT.MOZILLA, it'll use XULRunner. Supported version of XULRunner for eclipse 3.7 is upto 1.9.2. See faq for supported versions --> http://eclipse.org/swt/faq.php#browserlinux


Lakshmi P Shanmugam
Previous Topic:Launch standalone app outside of eclipse
Next Topic:How to get native NSView reference from SWT Composite
Goto Forum:
  


Current Time: Fri Dec 19 09:35:57 GMT 2014

Powered by FUDForum. Page generated in 0.01603 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software