Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » TPTP AGR runs from Linux with remote AC@Win32 but Freeze when collecting results
TPTP AGR runs from Linux with remote AC@Win32 but Freeze when collecting results [message #100538] Thu, 07 June 2007 10:15 Go to next message
Shaohua WEN is currently offline Shaohua WENFriend
Messages: 5
Registered: July 2009
Junior Member
Dear all,
We are trying to use TPTP (4.3.1) AGR (eclipse 3.2.2),jdk 1.6.0.1 (jdk
1.4.2 also tried) to record some UI functional test cases from windows and
linux, then we need to run the test cases from linux server ,we are using
the Agent Controller installed both in linux and windows system to replay
the tests from linux (locally) and windows system (remotly) for System
tests.
The problem is:
The application (eclipse work bench) cases successfully replayed in
the target system (win32),but in the linux system which we start the
remote test, the progress bar in eclipse freezes at "collection result"
phase, (about 93% in progress bar).
We also tried to run the same test from windows (client) + AC@linux and
it works, from linux (client) + AC@linux) works, from windows (client) +
AC @windows also works. only Linux (client) + AC@windows does not work at
"collecting result" phase.

I modified the log level to DEBUG in Agent Controller at windows and
found that there are some strange messages:

<CommonBaseEvent creationTime="2007-06-07T08:51:45.567000Z"
globalInstanceId="A3921D0470634E8D878774D4018E2E1A" msg="ACTL
stopDataFlush agent
Executor$org.eclipse.hyades.execution.harness.XMLExecutionDa taProcessor
invalid dataConnection 5003 " severity="50" version="1.0.1">
<sourceComponentId component="AgentController"
componentIdType="TPTPComponent"
executionEnvironment=" D:\cygwin\home\build\TPTP\4.3.1\TPTP-4.3.1-200702221346\agnt ctrl\src\transport\TPTPAgentCompTL\Connect2AC.c,
line 1064" instanceId="1005" location="ID8505096.nee.nokia.com"
locationType="IPV4" processId="3588" subComponent="Agent Compatibility TL"
threadId="2708" componentType="Eclipse_TPTP"/>
<situation categoryName="ReportSituation">
<situationType xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:type="ReportSituation" reasoningScope="INTERNAL" reportCategory="LOG"/>
</situation>
</CommonBaseEvent>

I don't know if this information is helpful for diagnose,but any help or
suggestion will be appreciated.

Thanks in advance!
Holy
Re: TPTP AGR runs from Linux with remote AC@Win32 but Freeze when collecting results [message #100652 is a reply to message #100538] Fri, 08 June 2007 14:41 Go to previous messageGo to next message
Liz Dancy is currently offline Liz DancyFriend
Messages: 77
Registered: July 2009
Member
Hi Holy,


There are some portability issues with test cases from Windows to Linux
however this sounds more like a problem with the execution harness and /or
agent.
I will need some additional information to get to the root cause of this
problem. Are you receiving an execution history from the Linux runs which
contains errors or failures or is the progress bar freeze forcing you to
stop the test execution prematurely with no execution result? If you have an
execution history please attach it as well as the error log for the test
run.

You may also wish to try these tests with the latest TPTP 4.4 candidate
driver to see if there is any difference.

Sincerely,

Liz Dancy

"Holy Wen" <Shaohua.wen@gmail.com> wrote in message
news:34f937227ce579c36234c60809d9d9cd$1@www.eclipse.org...
> Dear all,
> We are trying to use TPTP (4.3.1) AGR (eclipse 3.2.2),jdk 1.6.0.1 (jdk
> 1.4.2 also tried) to record some UI functional test cases from windows and
> linux, then we need to run the test cases from linux server ,we are using
> the Agent Controller installed both in linux and windows system to replay
> the tests from linux (locally) and windows system (remotly) for System
> tests.
> The problem is:
> The application (eclipse work bench) cases successfully replayed in the
> target system (win32),but in the linux system which we start the remote
> test, the progress bar in eclipse freezes at "collection result" phase,
> (about 93% in progress bar).
> We also tried to run the same test from windows (client) + AC@linux and
> it works, from linux (client) + AC@linux) works, from windows (client) +
> AC @windows also works. only Linux (client) + AC@windows does not work at
> "collecting result" phase.
> I modified the log level to DEBUG in Agent Controller at windows and
> found that there are some strange messages:
>
> <CommonBaseEvent creationTime="2007-06-07T08:51:45.567000Z"
> globalInstanceId="A3921D0470634E8D878774D4018E2E1A" msg="ACTL
> stopDataFlush agent
> Executor$org.eclipse.hyades.execution.harness.XMLExecutionDa taProcessor
> invalid dataConnection 5003 " severity="50" version="1.0.1">
> <sourceComponentId component="AgentController"
> componentIdType="TPTPComponent"
> executionEnvironment=" D:\cygwin\home\build\TPTP\4.3.1\TPTP-4.3.1-200702221346\agnt ctrl\src\transport\TPTPAgentCompTL\Connect2AC.c,
> line 1064" instanceId="1005" location="ID8505096.nee.nokia.com"
> locationType="IPV4" processId="3588" subComponent="Agent Compatibility TL"
> threadId="2708" componentType="Eclipse_TPTP"/>
> <situation categoryName="ReportSituation">
> <situationType xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> xsi:type="ReportSituation" reasoningScope="INTERNAL"
> reportCategory="LOG"/>
> </situation>
> </CommonBaseEvent>
> I don't know if this information is helpful for diagnose,but any help or
> suggestion will be appreciated.
>
> Thanks in advance!
> Holy
>
>
>
Re: TPTP AGR runs from Linux with remote AC@Win32 but Freeze when collecting res [message #100690 is a reply to message #100652] Mon, 11 June 2007 01:39 Go to previous messageGo to next message
Shaohua WEN is currently offline Shaohua WENFriend
Messages: 5
Registered: July 2009
Junior Member
Hi Dancy!
From the linux server that start the tests,there is no error log or
error message until I stop the test by press the red "cancelling
operation" button and exit eclipse,and the message is:

org.eclipse.hyades.execution.invocation.RemoteInvoc ationException
at
org.eclipse.hyades.execution.local.SessionImpl.invokeRemote( SessionIm
pl.java:107)
at
org.eclipse.hyades.execution.local.RemoteObjectStub.delegate RemoteCal
l(RemoteObjectStub.java:87)
at
org.eclipse.hyades.execution.local.ExecutorStub.kill(Executo rStub.jav a:92)
at
org.eclipse.hyades.execution.local.ExecutorStub.kill(Executo rStub.jav
a:104)
at
org.eclipse.hyades.execution.harness.TestExecutionHarness.st opTest(Te
stExecutionHarness.java:2575)
at
org.eclipse.hyades.execution.harness.TestExecutionHarness.st opTest(Te
stExecutionHarness.java:2595)
at
org.eclipse.hyades.test.core.internal.launch.processes.TestE xecutionP
rocess.terminate(TestExecutionProcess.java:138)
at org.eclipse.debug.core.Launch.terminate(Launch.java:229)
at
org.eclipse.debug.internal.core.LaunchManager.shutdown(Launc hManager.
java:1961)
at org.eclipse.debug.core.DebugPlugin.stop(DebugPlugin.java:560 )
at
org.eclipse.osgi.framework.internal.core.BundleContextImpl$3 .run(Bund
leContextImpl.java:1032)
at java.security.AccessController.doPrivileged(Native Method)
at
org.eclipse.osgi.framework.internal.core.BundleContextImpl.s top(Bundl
eContextImpl.java:1028)
at
org.eclipse.osgi.framework.internal.core.BundleHost.stopWork er(Bundle
Host.java:396)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.stop (Abstract
Bundle.java:400)
at
org.eclipse.core.runtime.internal.adaptor.BundleStopper.basi cStopBund
les(BundleStopper.java:86)
at
org.eclipse.core.runtime.internal.adaptor.BundleStopper.stop Bundles(B
undleStopper.java:73)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAdaptorHook .framewor
kStopping(EclipseAdaptorHook.java:156)
at
org.eclipse.osgi.baseadaptor.BaseAdaptor.frameworkStopping(B aseAdapto
r.java:288)
at
org.eclipse.osgi.framework.internal.core.Framework.shutdown( Framework
java:538)
at
org.eclipse.osgi.framework.internal.core.Framework.close(Fra mework.ja
va:449)
at
org.eclipse.osgi.framework.internal.core.OSGi.close(OSGi.jav a:41)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.shutdown(Ecl ipseStart
er.java:423)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.ja
va:193)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.
java:39)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAcces
sorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.core.launcher.Main.invokeFramework(Main.java:336 )
at org.eclipse.core.launcher.Main.basicRun(Main.java:280)
at org.eclipse.core.launcher.Main.run(Main.java:977)
at org.eclipse.core.launcher.Main.main(Main.java:952)
Caused by:
org.eclipse.hyades.internal.execution.local.control.Inactive AgentExce ption
at
org.eclipse.hyades.internal.execution.local.control.AgentImp l.invokeC
ustomCommand(AgentImpl.java:480)
at
org.eclipse.hyades.execution.local.SessionImpl.invokeRemote( SessionIm
pl.java:104)
... 31 more


The progress bar freeze forcing me to stop the test execution
prematurely with no execution result ,I've tried to wait about 15 minutes
,but still no result collected,and the 10002 connection is still
"ESTABLISHED" when check with netstat -na|grep 10002.

I will try to use TPTP 4.4 candidate driver to check if there is any
difference,but we need to run it in eclipse 3.2.x because our development
is based on it.

Thanks&Best Regards,
Holy


Liz Dancy wrote:

> Hi Holy,


> There are some portability issues with test cases from Windows to Linux
> however this sounds more like a problem with the execution harness and /or
> agent.
> I will need some additional information to get to the root cause of this
> problem. Are you receiving an execution history from the Linux runs which
> contains errors or failures or is the progress bar freeze forcing you to
> stop the test execution prematurely with no execution result? If you have an
> execution history please attach it as well as the error log for the test
> run.

> You may also wish to try these tests with the latest TPTP 4.4 candidate
> driver to see if there is any difference.

> Sincerely,

> Liz Dancy

> "Holy Wen" <Shaohua.wen@gmail.com> wrote in message
> news:34f937227ce579c36234c60809d9d9cd$1@www.eclipse.org...
>> Dear all,
>> We are trying to use TPTP (4.3.1) AGR (eclipse 3.2.2),jdk 1.6.0.1 (jdk
>> 1.4.2 also tried) to record some UI functional test cases from windows and
>> linux, then we need to run the test cases from linux server ,we are using
>> the Agent Controller installed both in linux and windows system to replay
>> the tests from linux (locally) and windows system (remotly) for System
>> tests.
>> The problem is:
>> The application (eclipse work bench) cases successfully replayed in the
>> target system (win32),but in the linux system which we start the remote
>> test, the progress bar in eclipse freezes at "collection result" phase,
>> (about 93% in progress bar).
>> We also tried to run the same test from windows (client) + AC@linux and
>> it works, from linux (client) + AC@linux) works, from windows (client) +
>> AC @windows also works. only Linux (client) + AC@windows does not work at
>> "collecting result" phase.
>> I modified the log level to DEBUG in Agent Controller at windows and
>> found that there are some strange messages:
>>
>> <CommonBaseEvent creationTime="2007-06-07T08:51:45.567000Z"
>> globalInstanceId="A3921D0470634E8D878774D4018E2E1A" msg="ACTL
>> stopDataFlush agent
>> Executor$org.eclipse.hyades.execution.harness.XMLExecutionDa taProcessor
>> invalid dataConnection 5003 " severity="50" version="1.0.1">
>> <sourceComponentId component="AgentController"
>> componentIdType="TPTPComponent"
>>
executionEnvironment=" D:cygwinhomebuildTPTP4.3.1TPTP-4.3.1-200702221346agntctrlsrc transportTPTPAgentCompTLConnect2AC.c,
>> line 1064" instanceId="1005" location="ID8505096.nee.nokia.com"
>> locationType="IPV4" processId="3588" subComponent="Agent Compatibility TL"
>> threadId="2708" componentType="Eclipse_TPTP"/>
>> <situation categoryName="ReportSituation">
>> <situationType xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>> xsi:type="ReportSituation" reasoningScope="INTERNAL"
>> reportCategory="LOG"/>
>> </situation>
>> </CommonBaseEvent>
>> I don't know if this information is helpful for diagnose,but any help or
>> suggestion will be appreciated.
>>
>> Thanks in advance!
>> Holy
>>
>>
>>
Re: TPTP AGR runs from Linux with remote AC@Win32 but Freeze when collecting res [message #100788 is a reply to message #100690] Mon, 11 June 2007 15:21 Go to previous messageGo to next message
Liz Dancy is currently offline Liz DancyFriend
Messages: 77
Registered: July 2009
Member
Hi Holy,

This sounds like an agent problem. Can you check that you do not have any
background java processes running which could be interfering?
Sincerely,

Liz Dancy
"Holy" <shaohua.wen@gmail.com> wrote in message
news:8c74321b45d6587370c1cf1682a66fc7$1@www.eclipse.org...
> Hi Dancy!
> From the linux server that start the tests,there is no error log or error
> message until I stop the test by press the red "cancelling operation"
> button and exit eclipse,and the message is:
>
> org.eclipse.hyades.execution.invocation.RemoteInvoc ationException
> at
> org.eclipse.hyades.execution.local.SessionImpl.invokeRemote( SessionIm
> pl.java:107)
> at
> org.eclipse.hyades.execution.local.RemoteObjectStub.delegate RemoteCal
> l(RemoteObjectStub.java:87)
> at
> org.eclipse.hyades.execution.local.ExecutorStub.kill(Executo rStub.jav
> a:92)
> at
> org.eclipse.hyades.execution.local.ExecutorStub.kill(Executo rStub.jav
> a:104)
> at
> org.eclipse.hyades.execution.harness.TestExecutionHarness.st opTest(Te
> stExecutionHarness.java:2575)
> at
> org.eclipse.hyades.execution.harness.TestExecutionHarness.st opTest(Te
> stExecutionHarness.java:2595)
> at
> org.eclipse.hyades.test.core.internal.launch.processes.TestE xecutionP
> rocess.terminate(TestExecutionProcess.java:138)
> at org.eclipse.debug.core.Launch.terminate(Launch.java:229)
> at
> org.eclipse.debug.internal.core.LaunchManager.shutdown(Launc hManager.
> java:1961)
> at org.eclipse.debug.core.DebugPlugin.stop(DebugPlugin.java:560 )
> at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl$3 .run(Bund
> leContextImpl.java:1032)
> at java.security.AccessController.doPrivileged(Native Method)
> at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.s top(Bundl
> eContextImpl.java:1028)
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.stopWork er(Bundle
> Host.java:396)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.stop (Abstract
> Bundle.java:400)
> at
> org.eclipse.core.runtime.internal.adaptor.BundleStopper.basi cStopBund
> les(BundleStopper.java:86)
> at
> org.eclipse.core.runtime.internal.adaptor.BundleStopper.stop Bundles(B
> undleStopper.java:73)
> at
> org.eclipse.core.runtime.internal.adaptor.EclipseAdaptorHook .framewor
> kStopping(EclipseAdaptorHook.java:156)
> at
> org.eclipse.osgi.baseadaptor.BaseAdaptor.frameworkStopping(B aseAdapto
> r.java:288)
> at
> org.eclipse.osgi.framework.internal.core.Framework.shutdown( Framework
> java:538)
> at
> org.eclipse.osgi.framework.internal.core.Framework.close(Fra mework.ja
> va:449)
> at
> org.eclipse.osgi.framework.internal.core.OSGi.close(OSGi.jav a:41)
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.shutdown(Ecl ipseStart
> er.java:423)
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.ja
> va:193)
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.
> java:39)
> at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAcces
> sorImpl.java:25)
> at java.lang.reflect.Method.invoke(Method.java:597)
> at org.eclipse.core.launcher.Main.invokeFramework(Main.java:336 )
> at org.eclipse.core.launcher.Main.basicRun(Main.java:280)
> at org.eclipse.core.launcher.Main.run(Main.java:977)
> at org.eclipse.core.launcher.Main.main(Main.java:952)
> Caused by:
> org.eclipse.hyades.internal.execution.local.control.Inactive AgentExce
> ption
> at
> org.eclipse.hyades.internal.execution.local.control.AgentImp l.invokeC
> ustomCommand(AgentImpl.java:480)
> at
> org.eclipse.hyades.execution.local.SessionImpl.invokeRemote( SessionIm
> pl.java:104)
> ... 31 more
>
>
> The progress bar freeze forcing me to stop the test execution
> prematurely with no execution result ,I've tried to wait about 15 minutes
> ,but still no result collected,and the 10002 connection is still
> "ESTABLISHED" when check with netstat -na|grep 10002.
>
> I will try to use TPTP 4.4 candidate driver to check if there is any
> difference,but we need to run it in eclipse 3.2.x because our development
> is based on it.
>
> Thanks&Best Regards,
> Holy
>
>
> Liz Dancy wrote:
>
>> Hi Holy,
>
>
>> There are some portability issues with test cases from Windows to Linux
>> however this sounds more like a problem with the execution harness and
>> /or agent.
>> I will need some additional information to get to the root cause of this
>> problem. Are you receiving an execution history from the Linux runs which
>> contains errors or failures or is the progress bar freeze forcing you to
>> stop the test execution prematurely with no execution result? If you have
>> an execution history please attach it as well as the error log for the
>> test run.
>
>> You may also wish to try these tests with the latest TPTP 4.4 candidate
>> driver to see if there is any difference.
>
>> Sincerely,
>
>> Liz Dancy
>
>> "Holy Wen" <Shaohua.wen@gmail.com> wrote in message
>> news:34f937227ce579c36234c60809d9d9cd$1@www.eclipse.org...
>>> Dear all,
>>> We are trying to use TPTP (4.3.1) AGR (eclipse 3.2.2),jdk 1.6.0.1 (jdk
>>> 1.4.2 also tried) to record some UI functional test cases from windows
>>> and linux, then we need to run the test cases from linux server ,we are
>>> using the Agent Controller installed both in linux and windows system to
>>> replay the tests from linux (locally) and windows system (remotly) for
>>> System tests.
>>> The problem is:
>>> The application (eclipse work bench) cases successfully replayed in
>>> the target system (win32),but in the linux system which we start the
>>> remote test, the progress bar in eclipse freezes at "collection result"
>>> phase, (about 93% in progress bar).
>>> We also tried to run the same test from windows (client) + AC@linux
>>> and it works, from linux (client) + AC@linux) works, from windows
>>> (client) + AC @windows also works. only Linux (client) + AC@windows does
>>> not work at "collecting result" phase.
>>> I modified the log level to DEBUG in Agent Controller at windows and
>>> found that there are some strange messages:
>>>
>>> <CommonBaseEvent creationTime="2007-06-07T08:51:45.567000Z"
>>> globalInstanceId="A3921D0470634E8D878774D4018E2E1A" msg="ACTL
>>> stopDataFlush agent
>>> Executor$org.eclipse.hyades.execution.harness.XMLExecutionDa taProcessor
>>> invalid dataConnection 5003 " severity="50" version="1.0.1">
>>> <sourceComponentId component="AgentController"
>>> componentIdType="TPTPComponent"
> executionEnvironment=" D:cygwinhomebuildTPTP4.3.1TPTP-4.3.1-200702221346agntctrlsrc transportTPTPAgentCompTLConnect2AC.c,
>>> line 1064" instanceId="1005" location="ID8505096.nee.nokia.com"
>>> locationType="IPV4" processId="3588" subComponent="Agent Compatibility
>>> TL" threadId="2708" componentType="Eclipse_TPTP"/>
>>> <situation categoryName="ReportSituation">
>>> <situationType xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>>> xsi:type="ReportSituation" reasoningScope="INTERNAL"
>>> reportCategory="LOG"/>
>>> </situation>
>>> </CommonBaseEvent>
>>> I don't know if this information is helpful for diagnose,but any help
>>> or suggestion will be appreciated.
>>>
>>> Thanks in advance!
>>> Holy
>>>
>>>
>>>
>
>
Re: TPTP AGR runs from Linux with remote AC@Win32 but Freeze when collecting res [message #101274 is a reply to message #100788] Wed, 20 June 2007 05:48 Go to previous messageGo to next message
Shaohua WEN is currently offline Shaohua WENFriend
Messages: 5
Registered: July 2009
Junior Member
Hi Dancy,
I tried with tptp4.4 Candidate (
tptp.runtime.allInOne.win32.win32.x86-TPTP-4.4.0-20070614010 0.zip
tptp.runtime.allInOne.linux.gtk.x86-TPTP-4.4.0-200706140100. zip and
org.eclipse.tptp.test.auto-TPTP-4.4.0-200706140100.zip
agntctrl.win_ia32-TPTP-4.4.0-200705080100D.zip) and it freeze at the same
point (93% when collecting result).
Eachtime I restarted my Agent Controller and stopped any other java
applications.

Best Regards,
Holy

Liz Dancy wrote:

> Hi Holy,

> This sounds like an agent problem. Can you check that you do not have any
> background java processes running which could be interfering?
> Sincerely,

> Liz Dancy
Re: TPTP AGR runs from Linux with remote AC@Win32 but Freeze when collecting res [message #101912 is a reply to message #101274] Wed, 27 June 2007 18:13 Go to previous messageGo to next message
Liz Dancy is currently offline Liz DancyFriend
Messages: 77
Registered: July 2009
Member
Hi Holy,

Which flavour of Linux are you running? Is this correct from your
description that you can launch the tests from a Linux machine remotely to
a Windows machine but the opposite is failing?


Sincerely,

Liz Dancy
"Holy" <shaohua.wen@gmail.com> wrote in message
news:5958f29e401f275560d4168e25483477$1@www.eclipse.org...
> Hi Dancy,
> I tried with tptp4.4 Candidate (
> tptp.runtime.allInOne.win32.win32.x86-TPTP-4.4.0-20070614010 0.zip
> tptp.runtime.allInOne.linux.gtk.x86-TPTP-4.4.0-200706140100. zip and
> org.eclipse.tptp.test.auto-TPTP-4.4.0-200706140100.zip
> agntctrl.win_ia32-TPTP-4.4.0-200705080100D.zip) and it freeze at the same
> point (93% when collecting result).
> Eachtime I restarted my Agent Controller and stopped any other java
> applications.
>
> Best Regards,
> Holy
>
> Liz Dancy wrote:
>
>> Hi Holy,
>
>> This sounds like an agent problem. Can you check that you do not have any
>> background java processes running which could be interfering?
>> Sincerely,
>
>> Liz Dancy
>
Re: TPTP AGR runs from Linux with remote AC@Win32 but Freeze when collecting res [message #103056 is a reply to message #101912] Thu, 05 July 2007 01:58 Go to previous messageGo to next message
Shaohua WEN is currently offline Shaohua WENFriend
Messages: 5
Registered: July 2009
Junior Member
Hi Liz,
We are running RedHat Enterprise Linux V4.
We are able to launch the test from a linux machine remotely to a
windows machine,but the test will fail at collecting result phase.
On the opposite,we can launch the test from a windows machine remotely
to a linux machine, and it will success.

Thanks for your time&Best Regards,
Holy

Liz Dancy wrote:

> Hi Holy,

> Which flavour of Linux are you running? Is this correct from your
> description that you can launch the tests from a Linux machine remotely to
> a Windows machine but the opposite is failing?


> Sincerely,

> Liz Dancy
Re: TPTP AGR runs from Linux with remote AC@Win32 but Freeze when collecting res [message #106135 is a reply to message #103056] Mon, 23 July 2007 14:28 Go to previous messageGo to next message
Liz Dancy is currently offline Liz DancyFriend
Messages: 77
Registered: July 2009
Member
Hi Holy,

Can you check for any firewall settings or security programs that could be
blocking the connection on the Linux machine? One user reported that this
was the problem for them when experiencing the same error.

Furthermore, you can check if you have any connection at all to the remote
agent controller by selecting Windows > Preferences > Hosts > select (or
add) your Linux host and then click 'Test Connection'. You should see a
connection success.

You will also need to have the Linux AC set to allow 'All' or specifically
to allow your Windows host to connect to it. This can be changed by running
../SetConfig.sh and changing the values manually, then restarting the agent
controller.

Please also be advised that Java 1.6 is not supported.
http://www.eclipse.org/tptp/home/project_info/releaseinfo/4. 4/support.html

However, you mentioned you have tried also with 1.4.2, which is.

Let me know your findings and we can continue working through this if
necessary.

Sincerely,

Liz Dancy

"Holy" <shaohua.wen@gmail.com> wrote in message
news:d4c1c4257d24f1f33ba8eb475f6d09cd$1@www.eclipse.org...
> Hi Liz,
> We are running RedHat Enterprise Linux V4.
> We are able to launch the test from a linux machine remotely to a windows
> machine,but the test will fail at collecting result phase.
> On the opposite,we can launch the test from a windows machine remotely to
> a linux machine, and it will success.
>
> Thanks for your time&Best Regards,
> Holy
>
> Liz Dancy wrote:
>
>> Hi Holy,
>
>> Which flavour of Linux are you running? Is this correct from your
>> description that you can launch the tests from a Linux machine remotely
>> to a Windows machine but the opposite is failing?
>
>
>> Sincerely,
>
>> Liz Dancy
>
Re: TPTP AGR runs from Linux with remote AC@Win32 but Freeze when collecting res [message #106380 is a reply to message #106135] Wed, 25 July 2007 03:08 Go to previous messageGo to next message
Shaohua WEN is currently offline Shaohua WENFriend
Messages: 5
Registered: July 2009
Junior Member
Hi Liz,
I just tried "Test connection" and it returns connection sucess also.
Actually the AC is running on Windows ,So we can use AC to start the
system test on windows platform.
The AC on windows has been configured to allow connections from 'All'
hosts.

I think it should be easy to reproduct this if anyone can try to start a
auto gui test from linux and use the AC server on windows, the test case
should be recorded in windows. But currently we only have RHEL 4 now,
maybe we can install some other linux distributions to test this also. Or
if someone has the success story, a suggestion of the working linux
distribution will be appreciated.

Thanks&Best Regards,
Holy

Liz Dancy wrote:

> Hi Holy,

> Can you check for any firewall settings or security programs that could be
> blocking the connection on the Linux machine? One user reported that this
> was the problem for them when experiencing the same error.

> Furthermore, you can check if you have any connection at all to the remote
> agent controller by selecting Windows > Preferences > Hosts > select (or
> add) your Linux host and then click 'Test Connection'. You should see a
> connection success.

> You will also need to have the Linux AC set to allow 'All' or specifically
> to allow your Windows host to connect to it. This can be changed by running
> ../SetConfig.sh and changing the values manually, then restarting the agent
> controller.

> Please also be advised that Java 1.6 is not supported.
> http://www.eclipse.org/tptp/home/project_info/releaseinfo/4. 4/support.html

> However, you mentioned you have tried also with 1.4.2, which is.

> Let me know your findings and we can continue working through this if
> necessary.

> Sincerely,

> Liz Dancy
Re: TPTP AGR runs from Linux with remote AC@Win32 but Freeze when collecting res [message #106838 is a reply to message #106380] Fri, 27 July 2007 21:18 Go to previous message
Liz Dancy is currently offline Liz DancyFriend
Messages: 77
Registered: July 2009
Member
Hi Holy,

I am wondering if it could be a firewall problem on the Windows machine. Are
you able to successfully run from a second Windows machine to the Windows
machine giving the problem ?

If so, it sounds like a bug. Could you please open a defect so we can track
the problem in bugzilla?

Here is the link:
https://bugs.eclipse.org/bugs/

Sincerely,

Liz Dancy


"Holy" <shaohua.wen@gmail.com> wrote in message
news:b1ccfb4f6933080c07b2e4d8834984e2$1@www.eclipse.org...
> Hi Liz,
> I just tried "Test connection" and it returns connection sucess also.
> Actually the AC is running on Windows ,So we can use AC to start the
> system test on windows platform.
> The AC on windows has been configured to allow connections from 'All'
> hosts.
>
> I think it should be easy to reproduct this if anyone can try to start a
> auto gui test from linux and use the AC server on windows, the test case
> should be recorded in windows. But currently we only have RHEL 4 now,
> maybe we can install some other linux distributions to test this also. Or
> if someone has the success story, a suggestion of the working linux
> distribution will be appreciated.
>
> Thanks&Best Regards,
> Holy
>
> Liz Dancy wrote:
>
>> Hi Holy,
>
>> Can you check for any firewall settings or security programs that could
>> be blocking the connection on the Linux machine? One user reported that
>> this was the problem for them when experiencing the same error.
>
>> Furthermore, you can check if you have any connection at all to the
>> remote agent controller by selecting Windows > Preferences > Hosts >
>> select (or add) your Linux host and then click 'Test Connection'. You
>> should see a connection success.
>
>> You will also need to have the Linux AC set to allow 'All' or
>> specifically to allow your Windows host to connect to it. This can be
>> changed by running ../SetConfig.sh and changing the values manually, then
>> restarting the agent controller.
>
>> Please also be advised that Java 1.6 is not supported.
>> http://www.eclipse.org/tptp/home/project_info/releaseinfo/4. 4/support.html
>
>> However, you mentioned you have tried also with 1.4.2, which is.
>
>> Let me know your findings and we can continue working through this if
>> necessary.
>
>> Sincerely,
>
>> Liz Dancy
>
>
>
Previous Topic:TPTP profiler using SSH tunnel
Next Topic:profiler not working
Goto Forum:
  


Current Time: Fri Nov 28 06:17:21 GMT 2014

Powered by FUDForum. Page generated in 0.03816 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software