Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Default entry point does not exist(Default entry point does not exist)
Default entry point does not exist [message #820782] Wed, 14 March 2012 14:59 Go to next message
Brandon Szeliga is currently offline Brandon Szeliga
Messages: 1
Registered: March 2012
Junior Member
Another instance of the default entry point for a web app that doesn't exist. Hopefully someone can point something out to me that I'm missing. Below is a listing of some of the common requested information:

jetty 6.1.26

Using OSGI command line all bundles are in active state (Except org.eclipse.equinox.serveletbridget.extensionbundle which is in resolved).

plugin.xml below:
<?xml version="1.0" encoding="UTF-8"?>
<?eclipse version="3.4"?>
<plugin>
<extension
id="mm.entrypoint"
point="org.eclipse.rap.ui.entrypoint">
<entrypoint
class="mm.EntryPoint"
id="mmdemo1.entrypoint2"
parameter="default">
</entrypoint>
<entrypoint
class="mm.EntryPoint"
id="mmdemo1.entrypoint1"
parameter="mm">
</entrypoint>
</extension>

<extension
point="org.eclipse.rap.ui.branding">
<branding
id="mmdemo1.branding"
servletName="mm"
themeId="org.eclipse.rap.design.example.business.theme"
title="RAP Maintenance Manager">
<presentationFactory
defaultLayoutId="org.eclipse.rap.design.example.business.layout"
id="org.eclipse.rap.design.example.business.factory"
name="Business PresentationFactory">
<defaultStackPresentation
id="org.eclipse.rap.design.example.stack.view">
</defaultStackPresentation>
</presentationFactory>
</branding>
</extension>

</plugin>

URL in use (after deploy to mm.war):
localhost:8080/mm/mm
localhost:8080/mm/mm?startup=default
localhost:8080/mm/mm?startup=mm

Thanks in advance.
Re: Default entry point does not exist [message #845880 is a reply to message #820782] Sun, 15 April 2012 14:03 Go to previous message
Wim Jongman is currently offline Wim Jongman
Messages: 418
Registered: July 2009
Senior Member
Hi,

Please ask the jetty group.

rEGARDS,

WIM


> Another instance of the default entry point for a web app that doesn't
exist. Hopefully someone can point something out to me that I'm missing.
Below is a listing of some of the common requested information:
>
> jetty 6.1.26
>
> Using OSGI command line all bundles are in active state (Except
org.eclipse.equinox.serveletbridget.extensionbundle which is in resolved).
>
> plugin.xml below:
> <?xml version="1.0" encoding="UTF-8"?>
> <?eclipse version="3.4"?>
> <plugin>
> <extension
> id="mm.entrypoint"
> point="org.eclipse.rap.ui.entrypoint">
> <entrypoint
> class="mm.EntryPoint"
> id="mmdemo1.entrypoint2"
> parameter="default">
> </entrypoint>
> <entrypoint
> class="mm.EntryPoint"
> id="mmdemo1.entrypoint1"
> parameter="mm">
> </entrypoint>
> </extension>
>
> <extension
> point="org.eclipse.rap.ui.branding">
> <branding
> id="mmdemo1.branding"
> servletName="mm"
> themeId="org.eclipse.rap.design.example.business.theme"
> title="RAP Maintenance Manager">
> <presentationFactory
> defaultLayoutId="org.eclipse.rap.design.example.business.layout"
> id="org.eclipse.rap.design.example.business.factory"
> name="Business PresentationFactory">
> <defaultStackPresentation
> id="org.eclipse.rap.design.example.stack.view">
> </defaultStackPresentation>
> </presentationFactory>
> </branding>
> </extension>
>
> </plugin>
>
> URL in use (after deploy to mm.war):
> localhost:8080/mm/mm
> localhost:8080/mm/mm?startup=default
> localhost:8080/mm/mm?startup=mm
>
> Thanks in advance.
Previous Topic:View with ISaveablePart
Next Topic:A detached view with an action to launch a new view
Goto Forum:
  


Current Time: Thu Oct 23 22:10:46 GMT 2014

Powered by FUDForum. Page generated in 0.05642 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software