Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Fresh PDT install won't allow editing PHP files(Everything else works as intended, but an IDE that won't permit editing?)
Fresh PDT install won't allow editing PHP files [message #820154] Tue, 13 March 2012 19:58 Go to next message
Web Maka is currently offline Web Maka
Messages: 2
Registered: March 2012
Junior Member
I've used Eclipse PDT on a number of occasions but this is a new one to me...

The environment: Fresh Windows 7 Ultimate x64 SP1 install on a fresh computer (read: built the box this past weekend). Fresh Zend Server CE 5.6 install, with Apache 2.2, PHP 5.3, and MySQL 5.5. Fresh Eclipse PDT install. ("About" gives version as "Build id: 20100617-1415", and install details gives "Eclipse IDE for PHP Developers - 1.3.0.20100617-0520")

Zend works fine. Viewing webpages works fine. MySQL works fine, as my phpMyAdmin efforts attest. Eclipse PDT works fine. Debugging in Eclipse PDT works fine. But, It refuses to accept text entry into an editor tab when I open a PHP file for editing.

I've checked file permissions in all relevant locations and all is well - I have full permissions to the files I'm wanting to edit, and can edit them without incident in ConTEXT (with my edits showing when I reopen the file in the editor in Eclipse) - but can't do anything but look in Eclipse, and thus far I've not found any settings anywhere in Eclipse that explains why it's treating everything as read-only.

I've got to be missing something dumb slash obvious. Any suggestions on where to look?
Re: Fresh PDT install won't allow editing PHP files [message #824497 is a reply to message #820154] Mon, 19 March 2012 18:42 Go to previous message
Web Maka is currently offline Web Maka
Messages: 2
Registered: March 2012
Junior Member
Yep, I missed something dumb slash obvious and now it's working properly. (Had a directory to some source code in as a library path instead of a source path.)
Previous Topic:Code Assist not working for PHP language functions
Next Topic:xdebug on apache 2.2 with PHP 5.3
Goto Forum:
  


Current Time: Sat Oct 25 02:56:59 GMT 2014

Powered by FUDForum. Page generated in 0.01648 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software