Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit » Show In History shows "No Input"
Show In History shows "No Input" [message #819436] Mon, 12 March 2012 23:04 Go to next message
Louis Hilden is currently offline Louis Hilden
Messages: 4
Registered: March 2012
Junior Member
I've imported a GIT project using File-->Import-->Git-->Projects from Git. I'm in the Java EE perspective, I select a resource, right click, select Team-->Show In History. The "History" output tab displays "No Input".


But if I switch to Git Repository Exploring perspective, and select the resource from the Git Repositories tab, right click, select Show In-->History, I can see the History for the resource.


How do I get Team-->Show in History to work in the Java EE perspective?

I'm running Eclipse Indigo Service Release 1, EGit plugin 1.3.0.201202151440-r
Re: Show In History shows "No Input" [message #819443 is a reply to message #819436] Mon, 12 March 2012 23:20 Go to previous messageGo to next message
Kevin Sawicki is currently offline Kevin Sawicki
Messages: 47
Registered: September 2011
Member
What view are you launching the Show In History action from in the Java EE perspective?
Re: Show In History shows "No Input" [message #819446 is a reply to message #819443] Mon, 12 March 2012 23:24 Go to previous messageGo to next message
Louis Hilden is currently offline Louis Hilden
Messages: 4
Registered: March 2012
Junior Member
It happens in Project Explorer, Navigator and Package Explorer views.
Re: Show In History shows "No Input" [message #819452 is a reply to message #819446] Mon, 12 March 2012 23:36 Go to previous messageGo to next message
Kevin Sawicki is currently offline Kevin Sawicki
Messages: 47
Registered: September 2011
Member
And you are running Team > Show In History and not Show In > History from the project explorer view?
Re: Show In History shows "No Input" [message #819594 is a reply to message #819452] Tue, 13 March 2012 04:52 Go to previous messageGo to next message
Louis Hilden is currently offline Louis Hilden
Messages: 4
Registered: March 2012
Junior Member
Team-->Show In History. In the Project Explorer view in my version of Eclipse, "Show In" only has "Properties".
Re: Show In History shows "No Input" [message #819653 is a reply to message #819594] Tue, 13 March 2012 06:55 Go to previous messageGo to next message
Matthias Sohn is currently offline Matthias Sohn
Messages: 580
Registered: July 2009
Senior Member
I guess EGit lacks some adapter code to hook itself to some types used in those views instead of IResource.
Re: Show In History shows "No Input" [message #819990 is a reply to message #819653] Tue, 13 March 2012 15:36 Go to previous messageGo to next message
Kevin Sawicki is currently offline Kevin Sawicki
Messages: 47
Registered: September 2011
Member
I think this may be a bug where projects were not properly associated with repositories when using the File > Import > Git > Projects from Git wizard.

Can you remove the projects from the workspace and re-import them from the "Import Project..." menu option from a repository selection in the Git Repositories view.

https://bugs.eclipse.org/bugs/show_bug.cgi?id=372789
Re: Show In History shows "No Input" [message #820164 is a reply to message #819990] Tue, 13 March 2012 20:13 Go to previous messageGo to next message
Louis Hilden is currently offline Louis Hilden
Messages: 4
Registered: March 2012
Junior Member
Unfortunately that didn't work. I still get "No Input" in the History window when I select Team-->Show In History via Navigator, Project Explorer and Package Explorer.
Re: Show In History shows "No Input" [message #820204 is a reply to message #820164] Tue, 13 March 2012 21:18 Go to previous message
Kevin Sawicki is currently offline Kevin Sawicki
Messages: 47
Registered: September 2011
Member
Does it fail for all resources? Files, folders, and projects?
Previous Topic:Setting up Synchronisation with Remote Repository
Next Topic:Cloning remote repository fails
Goto Forum:
  


Current Time: Wed Oct 01 18:27:18 GMT 2014

Powered by FUDForum. Page generated in 0.03041 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software