Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » [tooling] Important Note re: Server Runtime Versions
[tooling] Important Note re: Server Runtime Versions [message #817369] Sat, 10 March 2012 01:22 Go to next message
Miles Parker is currently offline Miles Parker
Messages: 1340
Registered: July 2009
Senior Member
We have replaced the existing multiple Server Runtimes for Virgo Releases with a single unified release. This means that if you have created a 3.5 Server Runtime (that wouldn't have worked anyway), you need to delete it and create a new Virgo Runtime. Please see:

http://wiki.eclipse.org/Virgo/Tooling#Server_Versions

On the subject of Virgo Server versions, we should now have full support for 3.5 *and* the Kernel in tooling, with Jetty soon to come.

cheers,

Miles
Re: [tooling] Important Note re: Server Runtime Versions [message #820036 is a reply to message #817369] Tue, 13 March 2012 16:43 Go to previous messageGo to next message
Chris Frost is currently offline Chris Frost
Messages: 230
Registered: January 2010
Location: Southampton, England
Senior Member

Hi,

I tried out the latest snapshot (1.0.0.201203100237-SNAPSHOT), it's all looking really good. I know you have already mentioned a composite repository elsewhere but it would be good.

I pointed the tooling at 4 Virgo servers, 3.0.2.RELEASE Kernel and Tomcat and also 3.5.0.M02 Kernel and Tomcat, all working great, started, deployed a simple WAB or Bundle and stopped. I spotted few minor points though while playing with it all.

The PAR manifest editor didn't seem to work when trying to edit the one from our Greenpages sample, the editor just showed a message in big green letters saying it couldn't load the PAR manifest editor.

When I clicked on 'About Eclipse' from the drop down menus the Virgo IDE tooling still has a SpringSource Logo, would be better with the EclipseRT logo (http://wiki.eclipse.org/EclipseRT_Logos). The burb about the Virgo IDE also talks about STS still.

I tried playing with the Bundle Dependancy Graph on some of the servers, it deployed the "org.eclipse.virgo.ide.management.remote" bundle but I couldn't get it to show me anything, I searched for a few packages I know about. Is this expected to be working at the moment?

As for getting Jetty going, I'm looking at https://bugs.eclipse.org/bugs/show_bug.cgi?id=369238 later this week which may provide some help, add yourself to the Bugzilla if your interested.

Great Stuff,
Chris.


------------------------------------------------
Chris Frost, Twitter @cgfrost
Springsource, a divison of VMware.
Re: [tooling] Important Note re: Server Runtime Versions [message #820056 is a reply to message #820036] Tue, 13 March 2012 17:10 Go to previous messageGo to next message
Miles Parker is currently offline Miles Parker
Messages: 1340
Registered: July 2009
Senior Member
Chris Frost wrote on Tue, 13 March 2012 12:43

I pointed the tooling at 4 Virgo servers, 3.0.2.RELEASE Kernel and Tomcat and also 3.5.0.M02 Kernel and Tomcat, all working great, started, deployed a simple WAB or Bundle and stopped.


Good to hear!

Quote:
The PAR manifest editor didn't seem to work when trying to edit the one from our Greenpages sample, the editor just showed a message in big green letters saying it couldn't load the PAR manifest editor.


I know that there are many outstanding bugs in the manifest and PAR stuff. That's been down on the list. Please raise a bug if you don't see that one in there.

Quote:
When I clicked on 'About Eclipse' from the drop down menus the Virgo IDE tooling still has a SpringSource Logo, would be better with the EclipseRT logo (http://wiki.eclipse.org/EclipseRT_Logos). The burb about the Virgo IDE also talks about STS still.


Thanks for noticing that. We've done text searches but I'm not surprised that stuff has fallen through the cracks. I've opened 374110: Update product branding
https://bugs.eclipse.org/bugs/show_bug.cgi?id=374110

Quote:
I tried playing with the Bundle Dependancy Graph on some of the servers, it deployed the "org.eclipse.virgo.ide.management.remote" bundle but I couldn't get it to show me anything, I searched for a few packages I know about. Is this expected to be working at the moment?


No, and we should probably just remove the page altogether. It looks like that has moved over to Libra, though Leo and I should coordinate with them on that.

I'll be following the Jetty bug as well. Smile

Thanks!

-Miles
Re: [tooling] Important Note re: Server Runtime Versions [message #820059 is a reply to message #820056] Tue, 13 March 2012 17:16 Go to previous messageGo to next message
Chris Frost is currently offline Chris Frost
Messages: 230
Registered: January 2010
Location: Southampton, England
Senior Member

Hi,

Thanks for the quick response. All sounds fine to me. It is occurring to me that we may end in the situation where we (non-tooling folk) don't know what features have gone over to Libra and which have stayed and might just think some have gone away when they have actually just moved. I think it would be good to get some docs about what features we have and what has gone over to Libra, even if it's just a quick brain dump from you guys that we can write up later in a user guide some where.

Chris.


------------------------------------------------
Chris Frost, Twitter @cgfrost
Springsource, a divison of VMware.
Re: [tooling] Important Note re: Server Runtime Versions [message #820061 is a reply to message #820059] Tue, 13 March 2012 17:18 Go to previous messageGo to next message
Miles Parker is currently offline Miles Parker
Messages: 1340
Registered: July 2009
Senior Member
Yeah, I'm not sure that any of us are totally clear on this but we're starting to coordinate. I think they are relatively discrete. The other major pieces have to do with the bundlor mechanism, and we need to determine who "owns" some of that.
Re: [tooling] Important Note re: Server Runtime Versions [message #820064 is a reply to message #820056] Tue, 13 March 2012 17:21 Go to previous messageGo to next message
Leo Dos Santos is currently offline Leo Dos Santos
Messages: 26
Registered: July 2009
Junior Member
Looks like the Bundle Dependency Graph hasn't been working for some time: 350914: Bundle dependency graph displays a blank screen
https: //bugs.eclipse.org/bugs/show_bug.cgi?id=350914

That editor page has moved to Libra though, so we'll need to coordinate on a fix.

[Updated on: Tue, 13 March 2012 17:22]

Report message to a moderator

Re: [tooling] Important Note re: Server Runtime Versions [message #825425 is a reply to message #820064] Tue, 20 March 2012 20:45 Go to previous message
Miles Parker is currently offline Miles Parker
Messages: 1340
Registered: July 2009
Senior Member
OK, we have Jetty support "working" in the forthcoming snapshot build. I put that in quotes because I'm not sure that we've actually got it configured exactly correctly. So it would be extremely helpful if Jetty users could try it out and let us know if there are issues with it.
Previous Topic:Possible caching issue?
Next Topic:How to debug with Virgo
Goto Forum:
  


Current Time: Sat Oct 25 12:43:52 GMT 2014

Powered by FUDForum. Page generated in 0.02466 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software