Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » can you update the derby core plugin version?(Is it possible to update the derby core plugin version?)
icon5.gif  can you update the derby core plugin version? [message #814849] Wed, 07 March 2012 00:05 Go to next message
Aaron Titus is currently offline Aaron Titus
Messages: 10
Registered: March 2012
Junior Member
Hello Everyone,

I recently downloaded the all-in-one indigo eclipse BIRT project distribution. I noticed that within the BIRT Project, it automatically includes an older (10.5) version of the apache derby core plugin. I would like to use the latest version, which is 10.8. I noticed that if install the newer plugin versions, then both are present at the same time.

Which does it use? How can I safely eliminate the older 10.5 derby core plugin and use the new 10.8 plugin without breaking BIRT?

Thank you in Advance,
Aaron
Re: can you update the derby core plugin version? [message #815485 is a reply to message #814849] Wed, 07 March 2012 18:20 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Does it fail when you delete the 10.5 version? You may also want to
remove the sampledb plugin.
org.eclipse.birt.report.data.oda.sampledb_version

Jason

On 3/6/2012 7:05 PM, Aaron Titus wrote:
> Hello Everyone,
> I recently downloaded the all-in-one indigo eclipse BIRT project
> distribution. I noticed that within the BIRT Project, it automatically
> includes an older (10.5) version of the apache derby core plugin. I
> would like to use the latest version, which is 10.8. I noticed that if
> install the newer plugin versions, then both are present at the same time.
> Which does it use? How can I safely eliminate the older 10.5 derby core
> plugin and use the new 10.8 plugin without breaking BIRT?
> Thank you in Advance, Aaron
Re: can you update the derby core plugin version? [message #816994 is a reply to message #815485] Fri, 09 March 2012 13:55 Go to previous messageGo to next message
Aaron Titus is currently offline Aaron Titus
Messages: 10
Registered: March 2012
Junior Member
Jason Weathersby wrote on Wed, 07 March 2012 13:20
Does it fail when you delete the 10.5 version? You may also want to
remove the sampledb plugin.
org.eclipse.birt.report.data.oda.sampledb_version

Jason



Well, I was nervous to just remove it and see what happens, that is why I made the post here. Since the plugin name is different from the default derby one, I want to know if BIRT has some dependency on these and if I remove them, will BIRT stop functioning properly?
Re: can you update the derby core plugin version? [message #817230 is a reply to message #816994] Fri, 09 March 2012 20:26 Go to previous message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Currently the derby plugin is used only for the sample db. I see no
reason why the new one will not work.

Jason

On 3/9/2012 8:55 AM, Aaron Titus wrote:
> Jason Weathersby wrote on Wed, 07 March 2012 13:20
>> Does it fail when you delete the 10.5 version? You may also want to
>> remove the sampledb plugin.
>> org.eclipse.birt.report.data.oda.sampledb_version
>>
>> Jason
>
>
> Well, I was nervous to just remove it and see what happens, that is why
> I made the post here. Since the plugin name is different from the
> default derby one, I want to know if BIRT has some dependency on these
> and if I remove them, will BIRT stop functioning properly?
Previous Topic:Severe tomcat error messages when stop/undeploy viewer
Next Topic:pdf emitter gives an "Internet Explorer cannot display the webpage" with IE 8 and https
Goto Forum:
  


Current Time: Mon Oct 20 13:21:26 GMT 2014

Powered by FUDForum. Page generated in 0.02523 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software