Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Intellisense does not work for one class
Intellisense does not work for one class [message #812375] Sat, 03 March 2012 18:23 Go to next message
Hong Zhang is currently offline Hong Zhang
Messages: 6
Registered: March 2012
Junior Member
I am experiencing a very weird problem in using Eclipse for Android projects.
The intellisense works very except one class: android.view.View.
Let's say I have View = v. When I type the following:
v.

Eclipse lists all the members of class Object, not View.
If I have
v.setVisibility(View.GONE);

Everything works fine. Apparently Eclipse knows that View has method setVisibility, but its intellisense simply does not show it and numerous other methods.

I am wondering if anyone could offer some tips on how to track down the problem.

[Updated on: Mon, 05 March 2012 11:40]

Report message to a moderator

Re: Intellisense does not work for one class [message #813331 is a reply to message #812375] Mon, 05 March 2012 05:41 Go to previous messageGo to next message
Satyam Kandula is currently offline Satyam Kandula
Messages: 444
Registered: July 2009
Senior Member
I couldn't reproduce the problem. Can you see if there is any error in the file <Workspace>/.metadata/.log?
Re: Intellisense does not work for one class [message #813532 is a reply to message #813331] Mon, 05 March 2012 11:43 Go to previous messageGo to next message
Hong Zhang is currently offline Hong Zhang
Messages: 6
Registered: March 2012
Junior Member
Thank you, Satyam, for lending a hand here.

I could not find anything potentially related to this issue in the log. I cleared the log, and restarted Eclipse. Nothing has been logged since the restart.

View happens to be the most frequently used class, so this has become a major nuisance.
Re: Intellisense does not work for one class [message #813679 is a reply to message #813532] Mon, 05 March 2012 15:45 Go to previous messageGo to next message
Harutyun Arzumanian is currently offline Harutyun Arzumanian
Messages: 35
Registered: February 2012
Member
It's from the eclipse version, use the latest eclipse version as the bugs will be less..
Re: Intellisense does not work for one class [message #813725 is a reply to message #813679] Mon, 05 March 2012 16:40 Go to previous messageGo to next message
Hong Zhang is currently offline Hong Zhang
Messages: 6
Registered: March 2012
Junior Member
I am running Build id: 20120216-1857.

I have just done the following again: Help > Check for Updates, but no updates have been found.

I gather from the build path that the intellisense extracts the data from E:\Program Files\android-sdks\platforms\android-15\android.jar. I examined android.jar, and everything in it looks normal. Class View is there. The only difference this class has from others is its large size (10KB). Most other classes are smaller than 1KB.

I am running Windows 7 Ultimate 64-bit on a quad-core machine. The capacity of the machine should not be a problem.
Re: Intellisense does not work for one class [message #814468 is a reply to message #813725] Tue, 06 March 2012 13:43 Go to previous messageGo to next message
Harutyun Arzumanian is currently offline Harutyun Arzumanian
Messages: 35
Registered: February 2012
Member
I can advise you to perform the below steps:
1. Download a fresh android SDK and re-install it
2. Download the latest eclipse version (I think Indigo)
3. Do all the updates of your plugins as you did before

And check if the intellisense will work again.

[Updated on: Wed, 07 March 2012 07:26]

Report message to a moderator

Re: Intellisense does not work for one class [message #814752 is a reply to message #814468] Tue, 06 March 2012 21:09 Go to previous messageGo to next message
Hong Zhang is currently offline Hong Zhang
Messages: 6
Registered: March 2012
Junior Member
Android SDK was uninstalled and installed yesterday.

I downloaded Indigo a moment ago, and ran it with the project. The issue remains.

I have tried other jars such as E:\Program Files\android-sdks\platforms\android-8\android.jar, none has worked.

At this moment, I just hope a future version will somehow fix this.

[Updated on: Tue, 06 March 2012 21:10]

Report message to a moderator

Re: Intellisense does not work for one class [message #815063 is a reply to message #814752] Wed, 07 March 2012 07:23 Go to previous messageGo to next message
Harutyun Arzumanian is currently offline Harutyun Arzumanian
Messages: 35
Registered: February 2012
Member
Then definitely the problem is from Android.jar.
Re: Intellisense does not work for one class [message #835326 is a reply to message #815063] Tue, 03 April 2012 03:56 Go to previous message
Hong Zhang is currently offline Hong Zhang
Messages: 6
Registered: March 2012
Junior Member
Everything is fine now after a recent batch of updates of ADT and Android SDK. I am not sure exactly which update is responsible for the fix.
Previous Topic:app engine req.getParameter with type float
Next Topic:how to change xml dynamically in java
Goto Forum:
  


Current Time: Sat Sep 20 12:06:36 GMT 2014

Powered by FUDForum. Page generated in 0.01907 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software