Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » visual editor for eclipse IDE for Java Developers
visual editor for eclipse IDE for Java Developers [message #811618] Fri, 02 March 2012 10:56 Go to next message
Bernhard Fuchs is currently offline Bernhard Fuchs
Messages: 1
Registered: March 2012
Junior Member
I want to install visual editor via the marketplace and get following error message:

Cannot complete the install because of a conflicting dependency.
  Software being installed: Visual Editor 1.5.0.R20101202-1328 (org.eclipse.ve.feature.group 1.5.0.R20101202-1328)
  Software currently installed: Eclipse IDE for Java Developers 1.4.2.20120213-0813 (epp.package.java 1.4.2.20120213-0813)
  Only one of the following can be installed at once: 
    International Components for Unicode for Java (ICU4J) 4.4.2.v20110208 (com.ibm.icu 4.4.2.v20110208)
    International Components for Unicode for Java (ICU4J) 4.4.2.v20110823 (com.ibm.icu 4.4.2.v20110823)
    International Components for Unicode for Java (ICU4J) 4.2.1.v20100412 (com.ibm.icu 4.2.1.v20100412)
  Cannot satisfy dependency:
    From: Eclipse IDE for Java Developers 1.4.2.20120213-0813 (epp.package.java 1.4.2.20120213-0813)
    To: org.eclipse.epp.package.java.feature.feature.group [1.4.2.20120213-0813]
  Cannot satisfy dependency:
    From: EPP Java Package 1.4.2.20120213-0813 (org.eclipse.epp.package.java.feature.feature.group 1.4.2.20120213-0813)
    To: org.eclipse.platform.feature.group [3.7.2.v20120207-1839-9gF7UHPDFxGjd-PqDr2jX_4yKaumkoHTz04_q-q]
  Cannot satisfy dependency:
    From: Eclipse Platform 3.7.2.v20120207-1839-9gF7UHPDFxGjd-PqDr2jX_4yKaumkoHTz04_q-q (org.eclipse.platform.feature.group 3.7.2.v20120207-1839-9gF7UHPDFxGjd-PqDr2jX_4yKaumkoHTz04_q-q)
    To: org.eclipse.rcp.feature.group [3.7.2.v20120120-1424-9DB5FmnFq5JCf1UA38R-kz0S0272]
  Cannot satisfy dependency:
    From: Eclipse RCP 3.7.2.v20120120-1424-9DB5FmnFq5JCf1UA38R-kz0S0272 (org.eclipse.rcp.feature.group 3.7.2.v20120120-1424-9DB5FmnFq5JCf1UA38R-kz0S0272)
    To: com.ibm.icu [4.4.2.v20110823]
  Cannot satisfy dependency:
    From: Visual Editor 1.5.0.R20101202-1328 (org.eclipse.ve.feature.group 1.5.0.R20101202-1328)
    To: org.eclipse.ve.java.core [1.3.0,2.0.0)
  Cannot satisfy dependency:
    From: Visual Editor Java Core 1.5.0.R20101202-1328 (org.eclipse.ve.java.core 1.5.0.R20101202-1328)
    To: bundle com.ibm.icu [3.4.4.1,4.3.0)


Eclipse Version: Indigo Service Release 2
Build id: 20120216-1857

Someone out there who can help me?
Re: visual editor for eclipse IDE for Java Developers [message #814568 is a reply to message #811618] Tue, 06 March 2012 10:53 Go to previous message
Eric Rizzo is currently offline Eric Rizzo
Messages: 2207
Registered: July 2009
Senior Member
The Visual Editor project is old and pretty much dead as far as I know.
The state-of-the-art for "visual" GUI editors in Eclipse is
WindowBuilder, which is included in the most recent versions of the
Eclipse for Java Developers package. What version of Eclipse did you
download/install?

Eric


On 3/2/12 10:56 AM, Bernhard Fuchs wrote:
> I want to install visual editor via the marketplace and get following
> error message:
>
> Cannot complete the install because of a conflicting dependency.
> Software being installed: Visual Editor 1.5.0.R20101202-1328
> (org.eclipse.ve.feature.group 1.5.0.R20101202-1328)
> Software currently installed: Eclipse IDE for Java Developers
> 1.4.2.20120213-0813 (epp.package.java 1.4.2.20120213-0813)
> Only one of the following can be installed at once: International
> Components for Unicode for Java (ICU4J) 4.4.2.v20110208 (com.ibm.icu
> 4.4.2.v20110208)
> International Components for Unicode for Java (ICU4J) 4.4.2.v20110823
> (com.ibm.icu 4.4.2.v20110823)
> International Components for Unicode for Java (ICU4J) 4.2.1.v20100412
> (com.ibm.icu 4.2.1.v20100412)
> Cannot satisfy dependency:
> From: Eclipse IDE for Java Developers 1.4.2.20120213-0813
> (epp.package.java 1.4.2.20120213-0813)
> To: org.eclipse.epp.package.java.feature.feature.group
>
> Cannot satisfy dependency:
> From: EPP Java Package 1.4.2.20120213-0813
> (org.eclipse.epp.package.java.feature.feature.group 1.4.2.20120213-0813)
> To: org.eclipse.platform.feature.group
>
> Cannot satisfy dependency:
> From: Eclipse Platform
> 3.7.2.v20120207-1839-9gF7UHPDFxGjd-PqDr2jX_4yKaumkoHTz04_q-q
> (org.eclipse.platform.feature.group
> 3.7.2.v20120207-1839-9gF7UHPDFxGjd-PqDr2jX_4yKaumkoHTz04_q-q)
> To: org.eclipse.rcp.feature.group
>
> Cannot satisfy dependency:
> From: Eclipse RCP 3.7.2.v20120120-1424-9DB5FmnFq5JCf1UA38R-kz0S0272
> (org.eclipse.rcp.feature.group
> 3.7.2.v20120120-1424-9DB5FmnFq5JCf1UA38R-kz0S0272)
> To: com.ibm.icu [4.4.2.v20110823]
> Cannot satisfy dependency:
> From: Visual Editor 1.5.0.R20101202-1328 (org.eclipse.ve.feature.group
> 1.5.0.R20101202-1328)
> To: org.eclipse.ve.java.core [1.3.0,2.0.0)
> Cannot satisfy dependency:
> From: Visual Editor Java Core 1.5.0.R20101202-1328
> (org.eclipse.ve.java.core 1.5.0.R20101202-1328)
> To: bundle com.ibm.icu [3.4.4.1,4.3.0)
>
> Eclipse Version: Indigo Service Release 2
> Build id: 20120216-1857
>
> Someone out there who can help me?
Previous Topic:How to create a simple remote HTTP server for static publishing?
Next Topic:JUnit Test Case not listed as option to choose
Goto Forum:
  


Current Time: Thu Jul 31 15:57:57 EDT 2014

Powered by FUDForum. Page generated in 0.02162 seconds