Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Waiting for XDebug Session ...(XDebug doesn't launch and Debug perspective is empty)
Waiting for XDebug Session ... [message #811486] Fri, 02 March 2012 12:01 Go to next message
Ginger Opariti is currently offline Ginger OparitiFriend
Messages: 5
Registered: March 2012
Junior Member
Hi,
I certainly have a settings problem on my enabled XDebug V 2.0.5 - as referenced in phpinfo output. I'm using Eclipse Helios on Ubuntu 10.04, I have the Bug icon in the menu, the PHPDebug perspective available, but when I launch a PHP project in debugging mode I have no output in Eclipse, though the application is launched in the browser in the background. In the console window of Eclipse I just have the message "Waiting for the XDebug Session 57% ...".
What am I missing?
Thanks
Re: Waiting for XDebug Session ... [message #811564 is a reply to message #811486] Fri, 02 March 2012 14:23 Go to previous messageGo to next message
Ginger Opariti is currently offline Ginger OparitiFriend
Messages: 5
Registered: March 2012
Junior Member
Found it: edit /etc/php5/conf.d/xdebug.ini and add this after the "zend line":
xdebug.remote_enable=On
Re: Waiting for XDebug Session ... [message #839060 is a reply to message #811564] Sun, 08 April 2012 03:40 Go to previous message
atlas zhu is currently offline atlas zhuFriend
Messages: 1
Registered: April 2012
Junior Member
Great answer. The problem also confused me before.
Previous Topic:Infinite nesting of project folders
Next Topic:update problem at pdt 3.02
Goto Forum:
  


Current Time: Mon Nov 24 04:03:37 GMT 2014

Powered by FUDForum. Page generated in 0.01525 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software