Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » Class not found, export only problem
Class not found, export only problem [message #811452] Fri, 02 March 2012 06:06 Go to next message
Barbara Rosi-Schwartz is currently offline Barbara Rosi-Schwartz
Messages: 448
Registered: July 2009
Senior Member
I am generating a bundle from a third party jar using the Maven Bundle plugin. When I look at the contents of the jar, I can see that my class of interest is in the jar. The Manifest correctly exports the package to which the class belongs.

However, when I unleash my bundle in my Virgo kernel, a NoClassDefFoundException occurs on that class when I request it from another bundle, which correctly imports the package.

If I use the handy Virgo commands clhas, clload and clexport, I can see that the class is not found in any bundle and cannot loaded by any bundle; as for exporting, I am told that it is correctly exported and imported by the bundles I expect, but it tells me "class not found, export only" from the specific bundle that exports it.

Any idea as to what this might mean?

TIA,
B.
Re: Class not found, export only problem [message #811492 is a reply to message #811452] Fri, 02 March 2012 07:11 Go to previous message
Hristo Iliev is currently offline Hristo Iliev
Messages: 156
Registered: May 2010
Location: Sofia, Bulgaria
Senior Member

It may be the case that a class that is not available is used/imported and this breaks the class loading.

You may check which classes are imported by the class you tried to load and check their availability with the commands. In general any javax.* may be the reason for this if it is not present in the profile.
Previous Topic:How to disable necessaries log stoped in virgo tomcat server
Next Topic:virgo + springDM + custom Application Context Listener
Goto Forum:
  


Current Time: Wed Jul 23 06:10:48 EDT 2014

Powered by FUDForum. Page generated in 0.01609 seconds