Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit / JGit » Installation EGit(Missing requirement: EGit Mylyn UI)
Installation EGit [message #811187] Fri, 02 March 2012 02:44 Go to next message
Peter Balazovic is currently offline Peter BalazovicFriend
Messages: 6
Registered: December 2011
Junior Member
Cannot complete the install because one or more required items could not be found.
Software being installed: EGit Mylyn 1.3.0.201202151440-r (org.eclipse.egit.mylyn.feature.group 1.3.0.201202151440-r)
Missing requirement: EGit Mylyn UI 1.3.0.201202151440-r (org.eclipse.egit.mylyn.ui 1.3.0.201202151440-r) requires 'bundle

Any idea how to solve the issue?

Thank you!
Peter
Re: Installation EGit [message #811332 is a reply to message #811187] Fri, 02 March 2012 07:56 Go to previous messageGo to next message
Manuel Doninger is currently offline Manuel DoningerFriend
Messages: 119
Registered: October 2010
Senior Member
What is the complete error message?
After the line "Missing requirement: EGit Mylyn UI 1.3.0.201202151440-r (org.eclipse.egit.mylyn.ui 1.3.0.201202151440-r) requires 'bundle" there should be the missing packages.
Re: Installation EGit [message #811370 is a reply to message #811332] Fri, 02 March 2012 08:58 Go to previous messageGo to next message
Peter Balazovic is currently offline Peter BalazovicFriend
Messages: 6
Registered: December 2011
Junior Member
I am sorry Sad
This is a completed message I got:

Cannot complete the install because one or more required items could not be found.
Software being installed: EGit Mylyn 1.3.0.201202151440-r (org.eclipse.egit.mylyn.feature.group 1.3.0.201202151440-r)
Missing requirement: EGit Mylyn UI 1.3.0.201202151440-r (org.eclipse.egit.mylyn.ui 1.3.0.201202151440-r) requires 'bundle org.eclipse.mylyn.monitor.core [3.0.0,4.0.0)' but it could not be found
Cannot satisfy dependency:
From: EGit Mylyn 1.3.0.201202151440-r (org.eclipse.egit.mylyn.feature.group 1.3.0.201202151440-r)
To: org.eclipse.egit.mylyn.ui [1.3.0.201202151440-r]
Re: Installation EGit [message #811393 is a reply to message #811370] Fri, 02 March 2012 09:40 Go to previous messageGo to next message
Manuel Doninger is currently offline Manuel DoningerFriend
Messages: 119
Registered: October 2010
Senior Member
Is the checkbox "Contact all update sites during install to find required software" checked? That dependency should be in the indigo repository, maybe you can also try to add the Mylyn update site (http://download.eclipse.org/mylyn/releases/latest), and then try again to install.
Re: Installation EGit [message #811442 is a reply to message #811393] Fri, 02 March 2012 10:51 Go to previous messageGo to next message
Peter Balazovic is currently offline Peter BalazovicFriend
Messages: 6
Registered: December 2011
Junior Member
You're right! My mistake - I did not have marked the checkbox "Contact all update sites during install to find required software". Now it's installing!
Thank you very much! SOLVED

Best regards,
Peter
Re: Installation EGit [message #896261 is a reply to message #811187] Tue, 17 July 2012 19:00 Go to previous messageGo to next message
Don Hahn is currently offline Don HahnFriend
Messages: 1
Registered: July 2012
Junior Member
I had a problem with this, figured it out Smile And so now I don't know how to delete this post, sorry that I'm a newcomer here.

[Updated on: Tue, 17 July 2012 19:03]

Report message to a moderator

Re: Installation EGit [message #896287 is a reply to message #896261] Tue, 17 July 2012 21:14 Go to previous messageGo to next message
Robin Rosenberg is currently offline Robin RosenbergFriend
Messages: 332
Registered: July 2009
Senior Member
Don Hahn skrev 2012-07-17 21.00:
> I'm having pretty much this same exact problem, but the checkbox for
> "Contact all update sites during install to find required software" is
> checked by default. I'm trying to get EGit from
> http://download.eclipse.org/egit/updates. The entire message for me is
> Cannot complete the install because one or more required items could not
> be found.
> Software being installed: EGit Import Support 2.0.0.201206130900-r
> (org.eclipse.egit.import.feature.group 2.0.0.201206130900-r)
> Missing requirement: EGit Import 2.0.0.201206130900-r
> (org.eclipse.egit.import 2.0.0.201206130900-r) requires 'bundle
> org.eclipse.team.core 3.6.100' but it could not be found
> Cannot satisfy dependency:
> From: EGit Import Support 2.0.0.201206130900-r
> (org.eclipse.egit.import.feature.group 2.0.0.201206130900-r)
> To: org.eclipse.egit.import [2.0.0.201206130900-r]

That's not the same problem. Skip the "EGit Import Support" feature if
you are not on Eclipse 3.8 or 4.2.

-- robin
Re: Installation EGit [message #1779528 is a reply to message #811332] Tue, 09 January 2018 09:26 Go to previous messageGo to next message
Bhupendra singh is currently offline Bhupendra singhFriend
Messages: 1
Registered: January 2018
Junior Member
Hi,

I am also trying to install GIt and getting error "Cannot complete the install because one or more required items could not be found.
Software being installed: Git integration for Eclipse - Task focused interface 4.10.0.201712302008-r (org.eclipse.egit.mylyn.feature.group 4.10.0.201712302008-r)
Missing requirement: EGit Mylyn UI 4.10.0.201712302008-r (org.eclipse.egit.mylyn.ui 4.10.0.201712302008-r) requires 'bundle org.eclipse.mylyn.monitor.core [3.0.0,4.0.0)' but it could not be found
Cannot satisfy dependency:
From: Git integration for Eclipse - Task focused interface 4.10.0.201712302008-r (org.eclipse.egit.mylyn.feature.group 4.10.0.201712302008-r)
To: org.eclipse.egit.mylyn.ui [4.10.0.201712302008-r]
"

1) I have already marker check box for "Contact all update sites during install to find required software".

But still I am getting such error.Kindly Suggest

Regards
Bhupendra Singh
Re: Installation EGit [message #1780548 is a reply to message #1779528] Tue, 23 January 2018 20:24 Go to previous message
Matthias Sohn is currently offline Matthias SohnFriend
Messages: 1007
Registered: July 2009
Senior Member
You probably don't have Mylyn installed in your Eclipse installation. You should be able to install it from
your release's update site. If you are using the latest release Oxygen (Eclipse 4.7.x) you should be able
to install it from http://download.eclipse.org/releases/oxygen
Previous Topic:GIT HTTPS Internal CA "cannot open git-upload-pack"
Next Topic:Cancelling a JGit operation
Goto Forum:
  


Current Time: Tue Apr 24 01:24:44 GMT 2018

Powered by FUDForum. Page generated in 0.02717 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software