Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » second time, no offer to run(Eclipse not offering to compile my hello world)
second time, no offer to run [message #810648] Thu, 01 March 2012 11:22 Go to next message
Eric Barnhill is currently offline Eric BarnhillFriend
Messages: 5
Registered: March 2012
Junior Member
Greetings,

I am getting to know Eclipse today for Java. In my first opening of the program all went smoothly, I wrote a "hello world" and it worked both inside the IDE and on the command line.

My second time opening Eclipse I re-open the program but I only get an offer to run as an "Ant build" whatever that is. So I am writing my code in Eclipse, saving it, then having to go to the command line to run it. Why would this be?

Thanks,
Eric the Total Noob
Re: second time, no offer to run [message #810651 is a reply to message #810648] Thu, 01 March 2012 11:28 Go to previous messageGo to next message
Eric Barnhill is currently offline Eric BarnhillFriend
Messages: 5
Registered: March 2012
Junior Member
Update: now it is not offering me any options to run the code. It runs fine in the terminal window though.

[Updated on: Thu, 01 March 2012 11:29]

Report message to a moderator

Re: second time, no offer to run [message #810785 is a reply to message #810648] Thu, 01 March 2012 14:50 Go to previous messageGo to next message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3248
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 3/1/2012 4:22 AM, Eric Barnhill wrote:
> Greetings,
>
> I am getting to know Eclipse today for Java. In my first opening of the
> program all went smoothly, I wrote a "hello world" and it worked both
> inside the IDE and on the command line.
>
> My second time opening Eclipse I re-open the program but I only get an
> offer to run as an "Ant build" whatever that is. So I am writing my code
> in Eclipse, saving it, then having to go to the command line to run it.
> Why would this be?
>
> Thanks,
> Eric the Total Noob

Not seeing your workbench, but...

What happens when you right-click your "hello world" Java file? Do you
not see Run as Java application?
Re: second time, no offer to run [message #820000 is a reply to message #810785] Tue, 13 March 2012 15:52 Go to previous message
Eric Barnhill is currently offline Eric BarnhillFriend
Messages: 5
Registered: March 2012
Junior Member
Thank you for your response. I hope you don't mind me picking up this thread days later, but I had to turn to another project. When I right click in the outline window on the class, I get "Run As" but the only option is "Run Configurations". The "Run" button only offers me "Ant Build."

Thanks to anyone for their help getting started, I would really like to start using Eclipse.
Previous Topic:bundles not resolved
Next Topic:BIRT Runtime shared
Goto Forum:
  


Current Time: Fri Nov 28 21:59:00 GMT 2014

Powered by FUDForum. Page generated in 0.02364 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software