Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Service Component Architecture (SCA) Tools » How to instal SOA Tool
How to instal SOA Tool [message #8868] Sun, 07 June 2009 09:23 Go to next message
KevinWang is currently offline KevinWangFriend
Messages: 6
Registered: July 2009
Junior Member
Hello all:
It was not successful when I install on Eclipse 3.5 Galileo RC1 and RC2.
I have been update site from --All Available Sites--'s SOA Development,
"Web,XML,and Java....." items then I have prepare Tuscany lib too.

But when it install finished, I wanna try to use Restaurant by SCA
Example, but only Restaurant.composite and Restaurant.composite_diagram
were error.

How do I solve it???
Re: How to instal SOA Tool [message #8911 is a reply to message #8868] Mon, 08 June 2009 09:35 Go to previous messageGo to next message
Stephane Drapeau is currently offline Stephane DrapeauFriend
Messages: 198
Registered: July 2009
Senior Member
Kevin,

Which error do you have? have a look in to the error log (Window>Show
view>Error log)
Which update site for SCA Tools are you using?

Stephane Drapeau
Obeo

KevinWang a écrit :
> Hello all:
> It was not successful when I install on Eclipse 3.5 Galileo RC1 and RC2.
> I have been update site from --All Available Sites--'s SOA Development,
> "Web,XML,and Java....." items then I have prepare Tuscany lib too.
>
> But when it install finished, I wanna try to use Restaurant by SCA
> Example, but only Restaurant.composite and Restaurant.composite_diagram
> were error.
>
> How do I solve it???
>
Re: How to instal SOA Tool [message #8930 is a reply to message #8911] Mon, 08 June 2009 15:15 Go to previous messageGo to next message
Stephane Drapeau is currently offline Stephane DrapeauFriend
Messages: 198
Registered: July 2009
Senior Member
Kevin,

Is this your error?: "The feature 'mixed' of '' with 2 element values
must have exactly 1 element value."
This error will be fixed in the next version of SCA Tools (next wednesday).
Currently, you can ignore it. The composite file can be deployed with
Tuscany.

Regards,

Stephane Drapeau
Obeo

Stephane Drapeau a écrit :
> Kevin,
>
> Which error do you have? have a look in to the error log (Window>Show
> view>Error log)
> Which update site for SCA Tools are you using?
>
> Stephane Drapeau
> Obeo
>
> KevinWang a écrit :
>> Hello all:
>> It was not successful when I install on Eclipse 3.5 Galileo RC1 and RC2.
>> I have been update site from --All Available Sites--'s SOA
>> Development, "Web,XML,and Java....." items then I have prepare Tuscany
>> lib too.
>>
>> But when it install finished, I wanna try to use Restaurant by SCA
>> Example, but only Restaurant.composite and
>> Restaurant.composite_diagram were error.
>>
>> How do I solve it???
>>
Re: How to instal SOA Tool [message #8951 is a reply to message #8930] Mon, 08 June 2009 17:02 Go to previous message
KevinWang is currently offline KevinWangFriend
Messages: 6
Registered: July 2009
Junior Member
yes!my error is "The feature 'mixed' of '' with 2 element values must have
exactly 1 element value."

by the way, I find that news on http://wiki.eclipse.org/STP/SCA_Component

The first news on Latest News item is "RC2 BUILD AVAILABLE! May 27, 2009:
SCA Tools 2.0.0 RC2 for Galileo (and Ganymede) is available. [Soon Update
site for Galileo] - Update site for Ganymede. "

therefore, I using Eclipse 3.4 Ganymede try to use SCA Example now
^______^ then, next wednesday I would like to use Eclipse 3.5 Galileo.

that's all!!!Thank you vary much!!^__________^
Re: How to instal SOA Tool [message #575279 is a reply to message #8868] Mon, 08 June 2009 09:35 Go to previous message
Stephane Drapeau is currently offline Stephane DrapeauFriend
Messages: 198
Registered: July 2009
Senior Member
Kevin,

Which error do you have? have a look in to the error log (Window>Show
view>Error log)
Which update site for SCA Tools are you using?

Stephane Drapeau
Obeo

KevinWang a écrit :
> Hello all:
> It was not successful when I install on Eclipse 3.5 Galileo RC1 and RC2.
> I have been update site from --All Available Sites--'s SOA Development,
> "Web,XML,and Java....." items then I have prepare Tuscany lib too.
>
> But when it install finished, I wanna try to use Restaurant by SCA
> Example, but only Restaurant.composite and Restaurant.composite_diagram
> were error.
>
> How do I solve it???
>
Re: How to instal SOA Tool [message #575284 is a reply to message #8911] Mon, 08 June 2009 15:15 Go to previous message
Stephane Drapeau is currently offline Stephane DrapeauFriend
Messages: 198
Registered: July 2009
Senior Member
Kevin,

Is this your error?: "The feature 'mixed' of '' with 2 element values
must have exactly 1 element value."
This error will be fixed in the next version of SCA Tools (next wednesday).
Currently, you can ignore it. The composite file can be deployed with
Tuscany.

Regards,

Stephane Drapeau
Obeo

Stephane Drapeau a écrit :
> Kevin,
>
> Which error do you have? have a look in to the error log (Window>Show
> view>Error log)
> Which update site for SCA Tools are you using?
>
> Stephane Drapeau
> Obeo
>
> KevinWang a écrit :
>> Hello all:
>> It was not successful when I install on Eclipse 3.5 Galileo RC1 and RC2.
>> I have been update site from --All Available Sites--'s SOA
>> Development, "Web,XML,and Java....." items then I have prepare Tuscany
>> lib too.
>>
>> But when it install finished, I wanna try to use Restaurant by SCA
>> Example, but only Restaurant.composite and
>> Restaurant.composite_diagram were error.
>>
>> How do I solve it???
>>
Re: How to instal SOA Tool [message #575295 is a reply to message #8930] Mon, 08 June 2009 17:02 Go to previous message
KevinWang is currently offline KevinWangFriend
Messages: 6
Registered: July 2009
Junior Member
yes!my error is "The feature 'mixed' of '' with 2 element values must have
exactly 1 element value."

by the way, I find that news on http://wiki.eclipse.org/STP/SCA_Component

The first news on Latest News item is "RC2 BUILD AVAILABLE! May 27, 2009:
SCA Tools 2.0.0 RC2 for Galileo (and Ganymede) is available. [Soon Update
site for Galileo] - Update site for Ganymede. "

therefore, I using Eclipse 3.4 Ganymede try to use SCA Example now
^______^ then, next wednesday I would like to use Eclipse 3.5 Galileo.

that's all!!!Thank you vary much!!^__________^
Previous Topic:About SCA Tools question
Next Topic:Extending the SCA Meta Model
Goto Forum:
  


Current Time: Fri Nov 28 06:10:13 GMT 2014

Powered by FUDForum. Page generated in 0.33683 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software