Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit » Egit(Mylyn GitHub Feature Won't Install)
Egit [message #809503] Tue, 28 February 2012 19:08 Go to next message
Mark Figueredo is currently offline Mark Figueredo
Messages: 1
Registered: February 2012
Junior Member
I keep getting the following error when trying to install the GitHib Connector
from download.eclipse.org/egit/github/updates-nightly . I have egit 1.3 installed.


Cannot complete the install because one or more required items could not be found.
Software being installed: Eclipse EGit Mylyn GitHub Feature 2.0.0.201202180002 (org.eclipse.mylyn.github.feature.feature.group 2.0.0.201202180002)
Missing requirement: Mylyn GitHub Connector Core 2.0.0.201202180002 (org.eclipse.mylyn.github.core 2.0.0.201202180002) requires 'package org.eclipse.egit.core [2.0.0,2.1.0)' but it could not be found
Cannot satisfy dependency:

Thanks!
Re: Egit [message #809506 is a reply to message #809503] Tue, 28 February 2012 19:09 Go to previous messageGo to next message
Kevin Sawicki is currently offline Kevin Sawicki
Messages: 47
Registered: September 2011
Member
The GitHub Mylyn connector 2.0 requires EGit/JGit 2.0.

EGit nightlies are available from: http://download.eclipse.org/egit/updates-nightly
Re: Egit [message #810196 is a reply to message #809506] Wed, 29 February 2012 15:35 Go to previous messageGo to next message
Guikubi Vanwoerkom is currently offline Guikubi Vanwoerkom
Messages: 4
Registered: February 2012
Junior Member
Is the repository broken, every time I try to install Egit 2.0 using that repo, I get an error (see below). I've tried both with Indigo 3.7.2 and Juno 4.2.0.

An error occurred while collecting items to be installed
session context was:(profile=SDKProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Multiple problems occurred while downloading.
Problems downloading artifact: osgi.bundle,org.eclipse.jgit,2.0.0.201202281711.
Unpacking fails because intermediate file is empty: /tmp/work6543723147355936357/p2.optimizers.incoming7131055264885693052.jar
Problems downloading artifact: osgi.bundle,org.eclipse.jgit,2.0.0.201202281711.
File has invalid content:/tmp/signatureFile3719675089015064221.jar
Invalid content:org/eclipse/jgit/blame/BlameResult.class
The file "org/eclipse/jgit/blame/BlameResult.class" in the jar "/tmp/signatureFile3719675089015064221.jar" has been tampered!
Invalid content:org/eclipse/jgit/ignore/IgnoreNode$MatchResult.class
The file "org/eclipse/jgit/ignore/IgnoreNode$MatchResult.class" in the jar "/tmp/signatureFile3719675089015064221.jar" has been tampered!
Re: Egit [message #810813 is a reply to message #810196] Thu, 01 March 2012 10:34 Go to previous messageGo to next message
Dani Megert is currently offline Dani Megert
Messages: 3801
Registered: July 2009
Senior Member
On 29.02.2012 21:35, Guikubi Vanwoerkom wrote:
> Is the repository broken, every time I try to install Egit 2.0 using
> that repo, I get an error (see below). I've tried both with Indigo
> 3.7.2 and Juno 4.2.0.
>
> An error occurred while collecting items to be installed
> session context was:(profile=SDKProfile,
> phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=,
> action=).
> Multiple problems occurred while downloading.
> Problems downloading artifact:
> osgi.bundle,org.eclipse.jgit,2.0.0.201202281711.
> Unpacking fails because intermediate file is empty:
> /tmp/work6543723147355936357/p2.optimizers.incoming7131055264885693052.jar
> Problems downloading artifact:
> osgi.bundle,org.eclipse.jgit,2.0.0.201202281711.
> File has invalid content:/tmp/signatureFile3719675089015064221.jar
> Invalid content:org/eclipse/jgit/blame/BlameResult.class
> The file "org/eclipse/jgit/blame/BlameResult.class" in the jar
> "/tmp/signatureFile3719675089015064221.jar" has been tampered!
> Invalid content:org/eclipse/jgit/ignore/IgnoreNode$MatchResult.class
> The file "org/eclipse/jgit/ignore/IgnoreNode$MatchResult.class" in the
> jar "/tmp/signatureFile3719675089015064221.jar" has been tampered!

It also fails for me, see https://bugs.eclipse.org/372942

Dani
Re: Egit [message #810932 is a reply to message #810813] Thu, 01 March 2012 12:48 Go to previous messageGo to next message
Guikubi Vanwoerkom is currently offline Guikubi Vanwoerkom
Messages: 4
Registered: February 2012
Junior Member
Oh, looks like it's working just now! I guess bug reports are more efficient, eh? Thanks!
Re: Egit [message #811704 is a reply to message #810932] Fri, 02 March 2012 13:10 Go to previous messageGo to next message
R Shapiro is currently offline R Shapiro
Messages: 386
Registered: June 2011
Senior Member
Broken again -- same form, different details:

An error occurred while collecting items to be installed
session context was:(profile=epp.package.java, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Multiple problems occurred while downloading.
Problems downloading artifact: osgi.bundle,org.eclipse.jgit,2.0.0.201203021103.
Unpacking fails because intermediate file is empty: /var/folders/j7/d8kbkjzn6ts199zznwqs2_50000lhn/T/work7158274065140896602/p2.optimizers.incoming1709215186868909766.jar
Problems downloading artifact: osgi.bundle,org.eclipse.jgit,2.0.0.201203021103.
File has invalid content:/var/folders/j7/d8kbkjzn6ts199zznwqs2_50000lhn/T/signatureFile6856372969132931619.jar
Invalid content:org/eclipse/jgit/blame/ReverseWalk$ReverseCommit.class
The file "org/eclipse/jgit/blame/ReverseWalk$ReverseCommit.class" in the jar "/var/folders/j7/d8kbkjzn6ts199zznwqs2_50000lhn/T/signatureFile6856372969132931619.jar" has been tampered!
Invalid content:org/eclipse/jgit/blame/BlameGenerator.class
The file "org/eclipse/jgit/blame/BlameGenerator.class" in the jar "/var/folders/j7/d8kbkjzn6ts199zznwqs2_50000lhn/T/signatureFile6856372969132931619.jar" has been tampered!
Re: Egit [message #819667 is a reply to message #811704] Tue, 13 March 2012 03:15 Go to previous message
Matthias Sohn is currently offline Matthias Sohn
Messages: 541
Registered: July 2009
Senior Member
pack200 stopped working for jgit so we disabled pack200 packing, installation should work again
Previous Topic:EGit pull results in NPE
Next Topic:Setting up Synchronisation with Remote Repository
Goto Forum:
  


Current Time: Wed Jul 23 14:17:44 EDT 2014

Powered by FUDForum. Page generated in 0.02286 seconds