Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Problem with ViewStack org.eclipse.rap.design.example.stack.view
Problem with ViewStack org.eclipse.rap.design.example.stack.view [message #808525] Mon, 27 February 2012 21:52 Go to next message
Thorsten Schlathölter is currently offline Thorsten SchlathölterFriend
Messages: 211
Registered: February 2012
Location: Düsseldorf
Senior Member
Hi,
i am trying to get a RAP project running which I have created starting with a New Plugin Project - "RAP Mail Template". The template creates a configuration that makes use of the BusinessPresentationFactory (org.eclipse.rap.design.example.business.factory). So far everything works just fine. I have added a new View by simpy duplicating the Message View of the application. I have added this new View to the ViewStack in the RAP Perspective.

...	
layout.addStandaloneView(NavigationView.ID,  false, IPageLayout.LEFT, 0.25f, editorArea);
		IFolderLayout folder = layout.createFolder("messages", IPageLayout.TOP, 0.5f, editorArea);
		folder.addPlaceholder(View.ID + ":*");
		folder.addView(View.ID);
		folder.addPlaceholder(View2.ID + ":*");
		folder.addView(View2.ID);
...	


And this is where the trouble starts. Whenever I try to activate this new view in the stack I get the following Message:

Could not evaluate javascript response:

Error: Could not apply border to child [object org.eclipse.swt.widgets.Composite] VML._copyData: source or target missing!

  Script: var wm = org.eclipse.swt.WidgetManager.getInstance();wm.dispose
......


If I remove the defaultStackPresentation attribute from the Business Presentation Factory, a default stackPresentation is used which doesn't fit the rest of the presentation but works. So the problem seems to be related to the org.eclipse.rap.internal.design.example.stacks.ViewStackPresentation.

I am using Eclipse 3.7 with the RAP Platform 1.4.1.20110914-1945

Any hints/thoughts would be appreciated since - comming from the RCP side - I haven't got the faintest idea where to start digging.

Regards,
Thorsten
Re: Problem with ViewStack org.eclipse.rap.design.example.stack.view [message #808900 is a reply to message #808525] Tue, 28 February 2012 09:12 Go to previous messageGo to next message
Thorsten Schlathölter is currently offline Thorsten SchlathölterFriend
Messages: 211
Registered: February 2012
Location: Düsseldorf
Senior Member
I have found this message in the forum

#797886

Discussing a similar Error message, namely: VML._copyData: source or target missing

There it is stated, that this error only occurs on IE8. I have checked with firefox and indeed I have no problems with firefox.
Re: Problem with ViewStack org.eclipse.rap.design.example.stack.view [message #809141 is a reply to message #808900] Tue, 28 February 2012 14:22 Go to previous message
Thorsten Schlathölter is currently offline Thorsten SchlathölterFriend
Messages: 211
Registered: February 2012
Location: Düsseldorf
Senior Member
The latest patch provided with this bug report: Bug 372728 solves the Problem.
Re: Problem with ViewStack org.eclipse.rap.design.example.stack.view [message #809144 is a reply to message #808900] Tue, 28 February 2012 14:22 Go to previous message
Thorsten Schlathölter is currently offline Thorsten SchlathölterFriend
Messages: 211
Registered: February 2012
Location: Düsseldorf
Senior Member
The latest patch provided with this bug report: Bug 372728 solves the Problem.
Previous Topic:Components RAP development
Next Topic:Close shell from within browser widget
Goto Forum:
  


Current Time: Fri Nov 28 01:47:56 GMT 2014

Powered by FUDForum. Page generated in 0.01749 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software