Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » [solved] NullPointerException Platform.getOS( ) in Standalone App
[solved] NullPointerException Platform.getOS( ) in Standalone App [message #805241] Thu, 23 February 2012 09:38 Go to next message
Frog Manhome is currently offline Frog Manhome
Messages: 5
Registered: January 2012
Junior Member
Hello,

I try to integrate the ChartWizard in a standalone application. But it crashes with a NullPointerException during a DragEnter Event.
I think the Problem is in the validation of DataTextDropListener

if ( Platform.OS_WIN32.equals( Platform.getOS( ) ) )

How can I fix this or register the Platform Object? I'm using BIRT 3.7.

Thank you.

Edit:
I solved the Problem:
I run the application as a Java Application, this was the fault.

Now I run the Application as RCP (Eclipse Application).

Only if you run the ChartWizardLauncher as an RCP or OSGI the Platform object is set, else it will throw the NullPointer. Now it works.

Thanks for help.

[Updated on: Wed, 29 February 2012 06:56]

Report message to a moderator

Re: NullPointerException Platform.getOS( ) in Standalone App [message #805304 is a reply to message #805241] Thu, 23 February 2012 11:00 Go to previous messageGo to next message
Frog Manhome is currently offline Frog Manhome
Messages: 5
Registered: January 2012
Junior Member
Found this bugs.eclipse.org/bugs/show_bug.cgi?id=318724
But this was for 2.5.1. Is there a resolve?

(Can't post links until I have posted more than 5 messages)
Re: NullPointerException Platform.getOS( ) in Standalone App [message #805520 is a reply to message #805304] Thu, 23 February 2012 16:31 Go to previous message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Take a look at this thread:
http://www.eclipse.org/forums/index.php/t/281695/

Example is still not complete but may help.

Jason

On 2/23/2012 11:00 AM, Frog Manhome wrote:
> Found this bugs.eclipse.org/bugs/show_bug.cgi?id=318724
> But this was for 2.5.1. Is there a resolve?
>
> (Can't post links until I have posted more than 5 messages)
Previous Topic:Linkage Error Seam, JBoss, BIRT
Next Topic:Not Getting Sequence order when use 'Y' Optional Grouping
Goto Forum:
  


Current Time: Wed Aug 20 08:50:50 EDT 2014

Powered by FUDForum. Page generated in 0.02291 seconds